You are not logged in.

#26 2016-10-21 02:11:56

Bearded_Blunder
Dodging A Bullet
From: Seat: seat0; vc7
Registered: 2015-09-29
Posts: 730

Re: The oldest machine running Bunsenlabs with/without hiccups?

I did have Bunsen on an old Compaq N200 P3 700MHz laptop with 192MB of RAM until recently, I wouldn't claim it ran "without hiccups" though, as useable browsers require processor instruction sets that old P3 mobile didn't support, I used it to play music mostly, until the power switch broke off, plastic parts for a laptop that age being unobtainable, and the part being too small to easily fabricate, it got consigned to the recyclers.

I miss it thouugh, was my first laptop, and accompanied me on a trip to the other side of the world.

I do have an even older machine I could experiment with, if i had the time and inclination to turn this thread into a competition.


Blessed is he who expecteth nothing, for he shall not be disappointed...
If there's an obscure or silly way to break it, but you don't know what.. Just ask me

Offline

#27 2016-10-21 06:31:14

nore
>2⁹
From: squirrels' nest
Registered: 2015-09-29
Posts: 513

Re: The oldest machine running Bunsenlabs with/without hiccups?

blinco wrote:

This isn't a very productive machine by today's standards

...and yet we used to do productive work with them back then: Netscape surfing and webpage editing, writing with WordPerfect or LaTeX, presentations with Harvard Graphics, spreadsheet in Lotus 123, even basic photo editing. All that in wacky Windows 95. We can't use those same machines in the same way anymore (except writing code in text editor), and that is called progress.

blinco wrote:

but it does encourage using the command line, which teaches a lot about how Linux works.

That's the spirit, blinco. What kind of monitor have you connected to that beast?

Offline

#28 2017-01-03 17:51:49

chris667
Member
Registered: 2017-01-03
Posts: 11

Re: The oldest machine running Bunsenlabs with/without hiccups?

My main machine up until recently was an Asus EEEPC 4G. 2GB ram, single core Celeron processor at 633Mhz and a 16gb hard disk. I was running nonPAE Bunsenlabs on it which was fine.

It was perfectly OK for web browsing and writing. I acquired a much more modern Lenovo at Christmas which will replace it though.

Offline

#29 2017-03-26 02:24:54

fishesandloaves
New Member
From: Central Ohio USA
Registered: 2017-03-26
Posts: 2

Re: The oldest machine running Bunsenlabs with/without hiccups?

Mine are not the oldest, but they are certainly on the limited functionality end of things, as most people would believe. I have two netbooks that I use for puttering around with BL: (1) Asus Eee PC 1015PX (Atom N570) and (2) Asus 1025C (Atom 2600). The 1015PX had Crunchbang Waldorf on it previously. I have a Lenovo S10-3 (Atom N455) that I haven't loaded yet, a cast-off from a coworker, but it isn't that different from another Eee PC that I had, so I know it'll run fine. Netbooks make great BL machines.

Offline

#30 2018-05-20 09:15:32

ghorvath
Member
Registered: 2015-10-01
Posts: 142

Re: The oldest machine running Bunsenlabs with/without hiccups?

Ok, let me revive this thread now, when bl-Helium is out. :-) Since debian stretch (and therefore bl-Helium) does not support i586, anymore, there is a chance to steal the prize from blinco. :-)

Anyway, I managed to install bl-Helium on my approx. 18-20 years old Acer Travelmate 210 (Pentium Celeron 700 MHz, 512 MB RAM, 10GB ATA HDD, Linksys Combe PCMCIA 10 Mbit/s network card, still has the BNC connector!). USB boot is of course not supported, so needed to add a new menuentry to the old GRUB like explained here: https://forums.bunsenlabs.org/viewtopic.php?id=4147

The first boot was extremely slow, but the second one was ok, at least comparable to previous boots of Crunchbang. Before, I tried to install bl-Hydrogen on it, and even pure debian jessie, but somehow the grahics did not load, and needed to go back to CB. But apparently, bl-Helium now recognized the hardware properly, and it works, even if it is slow.

CLI, however, is still more or less snappy, uses only <50 MB memory after boot. I am rather surprised (and happy) that I managed to revive this machine with a very recent distro, even more so because wheezy LTS support ends in two weeks.

BTW, I use it in the basement to listen to music. And of course I only did it to check whether or not it is possible :-). E.g. Raspberry Pi has far more processing power than this machine.

Offline

#31 2018-05-20 15:11:18

DeepDayze
Like sands through an hourglass...
From: In Linux Land
Registered: 2017-05-28
Posts: 996

Re: The oldest machine running Bunsenlabs with/without hiccups?

lcafiero wrote:

I think blinco probably wins the thread. I use BL daily on a 64-bit machine, but my 32-bit BL hardware is an IBM ThinkPad T42, circa 2005ish, maxed out at 2GB RAM. It runs well.

I have that same exact Thinkpad T42 with same configuration (but upgraded the CPU to a 2.1 GHz Pentium-M) and I use it as a netbook that I take with me when I travel. Videos play well if I set the governor to performance. Originally it had AntiX on it, I wiped it and put BL Helium on and it runs like a champ.


Real Men Use Linux

Offline

#32 2019-05-23 17:52:34

Huldalumi
Member
From: Finland
Registered: 2019-05-15
Posts: 25

Re: The oldest machine running Bunsenlabs with/without hiccups?

esprimo mobile v5535
-Computer-
Processor        : Intel(R) Celeron(R) CPU          540  @ 1.86GHz
Memory        : 765MB (413MB used)
Operating System        : BunsenLabs GNU/Linux 9.8 (Helium)

I'm not sure what minimum spec is but I must be only just with in and it runs a little slow at times but its still faster than when it was windows XP


yeah,well, thats just like, your opinion man
The Dude

Offline

#33 2019-05-23 20:07:20

Wismut
Member
Registered: 2018-12-07
Posts: 23

Re: The oldest machine running Bunsenlabs with/without hiccups?

A bit OT: Managed to get OpenBSD 6.4 running on an old PowerBook G4 from 2003 with 1 GHz PowerPC processor and 512 MB RAM. Mac OS X wouldn't boot anymore, so I tried different alternative operating systems (not that there are a lot, I think there are only two linux distributions left supporting PowerPC) and found OpenBSD to work the best. After installing X, tint2, Openbox, conky and feh, it uses ~90 MB when freshly booted and looks partly like bunsenlabs and is usable for browsing the web. Unfortunately, a lot of drivers are missing (no sound, no backlit keyboard, can't change screen brightness etc.). The biggest downside is the lack of binaries for powerpc, so that there is almost no software that still runs on this nice-looking machine. Compiling would take too long and almost certainly would fill the internal hard drive in an instant (apart from the big vs. little endian problem). So due to the processor's architecture, it's almost unusable even though it is newer than some of the machines mentioned here.

Offline

#34 2019-05-31 09:49:29

Colonel Panic
Member
Registered: 2018-11-13
Posts: 181

Re: The oldest machine running Bunsenlabs with/without hiccups?

2006 machine here (a Packard Bell IMedia machine with a single core AMD 3800+ processor, 4GB of RAM and a 250 GB hard drive). Not the oldest but all the same it runs Bunsen just fine.

Offline

#35 2019-09-29 02:27:03

Mardus
Member
From: Estonia
Registered: 2019-05-03
Posts: 17

Re: The oldest machine running Bunsenlabs with/without hiccups?

I have an hp Pavilion dv5000 (dv5204ea), with Intel Celeron M 410 running at 1.46 GHz and 1 Gb of RAM memory, and a BIOS date from 13.06.2006., so the computer is 13 years old.

I use the CD version of BunsenLabs Helium as a LiveCD, and due to limited RAM memory, prefer that over the DVD variant.

NoScript is a huge amount of help when browsing the web, but YouTube is impossible to use with 1 Gb of RAM when BL is run from a LiveCD. In my experience, the LiveCD experience of YouTube is good with at least 2 Gb RAM and a dual-core CPU.

BunsenLabs (BL) meets several requirements:

  • LiveCD (not DVD), so uses less memory;

  • Small memory footprint;

  • Based on Debian, so is also compatible with Ubuntu;

  • Can run X, with only a window manager;

  • Touchpad and pointer drivers must work reliably;

  • Has modern Firefox.

  • Bonus point: SystemD allows me to limit the memory Firefox can use.

BunsenLabs is one of the few that offers all that. I have a Knoppix 7.2 liveCD, but it's from 2013, is very old, has unreliable pointer drivers, and installing ID card software was cumbersome, and worked partially; I was only able to login and check my bank balance, but not make any transfers.

Ubuntu compatibility and modern Firefox are required for the latest supported software that uses the Estonian ID card. Upon tweaking the installation script, it installs the ID card software and a Firefox extension (both meant for Ubuntu Xenial) that helps with authentication and making electronic signatures online.

The Estonian ID card is a smart card and an identification document that's used for electronic authentication and electronic signing; it's used to access banks and make money transfers; to sign official documents (incl. contracts); to access government services, to conduct business and communications with the government; to vote online in local, general, and EU elections (expat or traveling Estonians can vote anywhere in the world, if they have the kit); to encrypt files, usually for transfer, to ensure high message secrecy; to remove oneself from party membership, and lots more. The ID card is a valid travel document within the European Union.

Estonia adopted the ID card system in 2002, but I got my first ID card in 2009, seven years after adoption. Until then, I used a passport, mostly to identify my person during elections, and when taking cash to the bank.

So, a year ago, after my bank stopped using non-electronic code cards (those with written numerical codes) for two-factor authentication, I finally got an ID card reader — nine years after I got my first ID card (I'm on a second one), and sixteen years after ID card readers became a thing in Estonia.

With some effort, it's possible to install Estonian ID card software meant for Ubuntu, so I could login into my bank and make transfers. Unfortunately, the ID card management software does not yet work properly. But I could vote! — Because the voting program is a separate package.

I'm not a luddite when it comes to technology, but am one of those who gets personal access to interesting stuff and technology much later than my reference group. Because reasons, but that's life, I guess.

So, in Autumn and Winter of 2018, BunsenLabs was essential just so I could check my bank balance at home, and make transfers.

The day-to-day need to use BunsenLabs waned in January 2019. On Christmas 2018, a relative got a new smartphone, and I asked for their old smartphone, explaining, that I could upgrade that old smartphone from Android 4.0.3 to Android 4.1.2, and install Smart-ID — so I could easily access my bank when in transit. Android 4.1 is the oldest version still supported by the Smart-ID app. The relative was convinced, and I got their old smartphone.

My earlier smartphone runs Android 2.3.6, and does not have any more upgrades available. Furthermore, in December 2018, the YouTube app also stopped working on Gingerbread. (There, the default browser would render the mobile YouTube page and thus allow playback in an external player until September 2019.)

Smart-ID is a new two-factor authentication system and app in Estonia and Latvia.

There is also Mobile ID (Mobiil-ID). It's equivalent to the ID card, and supports absolutely all kinds of phones, even featurephones dating back to early 2000s and even a bit before. One can vote with Mobile ID, but not with Smart ID. But — Mobile ID requires a phone contract and a specialized and more expensive SIM card, and is not exactly free, as it requires a small and regular fee.

Whereas Smart-ID is completely free, but has support for less services.

Now, this newer device I got, is LG Optimus L5, which series was released in June 2012, a few months later than my Gingerbread phone.

I really didn't know if I could upgrade the LG phone from ICS to Jelly Bean; while information about upgrade possibility was up, off-the-air upgrades stayed within Android 4.0.3. This meant that I had to check if there was a computer-based upgrade possible.

At first sight, LG's official site had software available that would run on Windows 7 or greater, while I have Windows XP. Fortunately, LG's Australian section offered packages compatible with Windows XP, enabling me to make a backup of device data, and perform the upgrade to Android 4.1.2. Yay!

Getting Smart-ID registered still required use of the ID card, so BunsenLabs came in handy again.

I could login into my bank again. Yay!

As a result of installing registering Smart-ID, I could download my bank's app that just happens to also have Android 4.1 as the earliest supported Android, so with some effort (because this phone's RAM is only 512 Mb), I used Smart-ID to register my bank's app. My bank's app is crashy for most things, but at least allows me to check the balance quickly.

LG Optimus L5 has the same CPU and RAM specs as the phone with Gingerbread (Samsung Galaxy Mini 2), but sports a 5-megapixel camera with auto-focus and flash, while the Samsung smartphone has only a 3.15 Mpix sensor with just fixed-focus and without flash. This is really an upgrade to me, as the LG phone is able to scan more detailed QR codes, which has come in very handy.

Coincidentally, Android 4.1 is also the earliest/oldest Android supported by the Estonian online vote verification app, which scans a QR code displayed by the voting app in the computer after a user has finished voting. For some technical reason, the app wouldn't work as intended during the Estonian Parliament elections in March 2019. It's very possible, that the QR code to verify a person's vote has a very short lifetime. The app worked flawlessly during European Parliament elections in May 2019.

Last edited by Mardus (2019-09-29 09:03:32)

Offline

#36 2019-09-29 08:52:00

ohnonot
...again
Registered: 2015-09-29
Posts: 4,926
Website

Re: The oldest machine running Bunsenlabs with/without hiccups?

That's ... interesting.
I'm glad my bank still uses those 2FA codes on paper, and I'm also otherwise not depending on any ID apps.
And I would hate having to faff around with such old Android versions - well, I hate faffing around with any Android version neutral

Mardus wrote:

NoScript is a huge amount of help when browsing the web, but YouTube is impossible to use with 1 Gb of RAM when BL is run from a LiveCD.

You should try youtube-dl + mpv instead of the browser's heavy HTML5.


BL quote proposals to this thread please.
my repos / my repos

Offline

#37 2019-09-29 09:13:39

Mardus
Member
From: Estonia
Registered: 2019-05-03
Posts: 17

Re: The oldest machine running Bunsenlabs with/without hiccups?

ohnonot wrote:

I'm glad my bank still uses those 2FA codes on paper,

The paper/card based manual 2FA codes were withdrawn because of security issues, such as phishing attacks that used social engineering. Now, the only non-ID systems are code calculators, but there is a non-trivial one-time cost to obtaining these.

Back when my bank maintained a site that supported older browsers, I was able to login into my account with a code card using just Lynx. Fun times.

Last edited by Mardus (2019-09-29 09:19:26)

Offline

#38 2020-07-18 18:25:56

rickster1006
Member
Registered: 2018-05-08
Posts: 11

Re: The oldest machine running Bunsenlabs with/without hiccups?

So, I’m an admitted frequent district hopper, & always come back to BunsenLabs Linux. It’s extremely fast & incredibly reliable. That said, I’ve resurrected my old HP Pavilion DV-8000 & currently running Helium on it. I bought this laptop new back in 2006 & it’s built like a tank. It’s got 2GB of ram, 2 EIDE drives, & a full size keyboard. The keyboard can be a little cranky, but my only quibble is that it’s not backlight. As much as I love this laptop, I’m feeling like it’s time for retirement.  The processor is an AMD64 Turion (ML-37) & believe it’s vulnerable to Specter or Meltdown. When the system boots, I see the message: 
Spectre V2:  Spectre mitigation:  LFENCE not serializing, switching to generic retpoline. 
I ran the meltdown checker, & seems like some of the output is contradictory. Meaning, all the checks end with “your cpu vendor reported your cpu model is not vulnerable.”  This doesn’t inspire confidence.
Any thoughts or suggestions would be greatly appreciated.
-Rick

Offline

#39 2020-07-18 21:23:49

twoion
ほやほや
Registered: 2015-08-10
Posts: 2,963

Re: The oldest machine running Bunsenlabs with/without hiccups?

^ From a cursory search it seem like your Turion is from the AMD Lancaster family of CPUs which is not on the list of vulnerable CPUs https://www.techarp.com/guides/complete … pu-list/3/ from AMD, and the list includes CPUs even older.

The message about the retpoline is not an error; LFENCE is a x86 instruction that can be used for a more efficient implementation of a  kernel-level spectre mitigation strategy, this just says that it can't use that efficient version, so it falls back on a generic more in-efficient / slower implementation. It depends on the combination of feature flags your processor supports, see this old thread here https://bbs.archlinux.org/viewtopic.php … 0#p1774980 .

You can get the direct info what Linux thinks by running

grep . /sys/./devices/system/cpu/vulnerabilities/*

on a recent enough kernel.

As for the risk: I have all spectre and meltdown mitigations manually disabled on my daily driver Linux system because on my Haswell CPU from 2013/14, it'd kill the performance and render the device unusable. In your case, I'd probably just do the same and continue rolling. Mitigations have already landed in web browsers which should be the most important vector of attack today; I can live with that.

That being said I do take the specture/meltdown/l1tf class issues very serious in the server landscapes at work that use virtualization to isolate business-critical and sensitive processes against each other, but at home? not worth it (because of the performance penalty -- I'd effectively have to buy new hardware immediately). I'd say that today (after all the measures taken), the risk of spectre/meltdown class vulnerabilities on the random Linux PC at home is insiginificant when compared to other classes of exploits that affect e.g. web browsers.


Per aspera ad astra.

Offline

#40 2020-07-19 08:24:12

ohnonot
...again
Registered: 2015-09-29
Posts: 4,926
Website

Re: The oldest machine running Bunsenlabs with/without hiccups?

@rickster1006: 2006 sounds about right. I seem to remember that for intel processors the threshold was 2008 because I was sad that my old laptop was just about "new" enough to be affected by spectre/meltdown.

Trenton wrote:

I can't find the link but someone done some calculations of the amount of electricity that gets used per year when running old hardware and it was cheaper (and gave more performance per watt) to run either a NUC or a Raspberry.

From what i can remember the Raspberry payed for itself within a year and the NUC was 2 to 3 years depending on what model you purchased.

...and again you're trolling.
But I'll bite anyhow:
Compared to what? A raspi to a laptop? That would make little to no sense if you don't take into account the peripherals: 2 hard drives, a 14" screen, a keyboard... I'm pretty sure the raspi cannot run these without additional power supply.
And also take into account the cost of production, purchase and shipping.
Then we'll talk, so I suggest you come up with that link or some other useful information.


BL quote proposals to this thread please.
my repos / my repos

Offline

#41 2020-07-19 11:12:01

Mardus
Member
From: Estonia
Registered: 2019-05-03
Posts: 17

Re: The oldest machine running Bunsenlabs with/without hiccups?

Trenton, you might already know this, but

$ /cat/proc/cpuinfo

shows the names of vulnerabilities, too. Though it does not show if they have been mitigated; just if a CPU vulnerability exists in the silicon you have.

I'm not certain about this, but if memory serves, BunsenLabs has the GUI-based hardinfo tool installed by default, but it's not accessible through the default menu. You can launch it from the terminal with

$ hardinfo &

Offline

#42 2020-07-19 12:01:34

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 7,337
Website

Re: The oldest machine running Bunsenlabs with/without hiccups?

Mardus wrote:

...if memory serves, BunsenLabs has the GUI-based hardinfo tool installed by default, but it's not accessible through the default menu.

It doesn't have a dedicated menu slot, but you can find it in the "Applications" submenu > System > System Profiler and Benchmark


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Offline

Board footer

Powered by FluxBB