You are not logged in.

#1 2018-12-29 01:56:55

redrobo66
Member
Registered: 2018-03-18
Posts: 45

Using the 4.18 Kernel - seems too easy!

It's the season to be jolly so I've treated myself to a new PC which will arrive tomorrow smile
A nice new Intel NUC, latest gen coffee lake processor and lots of other goodies such as thunderbolt 3, nvme, Octane support, 3.1 10gb USB, Iris Plus graphics etc.

I could wimp-out and throw a rolling release on there (I rather like Tumbleweed) to get the latest Kernel but I'm very attached to BL and want to continue running it on the new machine, pulling across all of my backed up configs, but I need something newer than 4.9 for the hardware.

looking at the Debian wiki suggests I can use Synaptic to select a new Kernel and install as usual, so I did on my current 2012 Dell by way of experiment - and the system now boots using the 4.18 Kernel and everything seems to work just fine.

Is it really that easy?
Surely I have missed something?

Cheers,

Last edited by redrobo66 (2018-12-29 01:58:38)

Offline

#2 2019-01-05 11:52:31

ohnonot
...again
Registered: 2015-09-29
Posts: 4,016
Website

Re: Using the 4.18 Kernel - seems too easy!

it proabably means you already have backports enabled.
beyond that, yes, it really is that simple.

Offline

#3 2019-08-10 20:59:46

Danrobi
New Member
Registered: 2019-08-10
Posts: 2

Re: Using the 4.18 Kernel - seems too easy!

Hello lucky you, i do not know how you did it but i do not have such option in synaptic. Or i just do not know how.
I cant install steam, i think my kernel too old 4.9

EDit: I managed to install steam but steam doesnt work, says missing: libGL.so.1
But its actually installed already
---Mod edit - added [ code ] tags---

[2019-08-10 18:13:55] Downloading update (349,021 of 350,816 KB)...
[2019-08-10 18:13:55] Downloading update (349,984 of 350,816 KB)...
[2019-08-10 18:13:55] Downloading update (350,816 of 350,816 KB)...
[2019-08-10 18:13:56] Download Complete.
[2019-08-10 18:13:56] uninstalled manifest found in /home/danrobi/.steam/package/steam_client_ubuntu12 (1).
[2019-08-10 18:13:56] Extracting package...
[2019-08-10 18:14:06] Installing update...
[2019-08-10 18:14:06] Cleaning up...
[2019-08-10 18:14:06] Update complete, launching...
[2019-08-10 18:14:06] Shutdown
Running Steam on bunsenlabs 9.8 64-bit
STEAM_RUNTIME is enabled automatically
Pins potentially out-of-date, rebuilding...
Found newer runtime version for 64-bit libdbusmenu-glib.so.4. Host: 4.0.12 Runtime: 4.0.13
Found newer runtime version for 64-bit libmpg123.so.0. Host: 0.42.3 Runtime: 0.44.8
Found newer runtime version for 64-bit libvulkan.so.1. Host: 1.0.39 Runtime: 1.1.73
Found newer runtime version for 64-bit libopus.so.0. Host: 0.5.3 Runtime: 0.7.0
Forced use of runtime version for 64-bit libcurl.so.4. Host: 4.4.0 Runtime: 4.2.0
Found newer runtime version for 64-bit libdbusmenu-gtk.so.4. Host: 4.0.12 Runtime: 4.0.13
Found newer runtime version for 64-bit libGLU.so.1. Host: 1.3.1 Runtime: 1.3.8004
Error: You are missing the following 32-bit libraries, and Steam may not run:
libGL.so.1
WARNING: setlocale('en_US.UTF-8') failed, using locale: 'C'. International characters may not work.
[2019-08-10 18:15:06] Startup - updater built Aug  6 2019 01:02:51
[2019-08-10 18:15:07] Verifying installation...
[2019-08-10 18:15:07] Unable to read and verify install manifest /home/danrobi/.steam/package/steam_client_ubuntu12.installed
[2019-08-10 18:15:07] Verification complete
[2019-08-10 18:15:07] Downloading update...
[2019-08-10 18:15:07] Checking for available updates...
[2019-08-10 18:15:07] Downloading manifest: client-download.steampowered.com/client/steam_client_ubuntu12
[2019-08-10 18:15:07] Download complete.
[2019-08-10 18:15:07] uninstalled manifest found in /home/danrobi/.steam/package/steam_client_ubuntu12 (1).
[2019-08-10 18:15:07] Extracting package...
[2019-08-10 18:15:17] Installing update...
[2019-08-10 18:15:20] Cleaning up...
[2019-08-10 18:15:20] Update complete, launching Steam...
[2019-08-10 18:15:20] Shutdown
Restarting Steam by request...
Running Steam on bunsenlabs 9.8 64-bit
STEAM_RUNTIME has been set by the user to: /home/danrobi/.steam/ubuntu12_32/steam-runtime
Pins up-to-date!
Error: You are missing the following 32-bit libraries, and Steam may not run:
libGL.so.1
WARNING: setlocale('en_US.UTF-8') failed, using locale: 'C'. International characters may not work.
[2019-08-10 18:15:22] Startup - updater built Aug  6 2019 01:02:51
[2019-08-10 18:15:22] Verifying installation...
[2019-08-10 18:15:22] Verification complete
[2019-08-10 18:15:23] Shutdown

I aslo have 64 kept back packages:

~$ sudo apt-get -t stretch-backports upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  btrfs-progs dirmngr dkms e2fslibs e2fsprogs f2fs-tools flatpak gnupg gnupg-agent
  libcomerr2 libdrm-amdgpu1 libdrm-amdgpu1:i386 libdrm2 libdrm2:i386
  libegl-nvidia0 libegl1-mesa libgbm1 libgl1-mesa-dri libgl1-mesa-dri:i386
  libgl1-mesa-glx libgl1-mesa-glx:i386 libgl1-nvidia-glvnd-glx libglapi-mesa
  libglapi-mesa:i386 libgles-nvidia1 libgles-nvidia2 libgles2-mesa libglx-nvidia0
  libgpg-error0 libgpg-error0:i386 libgpgme11 libjavascriptcoregtk-4.0-18
  libnvidia-cfg1 libnvidia-eglcore libnvidia-glcore libnvidia-ml1
  libreoffice-base-core libreoffice-common libreoffice-core libreoffice-gtk2
  libreoffice-writer libss2 libwayland-egl1-mesa libwebkit2gtk-4.0-37
  libxatracker2 linux-headers-amd64 linux-image-amd64 nvidia-alternative
  nvidia-driver nvidia-driver-bin nvidia-driver-libs nvidia-egl-icd
  nvidia-kernel-dkms nvidia-kernel-support nvidia-vdpau-driver nvidia-vulkan-icd
  python-cryptography systemd-sysv uno-libs3 ure wpasupplicant xdg-desktop-portal
  xdg-desktop-portal-gtk xserver-xorg-video-nvidia
0 upgraded, 0 newly installed, 0 to remove and 64 not upgraded.

Last edited by damo (2019-08-11 10:08:21)

Offline

#4 2019-08-11 07:28:25

ohnonot
...again
Registered: 2015-09-29
Posts: 4,016
Website

Re: Using the 4.18 Kernel - seems too easy!

Danrobi wrote:

Error: You are missing the following 32-bit libraries, and Steam may not run:
libGL.so.1

it says rather clearly that you need the 32-bit version.
If your computer is 64bit, you need to install that separately.
https://wiki.debian.org/Steam

I aslo have 64 kept back packages:
~$ sudo apt-get -t stretch-backports upgrade

Doesn't this mean that ALL packages will be upgraded to their backport versions?
I really do not think one should do it like this.

But I'll leave this one to Debianites better than I.

Offline

#5 2019-08-12 02:10:00

bigbenaugust
Member
From: unc.edu / the 919 / KIGX
Registered: 2017-05-20
Posts: 167

Re: Using the 4.18 Kernel - seems too easy!

That's not normally recommended -- unless you like to live dangerously.

I've always updated from backports on an as-desired basis (kernel, openoffice, ffmpeg, etc.) and never en masse.


--Ben
BL / MX / Raspbian... and a whole bunch of RHEL boxes. :)

Offline

#6 2019-08-12 05:01:25

ohnonot
...again
Registered: 2015-09-29
Posts: 4,016
Website

Re: Using the 4.18 Kernel - seems too easy!

^ yes but what we the right way to upgrade
a) all packages installed normally to their newest stable versions
b) all packages installed from backports to their newest backport versions
???
(assuming that's what op really wanted)

Offline

#7 2019-08-12 13:51:52

bigbenaugust
Member
From: unc.edu / the 919 / KIGX
Registered: 2017-05-20
Posts: 167

Re: Using the 4.18 Kernel - seems too easy!

This is what I've been doing:

sudo apt install -t stretch-backports foo

(where foo is usually one of linux-image-4.19 or libreoffice)
and then letting apt handle the dependencies.


--Ben
BL / MX / Raspbian... and a whole bunch of RHEL boxes. :)

Offline

#8 2019-08-12 14:08:04

BLizgreat!
Resident Babbler - vll!
Registered: 2015-10-03
Posts: 1,019

Re: Using the 4.18 Kernel - seems too easy!

Personally would try going newer just to see if there's any performance benefits in newer kernel's. Check what's available in backports for your release. Try some, nothing wonderful in them would pull in a later kernel from sid or whatever. Might want to do a backup beforehand just in case. Congrats on the new shiny and high spec system.

Offline

#9 2019-08-12 20:16:47

ohnonot
...again
Registered: 2015-09-29
Posts: 4,016
Website

Re: Using the 4.18 Kernel - seems too easy!

bigbenaugust wrote:

This is what I've been doing:

sudo apt install -t stretch-backports foo

(where foo is usually one of linux-image-4.19 or libreoffice)
and then letting apt handle the dependencies.

Yes but how would you run a full system upgrade that honours stable, but also installed backported packages' newest versions? Is it possible to do that in one go?

Offline

#10 2019-08-13 06:01:15

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 5,851
Website

Re: Using the 4.18 Kernel - seems too easy!

ohnonot wrote:
bigbenaugust wrote:

This is what I've been doing:

sudo apt install -t stretch-backports foo

(where foo is usually one of linux-image-4.19 or libreoffice)
and then letting apt handle the dependencies.

Yes but how would you run a full system upgrade that honours stable, but also installed backported packages' newest versions? Is it possible to do that in one go?

Possible, but not at all recommended because backports aren't as reliable as regular repo releases.

If you really wanted to do it anyway (for experimental purposes presumably) you need to change the apt pinning of the backports repo from its Debian default of 100 to the same as the main repo, 500. Run 'apt-cache policy' to see the current situation.

Now go read about pinning:
https://wiki.debian.org/AptPreferences
https://www.gilesorr.com/blog/debian-ba … kages.html

But why not just upgrade to Testing?


John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
In case you forget, the rules.

Offline

#11 2019-08-13 20:04:56

ohnonot
...again
Registered: 2015-09-29
Posts: 4,016
Website

Re: Using the 4.18 Kernel - seems too easy!

johnraff wrote:

But why not just upgrade to Testing?

You jest?
Isn't "Stable + a few select backported packages" a very different thing than "Testing"?

Offline

#12 2019-08-14 03:02:13

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 5,851
Website

Re: Using the 4.18 Kernel - seems too easy!

^I wasn't jesting, but clearly I misunderstood what you were asking.

ohnonot wrote:
bigbenaugust wrote:

This is what I've been doing:

sudo apt install -t stretch-backports foo

(where foo is usually one of linux-image-4.19 or libreoffice)
and then letting apt handle the dependencies.

Yes but how would you run a full system upgrade that honours stable, but also installed backported packages' newest versions?

I took this as meaning you wanted to upgrade every package on your system to the latest backport version, if available.

But, looking earlier:

ohnonot wrote:

what we the right way to upgrade
a) all packages installed normally to their newest stable versions
b) all packages installed from backports to their newest backport versions

This is so simple I just presumed that couldn't be what you were asking.

sudo apt-get update
sudo apt-get upgrade

...will do exactly that.

It just happens that I have devscripts on my Stretch system, from stretch-backports:

john@helium:~$ sudo apt-get update
[sudo] password for john: 
Ign:1 https://cdn-aws.deb.debian.org/debian stretch InRelease
Get:2 https://cdn-aws.deb.debian.org/debian-security stretch/updates InRelease [94.3 kB]
Hit:4 https://cdn-aws.deb.debian.org/debian stretch-updates InRelease
Hit:3 https://asia.pkg.bunsenlabs.org/debian stretch-backports InRelease
Hit:6 https://asia.pkg.bunsenlabs.org/debian helium InRelease
Hit:5 https://cdn-aws.deb.debian.org/debian stretch-backports InRelease
Hit:7 https://cdn-aws.deb.debian.org/debian stretch Release
Fetched 94.3 kB in 2s (39.9 kB/s)
Reading package lists... Done
john@helium:~$ apt-cache policy devscripts
devscripts:
  Installed: 2.19.5~bpo9+1
  Candidate: 2.19.5+deb10u1~bpo9+2
  Version table:
     2.19.5+deb10u1~bpo9+2 100
        100 https://deb.debian.org/debian stretch-backports/main amd64 Packages
 *** 2.19.5~bpo9+1 100
        100 /var/lib/dpkg/status
     2.17.6+deb9u2 500
        500 https://deb.debian.org/debian stretch/main amd64 Packages
john@helium:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
  devscripts
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,046 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] 
Get:1 https://cdn-aws.deb.debian.org/debian stretch-backports/main amd64 devscripts amd64 2.19.5+deb10u1~bpo9+2 [1,046 kB]
Fetched 1,046 kB in 5s (176 kB/s)     
Reading changelogs... Done
(Reading database ... 280180 files and directories currently installed.)
Preparing to unpack .../devscripts_2.19.5+deb10u1~bpo9+2_amd64.deb ...
Unpacking devscripts (2.19.5+deb10u1~bpo9+2) over (2.19.5~bpo9+1) ...
Setting up devscripts (2.19.5+deb10u1~bpo9+2) ...
Processing triggers for man-db (2.7.6.1-2) ...

So backported packages get upgraded from the backports repo, and others from the regular repo.

Last edited by johnraff (2019-08-14 03:03:07)


John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
In case you forget, the rules.

Offline

#13 2019-08-14 17:49:18

ohnonot
...again
Registered: 2015-09-29
Posts: 4,016
Website

Re: Using the 4.18 Kernel - seems too easy!

johnraff wrote:

This is so simple I just presumed that couldn't be what you were asking.

sudo apt-get update
sudo apt-get upgrade

...will do exactly that.

OK, thanks for clarifying.
Yes, I can be that clueless with anything "advanced" debian; although I do remember now that I had 1 or 2 backported packages on my server when it was still jessie, and they seemed to get updated, too.

Offline

Board footer

Powered by FluxBB