You are not logged in.

#1 2019-04-02 03:27:32

linux_user
Member
Registered: 2016-11-04
Posts: 345

[RESOLVED] Nitrogen doesn't restore wallpaper

All was fine, until something changed.

Nitrogen no longer restores the wallpapers. It restores to a wallpaper that I have used earlier. I have to go to terminal and restore it.

toor@linux:~$ nitrogen --restore
UNKNOWN ROOT WINDOW TYPE DETECTED, will attempt to set via normal X procedure
toor@linux:~$ 

I have read this post about the same, and to clarify few things mentioned in it.

In openbox settings, nitrogen --restore & appears before conky, tint2 and even compositor.

This is the syntax in the config file ~/.config/nitrogen/bg-saved.cfg after I have done the restore through terminal. mask_anonymus_light_85666_1280x1024.jpg is the current wallpaper and anchor_drawing_vector_dark_93570_1280x1024.jpg was the previous wallpaper. But on start up, nitrogen restores to another wallpaper that I had used earlier. None of these two.

[xin_-1]
file=/home/toor/pictures/wallpapers/anchor_drawing_vector_dark_93570_1280x1024.jpg
mode=0
bgcolor=#001e44

[:0.0]
file=/home/toor/pictures/wallpapers/mask_anonymus_light_85666_1280x1024.jpg
mode=4
bgcolor=#000000

If I change a wallpaper on my system, it is changed in the [:0.0] entry.

To supplement this post, my bl log in screen background is black since yesterday. Not sure if these two are related.

My Autostart. Seems like an updated one even though this link doesn't work.

## Openbox autostart
## ====================
## When you login to your BunsenLabs Openbox session, this autostart script
## will be executed to set-up your environment and launch any applications
## you want to run at startup.
##
## Note: some programs, such as 'nm-applet' are run via XDG autostart.
## Run
## /usr/lib/x86_64-linux-gnu/openbox-xdg-autostart --list
## or
## /usr/lib/i386-linux-gnu/openbox-xdg-autostart --list
## to list any XDG autostarted programs.
##
## More information about this can be found at:
## http://openbox.org/wiki/Help:Autostart
##
## If you do something cool with your autostart script and you think others
## could benefit from your hack, please consider sharing it at:
## http://forums.bunsenlabs.org (registration required)
##

### SETTINGS START

## Turn on/off system beep.
xset b off

## Set keyboard settings - 250 ms delay and 25 cps (characters per second) repeat rate.
## Adjust the values according to your preferances.
xset r rate 250 25

## Add keyboard mapping.
#xmodmap -e "keysym Insert = Multi_key"

## Disable CapsLock
#setxkbmap -option ctrl:nocaps
# alternative: use as compose key
#setxkbmap -option compose:caps

# Alias Super key to Super+Space for single-key menu.
# See 'man xcape' for other possibilities.
xcape -e 'Super_L=Super_L|space'

### TOUCHPAD: comment out the next two entries if you don't have one

## Configure touchpad. See 'man synaptics' for more info.
## (Now might be using libinput instead of synaptics.)
synclient VertEdgeScroll=1 HorizEdgeScroll=1 TapButton1=1 2>/dev/null

## Disable touchpad while typing
syndaemon -i .5 -K -t -R -d &

### TOUCHPAD END

### SETTINGS END

## GNOME PolicyKit authentication
/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 &

## Set a wallpaper
nitrogen --restore &

## Compton
## NOTE: composition must be started before tint2
bl-compositor --start

## Start the tint2 session (the default tint2 will run if no sessions have been set)
bl-tint2-session

## Volume control for systray
pnmixer &

## Start the Conky session (the default conkyrc will run if no sessions have been set)
bl-conky-session --autostart &

## Start Clipboard manager
clipit &

## bl-welcome - post-installation script, will not run in a live session and
## only runs once. Safe to remove.
(sleep 10; bl-welcome --firstrun) &

## bl-fortune - have the system come up with a little adage (not yet enabled)
#(sleep 120; bl-fortune) &

## Turns numlock on on boot
numlockx on

This seems to be a workaround to the issue, not a solution as such. There should be a better fix I guess.

Last edited by linux_user (2019-04-02 11:51:23)


"Blind faith to authority is the greatest enemy of truth."

Offline

#2 2019-04-02 04:08:50

hhh
Meep!
Registered: 2015-09-17
Posts: 8,046
Website

Re: [RESOLVED] Nitrogen doesn't restore wallpaper

This is a bug that has bitten me over and over again. There seemingly is no rhyme or reason to it... Nitrogen works, and then it doesn't. Nitrogen seems much stabler in buster, but until then...

We have not been able to troubleshoot this so far. What I have recommended, and it's what I use (I find it simpler than scrolling through the available walls in Nitrogen, anyway, so it is what I use by default) is to use feh, which is included in BunsenLabs. The bug you linked also suggests feh as a workaround, but this is a more elegant command than using an absolute path that needs to be updated every time you change your wallpaper...

1) Open Thunar and navigate to a wallpaper.

2) Right-click it, "Open with>Open with Feh"

3) The image opens full-size. Ignore that, right-click the image, File>Background>Set filled

4) Edit your Openbox autostart file by disabling the nitrogen entry ( put a # before it) and adding a feh command, like so...

## Set a wallpaper
#nitrogen --restore
sh ~/.fehbg &

Logout, done. Any background you set with feh will now persist through reboots and logins.

If anyone has any insight into this bug, by all means share it. Thanks!

Offline

#3 2019-04-02 04:17:42

hhh
Meep!
Registered: 2015-09-17
Posts: 8,046
Website

Re: [RESOLVED] Nitrogen doesn't restore wallpaper

Regarding your login screen, check that you have the right path in /etc/lightdm/lightdm-gtk-greeter.conf. Example...

background=/home/rachel/Pictures/wallpapers/wall.jpg

Occasionally I've come across jpg and png images that just won't work, I don't know why. Try another image is my best advice.

Offline

#4 2019-04-02 09:49:19

linux_user
Member
Registered: 2016-11-04
Posts: 345

Re: [RESOLVED] Nitrogen doesn't restore wallpaper

hhh wrote:

Regarding your login screen, check that you have the right path in /etc/lightdm/lightdm-gtk-greeter.conf. Example...

background=/home/rachel/Pictures/wallpapers/wall.jpg

Occasionally I've come across jpg and png images that just won't work, I don't know why. Try another image is my best advice.

Isn't the following the default conf? Every line is commented. I am wondering how the login page background worked earlier. Also, which background should I change? Line 7 or 48(15 from last)?

# LightDM GTK+ Configuration
# Available configuration options listed below.
#
# Appearance:
#  theme-name = GTK+ theme to use
#  icon-theme-name = Icon theme to use
#  background = Background file to use, either an image path or a color (e.g. #772953)
#  user-background = false|true ("true" by default)  Display user background (if available)
#  transition-duration = Length of time (in milliseconds) to transition between background images ("500" by default)
#  transition-type = ease-in-out|linear|none  ("ease-in-out" by default)
#
# Fonts:
#  font-name = Font to use
#  xft-antialias = false|true  Whether to antialias Xft fonts
#  xft-dpi = Resolution for Xft in dots per inch (e.g. 96)
#  xft-hintstyle = none|slight|medium|hintfull  What degree of hinting to use
#  xft-rgba = none|rgb|bgr|vrgb|vbgr  Type of subpixel antialiasing
#
# Login window:
#  active-monitor = Monitor to display greeter window (name or number). Use #cursor value to display greeter at monitor with cursor. Can be a semicolon separated list
#  position = x y ("50% 50%" by default)  Login window position
#  default-user-image = Image used as default user icon, path or #icon-name
#  hide-user-image = false|true ("false" by default)
#
# Panel:
#  panel-position = top|bottom ("top" by default)
#  clock-format = strftime-format string, e.g. %H:%M
#  indicators = semi-colon ";" separated list of allowed indicator modules. Built-in indicators include "~a11y", "~language", "~session", "~power", "~clock", "~host", "~spacer". Unity indicators can be represented by short name (e.g. "sound", "power"), service file name, or absolute path
#
# Accessibility:
#  a11y-states = states of accessibility features: "name" - save state on exit, "-name" - disabled at start (default value for unlisted), "+name" - enabled at start. Allowed names: contrast, font, keyboard, reader.
#  keyboard = command to launch on-screen keyboard (e.g. "onboard")
#  keyboard-position = x y[;width height] ("50%,center -0;50% 25%" by default)  Works only for "onboard"
#  reader = command to launch screen reader (e.g. "orca")
#
# Security:
#  allow-debugging = false|true ("false" by default)
#  screensaver-timeout = Timeout (in seconds) until the screen blanks when the greeter is called as lockscreen
#
# Template for per-monitor configuration:
#  [monitor: name]
#  background = overrides default value
#  user-background = overrides default value
#  laptop = false|true ("false" by default) Marks monitor as laptop display
#  transition-duration = overrides default value
#
[greeter]
#background=
#user-background=
#theme-name=
#icon-theme-name=
#font-name=
#xft-antialias=
#xft-dpi=
#xft-hintstyle=
#xft-rgba=
#indicators=
#clock-format=
#keyboard=
#reader=
#position=
#screensaver-timeout=

Last edited by linux_user (2019-04-02 09:55:18)


"Blind faith to authority is the greatest enemy of truth."

Offline

#5 2019-04-02 09:58:23

hhh
Meep!
Registered: 2015-09-17
Posts: 8,046
Website

Re: [RESOLVED] Nitrogen doesn't restore wallpaper

15 from last, under greeter. Example...

[greeter]
background=/usr/share/images/desktop-base/login-background.svg

Offline

#6 2019-04-02 10:39:12

linux_user
Member
Registered: 2016-11-04
Posts: 345

Re: [RESOLVED] Nitrogen doesn't restore wallpaper

hhh wrote:

15 from last, under greeter. Example...

[greeter]
background=/usr/share/images/desktop-base/login-background.svg

I see. As mentioned earlier I was wondering how did it work earlier given the fact that this conf file wasn't changed at all.

I then remembered that since I use a 5:4 monitor, I had deleted wallpapers of other aspect ratios from the /usr/share/images/bunsen/wallpaper folder. In that there is /default/BL-beam.png image, which is the default image for login screens. Restored that folder and things are fine now.

That keeps me still thinking, where is conf that calls this image to the login screen, or sets this image as the default login screen background?

hhh wrote:

Any background you set with feh will now persist through reboots and logins.

Worked like a charm.... Since this issue has been reported by many and is without a patch, are we going to still use nitrogen for buster/lithium?

Last edited by linux_user (2019-04-02 10:39:56)


"Blind faith to authority is the greatest enemy of truth."

Offline

#7 2019-04-02 13:42:37

hhh
Meep!
Registered: 2015-09-17
Posts: 8,046
Website

Re: [RESOLVED] Nitrogen doesn't restore wallpaper

Yes. Nitrogen is simple and it has a better GUI than feh. I've been bitten by this bug, but very few others have reported the same. Maybe a hardware issue? I don't know.

Anyway, we'll stay with nitrogen and keep including feh, since it's tiny and rock-solid. I've had no issues with nitrogen in my testing setup, so maybe that small bug is over with (fingers crossed).

Offline

#8 2019-04-02 13:51:26

hhh
Meep!
Registered: 2015-09-17
Posts: 8,046
Website

Re: [RESOLVED] Nitrogen doesn't restore wallpaper

linux_user wrote:

That keeps me still thinking, where is conf that calls this image to the login screen, or sets this image as the default login screen background?

/etc/lightdm/

https://packages.debian.org/buster/lightdm-gtk-greeter

For lithium, we plan to stay with lightdm but switch the greeter to slick-greeter. The conf is slick-greeter.conf and it's also found in /etc/lightdm...

https://packages.debian.org/buster/slick-greeter

BTW, there is also the package lightdm-gtk-greeter-settings available in stretch/helium, which I've never used but I'll have to test. There are also other new greeter options. I'm going to test lightdm-autologin-greeter now and arctica-greeter-theme later...

https://packages.debian.org/buster/ligh … in-greeter

https://packages.debian.org/buster/arct … ian-buster

Offline

#9 2019-04-02 13:58:12

hhh
Meep!
Registered: 2015-09-17
Posts: 8,046
Website

Re: [RESOLVED] Nitrogen doesn't restore wallpaper

lightdm-gtk-greeter-settings GUI...

Screenshot_2019-04-02_09-57-08.md.png

I'm changing the title tag from [SOLVED] to [RESOLVED]. Using feh is a great workaround, but it doesn't solve the nitrogen issue.

The command to launch this greeter-settings GUI is lightdm-gtk-greeter-settings-pkexec

To install it...

sudo apt install lightdm-gtk-greeter-settings

Then open gmrun, dmenu, jgmenu, etc... or a terminal and run...

lightdm-gtk-greeter-settings-pkexec

-edit- BTW, the greeter font will look better if the font setting is changed from bold to normal.

Last edited by hhh (2019-04-02 15:28:01)

Offline

#10 2019-04-02 18:04:48

linux_user
Member
Registered: 2016-11-04
Posts: 345

Re: [RESOLVED] Nitrogen doesn't restore wallpaper

hhh wrote:
linux_user wrote:

That keeps me still thinking, where is conf that calls this image to the login screen, or sets this image as the default login screen background?

/etc/lightdm/

Although it's good to hear about other greeter options, inside /etc/lightdm/ there are 4 files, and none of them shows or calls the default image. Most of the lines are commented. It's good to see that you can find it in gui (screenshot you posted), but where can I find it in the conf file?

hhh wrote:

I'm changing the title tag from [SOLVED] to [RESOLVED]. Using feh is a great workaround, but it doesn't solve the nitrogen issue.

Sure smile

Last edited by linux_user (2019-04-02 18:05:57)


"Blind faith to authority is the greatest enemy of truth."

Offline

#11 2019-04-02 18:40:29

damo
....moderator....
Registered: 2015-08-20
Posts: 5,006

Re: [RESOLVED] Nitrogen doesn't restore wallpaper

^ It is set by Debian Alternatives:

Run galternatives or Menu -> System -> Edit Debian Alternatives -> desktop-login-background


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#12 2019-04-02 19:33:49

hhh
Meep!
Registered: 2015-09-17
Posts: 8,046
Website

Re: [RESOLVED] Nitrogen doesn't restore wallpaper

^Nice, thanks damo! My system is testing lithium ATM so not everything is kosher here. big_smile

Offline

#13 2019-04-02 21:02:04

damo
....moderator....
Registered: 2015-08-20
Posts: 5,006

Re: [RESOLVED] Nitrogen doesn't restore wallpaper

My bad, the login background is set by BL, and it is a symlink:

/usr/share/images/bunsen/login/bl-login-background -> ../wallpapers/default/BL-beam.png

In /usr/share/lightdm/lightdm-gtk-greeter.conf.d/50_bunsen.conf is

background=/usr/share/images/bunsen/login

Last edited by damo (2019-04-02 21:10:41)


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#14 2019-04-03 04:20:15

linux_user
Member
Registered: 2016-11-04
Posts: 345

Re: [RESOLVED] Nitrogen doesn't restore wallpaper

damo wrote:

My bad, the login background is set by BL, and it is a symlink:

/usr/share/images/bunsen/login/bl-login-background -> ../wallpapers/default/BL-beam.png

In /usr/share/lightdm/lightdm-gtk-greeter.conf.d/50_bunsen.conf is

background=/usr/share/images/bunsen/login

Ah, finally! Thanks damo.


"Blind faith to authority is the greatest enemy of truth."

Offline

#15 2019-04-05 07:24:25

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 5,556
Website

Re: [RESOLVED] Nitrogen doesn't restore wallpaper

damo wrote:

In /usr/share/lightdm/lightdm-gtk-greeter.conf.d/50_bunsen.conf is

background=/usr/share/images/bunsen/login
background=/usr/share/images/bunsen/login/bl-login-background

John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
In case you forget, the rules.

Offline

#16 2019-06-29 10:30:26

iqbal2929
New Member
Registered: 2019-06-29
Posts: 1

Re: [RESOLVED] Nitrogen doesn't restore wallpaper

Hi guys, I just found a solution, really take a while to do that, but you need take 300mb disk space to do that cleanly without feh.
Just install nitrogen 1.6.1 and you're fine.
Here
Cheers!

Offline

#17 2019-06-29 19:20:51

twoion
ほやほや
Registered: 2015-08-10
Posts: 2,459

Re: [RESOLVED] Nitrogen doesn't restore wallpaper

iqbal2929 wrote:

Hi guys, I just found a solution, really take a while to do that, but you need take 300mb disk space to do that cleanly without feh.
Just install nitrogen 1.6.1 and you're fine.
Here
Cheers!

Nice. 1.6.1 will also be included with the next BL release Lithium based on Debian Buster.


What can you see / On the horizon?

Offline

#18 2019-06-30 06:58:33

hhh
Meep!
Registered: 2015-09-17
Posts: 8,046
Website

Re: [RESOLVED] Nitrogen doesn't restore wallpaper

https://packages.debian.org/buster/nitrogen

Very nice, I was wondering why I couldn't reproduce this bug on Lithium using the same old hardware.

Offline

#19 2019-06-30 22:45:12

DeepDayze
Member
From: In Linux Land
Registered: 2017-05-28
Posts: 714

Re: [RESOLVED] Nitrogen doesn't restore wallpaper

hhh wrote:

https://packages.debian.org/buster/nitrogen

Very nice, I was wondering why I couldn't reproduce this bug on Lithium using the same old hardware.

On my BL-Sid install Nitrogen works fine after I removed that 0:0 line (left over from Helium install).


Real Men Use Linux

Offline

#20 2019-07-24 11:04:20

amoeba
New Member
Registered: 2018-02-14
Posts: 3

Re: [RESOLVED] Nitrogen doesn't restore wallpaper

Hi there,

had the same bug, but the feh-workaround did the trick. Thanks!

Also I couldn't help but wondering how confusing this thread could have been, if it had occured during bunsenlabs "nitrogen" big_smile

Offline

#21 2019-07-31 02:45:22

tdlam
Member
Registered: 2015-10-02
Posts: 10

Re: [RESOLVED] Nitrogen doesn't restore wallpaper

Sorry if I shouldn't be posting on a RESOLVED thread but I solved this issue rather simply. I created a .desktop file with the following:

[Desktop Entry]
Name=nitrogen restore
Type=Application
Exec=nitrogen --restore
Terminal=false
Icon=nitrogen
Comment=
NoDisplay=false
Categories=Utility;

and put in in my autostart folder under the .config folder in my home directory.
I logged out then back in and it seems to have solved this problem.
I hope this helps


there are three kinds of people in the world...those that can count and those that can't

Offline

#22 2019-08-05 07:17:52

linux_user
Member
Registered: 2016-11-04
Posts: 345

Re: [RESOLVED] Nitrogen doesn't restore wallpaper

^this works. There is a slight delay in loading the wallpapers at boot up but it may not be noticeable in faster computers.

There is also another fix suggested here. However it requires you to make changes to conky.


"Blind faith to authority is the greatest enemy of truth."

Offline

Board footer

Powered by FluxBB