You are not logged in.

#1 2022-06-15 17:33:27

Registered: 2021-12-05
Posts: 11

Regular Crashes (Restarts) - microcode error flashes.

Hello all,

Arch Linux 5.18.3-arch1-1 (UEFI)
CPU - AMD Ryzen 7 5800x (16 thread) @ 3.800Ghz
Board - X570 Aorus Elite -CF
GPU Nvidia GeForce GTX 1050 Ti

Issue: Repeated Crashes (Reboots) no initial freezes or loss of control just straight up if I clicked the restart button. No issues on boot after crash but flashes "microcode error" but too quick to read further.
CPU Usage and Temp are visible on $sensor input **although I cannot find the right file to display it in i3-status. **(Only referring to temp. Usage displays as normal)

Things I have tried:
checked amd-ucode is installed.
remade GRUB file to auto recognize AMD-UCODE
changed bios setting - think it was PBO but will double check (from auto to another setting)

here is journalctl -b -l output after crash.

- … sp=sharing

I am a little new to reading this crash report and having a little issue spotting what is wrong. Any help with this issue would be grand.

All the best

P.S. I am fairly certain it is a hardware issue with the CPU itself, apparently there might be a recall or something. Thought I would try a software fix before changing it … 622/page/2

Also I do not mind reformatting the device and all the hardware has warranty.


#2 2022-06-15 19:49:01

Back to the roots 1.9
From: #! BL
Registered: 2015-10-31
Posts: 1,762

Re: Regular Crashes (Restarts) - microcode error flashes.

You use an archlinux kernel and ask in the BL forum ? Why don't you do it in the appropriate forum?  devil

I looked at your journal issue and can't see any specifics regarding the error. However, the command is also impractical. You should rather use

journalctl -b -e

The -e causes the output to jump to the end and from there you can look backwards at the last 20 - 30 entries, because that's where the error should be.

Another possibility would be to write the output to a file. To do this, open a terminal as root and type in

journalctl -af > ~/Riggo/freeze.txt

You leave this terminal open and continue working normally, hoping that something will be written to the file when the crash occurs.

Probably you won't succeed with this, because the journal can't be written at the moment of the crash.

One last word about the hardware. If it is the cause, you can find it out with the command:

dmesg --color=always | less -R 

Search for entries in red color. Good luck!


#3 2022-06-15 20:50:35

Registered: 2018-05-22
Posts: 871

Re: Regular Crashes (Restarts) - microcode error flashes.

Have you tried running a live cd version of some other distro to see if it still occurs?


#4 2022-06-20 18:14:16

Registered: 2021-12-05
Posts: 11

Re: Regular Crashes (Restarts) - microcode error flashes.

Hello again,

Sorry for the late reply. The crash did not happen till quite some time after my last post.

@sleekmason - I have not done this yet but I might try it later on in the week.


- Why no arch Linux forum? - Ive had some great interactions with the community here so why not post again?

- Journalctl -b - e output - … sp=sharing

Line 83 - 87 caught my eye with [hardware error] going to google the details in a little bit.

- Journalctl -af > file = did not have it running at the time of the crash. I thought an update fixed the issue and was about to report back with a solved then OOPS happened again.

- dmesg --color=always | less -R = no red was found.

- what do I think? I believe that my install is having trouble finding the thermal information for the CPU. Line 1 - 6 in the linked crashError.txt seems to suggest this.
When configuring my i3 bar (cause ofc its Arch with i3) I could not find the correct file to link my CPU temp to the i3-status app. When I run "sensors" (command line and GUI versions) it finds the temp just fine and everything appears normal (even right after crash). Is there a command to print out the path the "sensors" uses to find the temp?

Any help would be greatly appreciated.
All the best


#5 2022-06-20 18:33:33

Registered: 2021-12-05
Posts: 11

Re: Regular Crashes (Restarts) - microcode error flashes.

Also ran a "journalctl -k --priority err --boot 0" command and got the following errors from the kernel.

Jun 21 01:52:08 DISKArch kernel: mce: [Hardware Error]: CPU 5: Machine Check: 0 Bank 1: bc800800060c0859
Jun 21 01:52:08 DISKArch kernel: mce: [Hardware Error]: TSC 0 ADDR 141583000 MISC d012000000000000 IPID 100b000000000
Jun 21 01:52:08 DISKArch kernel: mce: [Hardware Error]: PROCESSOR 2:a20f10 TIME 1655747525 SOCKET 0 APIC a microcode a201016

These are the same as in the crashError.txt file I linked earlier so I may have been wrong about the temps being the issue. … u/89580/20

Found this post (above) and after reading through it there might be some sort of "voltage difference" between windows and linux that causes some AMD CPU's to be unstable?

I am going to try and disable C-states / change Power Supple Idle Control and / set Curve Optimizer to "All Cores" and see if that helps.


Board footer

Powered by FluxBB