You are not logged in.

#1 2019-12-07 01:32:20

makarovnik
Member
Registered: 2019-03-28
Posts: 27

Etcher won't run

Hey guys. I downloaded etcher from their website and extracted the zip file to my home directory file= balenaEtcher-1.5.66-x64.AppImage.

When I click on it nothing happens. I followed all the advice online regarding missing dependencies but it turns out all those were already installed on my system. I would like to get this working because the dd command just doesn't create a reliable bootable iso for me. I do use gnome-multi-writer and it always works but it always gives me nasty file access errors.

If anyone uses etcher and can give install advice it would be greatly appreciated.

Offline

#2 2019-12-07 02:31:07

damo
....moderator....
Registered: 2015-08-20
Posts: 6,734

Re: Etcher won't run

AFAIK Etcher is a "bloated frontend for dd", as someone here once said!

For creating bootable isos BL recommends using cp or dd, which have been the go-to methods for most of us. And Debian also recommends win32diskimager for windows machines.

You say that dd doesn't produce "reliable" results? What is the command you have been trying?

EDIT: there is a deb package available - https://github.com/balena-io/etcher#deb … nux-x86x64. Whether that borks your Stable system is something you can discover for yourself! Try just downloading the deb, and using gdebi - it will tell you if there are dependency problems.

EDIT2: The Etcher download is a 90MB zip archive! No thanks hmm

(dd is part of coreutils, which is a total of 15MB)

Last edited by damo (2019-12-07 02:41:04)


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#3 2019-12-07 04:49:21

beaker
Unverified Muppet
Registered: 2016-03-06
Posts: 175

Re: Etcher won't run

makarovnik wrote:

doesn't create a reliable bootable iso for me

Which iso?

Offline

#4 2019-12-07 13:09:04

manyroads
Member
From: around here, somewhere
Registered: 2019-04-16
Posts: 121
Website

Re: Etcher won't run

fwiw... I generally find dd to be the most reliable approach in producing bootable isos.  For MX & antiX, antiX/MX LiveUSB is best. For *buntu variants sometimes only unetbootin seems to works. For other failures I encounter when initially using dd, I need to go with Suse Imagewriter or Etcher.

For me at least, there is no 100% usable solution.


Pax vobiscum,
Mark Rabideau - http://many-roads.com  Professional Genealogist
dwm & i3wm ~ Reg. Linux User #449130
"For every complex problem there is an answer that is clear, simple, and wrong." H. L. Mencken

Offline

#5 2019-12-07 16:49:27

rbh
Moderator
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 1,345

Re: Etcher won't run

makarovnik wrote:

Hey guys. I downloaded etcher [...] because the dd command just doesn't create a reliable bootable iso for me.

I don't know if you actualey tried to do what you wrote...

Etcher is a frontend for dd, to transfer iso filesystem from for instance an iso file to an usb disk.
That is usable to boot live dist / start install, from usb-disk instead of CD/DVD.

You shall not crate an iso-file if you want to bootfrom usb-disk...

What's the command you use with dd?

Last edited by rbh (2019-12-07 16:50:38)


// Regards rbh

Please read before requesting help: Guide to getting help,
Introduction to the Bunsenlabs Lithium Desktop and other help topics under "Help Resources" on the BunsenLabs menu

Offline

#6 2020-06-23 21:03:14

Circlight
New Member
Registered: 2020-06-23
Posts: 2

Re: Etcher won't run

Fully understand the comments regarding preferential use of dd, which I often do myself, however sometimes I like to use etcher. Here's how I just got it running on Lithium:

Download the .deb from here: Github etcher

I got balena-etcher-electron_1.5.100_amd64.deb.

Do

sudo dpkg -i balena-etcher-electron_1.5.100_amd64.deb

There will be dependency errors, so now do

sudo apt install gconf2 gconf-service libappindicator1 libgconf-2-4

Yes, some more dependency errors. Fix those by:

sudo apt --fix-broken install

Etcher is now installed to /opt/balenaEtcher.

Now:

cd /opt/balenaEtcher
sudo chown root:$USER chrome-sandbox
sudo chmod 4755 chrome-sandbox

balenaEtcher will appear in jgmenu under Applications / Accessories and runs as expected.

Offline

#7 2021-12-11 17:36:15

novice
Member
Registered: 2020-01-30
Posts: 16

Re: Etcher won't run

I know this is an old post but THANK YOU!  I've been trying to get this working on Lithium for three days and no other advice I've seen worked.  This does.

Offline

Board footer

Powered by FluxBB