You are not logged in.

#1 2020-05-31 12:50:10

jimjamz
Member
From: Nagasaki, Japan
Registered: 2016-04-04
Posts: 109

[SOLVED] Xterm has lost it's styling (or wrong default terminal)?

I presume that the terminal app we have always used is xterm with a custom styling applied to it.   Well, that default style seems to have disappeared as my terminal app currently looks like this:
Screenshot-2020-05-31-13-48-15.png


the tray icon has also changed from it's default icon:
Screenshot-2020-05-31-13-48-36.png

I certainly haven't modified the terminal app in any way as I'm more than happy with the vanilla version that is provided by default with BL.
I also haven't `apt-get upgrade`d recently either so no changes to xterm AFAIK.

Hopefully someone can help me to get back the default styling as xterm is currently ugly.

EDIT: Updated title to assist other users find the topic more helpful.

Last edited by jimjamz (2020-05-31 18:07:16)

Offline

#2 2020-05-31 15:23:15

rbh
Member
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 442

Re: [SOLVED] Xterm has lost it's styling (or wrong default terminal)?

jimjamz wrote:

I presume that the terminal app we have always used is xterm with a custom styling applied to it.

No. In Helium default terminal is terminator. In Lithium it is lxterminal.


// Regards rbh

Offline

#3 2020-05-31 18:05:34

jimjamz
Member
From: Nagasaki, Japan
Registered: 2016-04-04
Posts: 109

Re: [SOLVED] Xterm has lost it's styling (or wrong default terminal)?

rbh wrote:

No. In Helium default terminal is terminator. In Lithium it is lxterminal.

I suspected it could have been a different terminal app and that the default may have changed more recently but could not remember neither the new or old terminal names as I have never needed to change it.

So, it appears my default terminal for both jgmenu and hotkeys (Super+T) have recently changed from `lxterminal` to `lxterm`.  As both had seemed to have changed, I suspected Alternatives was to blame.  Indeed, `x-terminal-emulator` was pointing to `/usr/bin/lxterm`.  How could this have happened?  As mentioned, I was more than happy with the default so felt no need for tinkering.

A quick change to Alternatives resolved this:

sudo update-alternatives --config x-terminal-emulator

and selecting the appropriate terminal [option 3]:

  Selection    Path                 Priority   Status
------------------------------------------------------------
  0            /usr/bin/lxterm       30        auto mode
  1            /usr/bin/koi8rxterm   20        manual mode
* 2            /usr/bin/lxterm       30        manual mode
  3            /usr/bin/lxterminal   20        manual mode
  4            /usr/bin/uxterm       20        manual mode
  5            /usr/bin/xterm        20        manual mode

Alternatively (no pun intended), this can also be changed via the jgmenu:
Screenshot-2020-05-31-18-41-44.png

and then selecting the appropriate choice:
Screenshot-2020-05-31-19-05-00.png

Last edited by jimjamz (2020-05-31 18:09:14)

Offline

Board footer

Powered by FluxBB