You are not logged in.

#1 2021-03-17 22:28:04

portaro
Member
Registered: 2020-01-03
Posts: 25

Can't launch G'MIC on Gimp

I Install gmic for gimp but for some reason it doesn't works when I try to use this when I process a image on Gimp.

The terminal output when I launch Gimp from command line present some errors (all scripts and addons I install with synaptic search and install.

joao@debian-asus:~$ gimp
gimp: LibGimpBase-WARNING: gimp: gimp_wire_read(): error
gimp: LibGimpBase-WARNING: gimp: gimp_wire_read(): error
gimp: LibGimpBase-WARNING: gimp: gimp_wire_read(): error
gimp: LibGimpBase-WARNING: gimp: gimp_wire_read(): error
gimp: LibGimpBase-WARNING: gimp: gimp_wire_read(): error
gimp: LibGimpBase-WARNING: gimp: gimp_wire_read(): error
gimp: LibGimpBase-WARNING: gimp: gimp_wire_read(): error
gimp: LibGimpBase-WARNING: gimp: gimp_wire_read(): error

(gmic_gimp:9012): GLib-GObject-WARNING **: 22:29:32.387: cannot register existing type 'GtkWidget'

(gmic_gimp:9012): GLib-GObject-CRITICAL **: 22:29:32.387: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(gmic_gimp:9012): GLib-GObject-WARNING **: 22:29:32.387: cannot register existing type 'GtkBuildable'

(gmic_gimp:9012): GLib-GObject-CRITICAL **: 22:29:32.387: g_type_interface_add_prerequisite: assertion 'G_TYPE_IS_INTERFACE (interface_type)' failed

(gmic_gimp:9012): GLib-CRITICAL **: 22:29:32.387: g_once_init_leave: assertion 'result != 0' failed

(gmic_gimp:9012): GLib-GObject-CRITICAL **: 22:29:32.387: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(gmic_gimp:9012): GLib-GObject-CRITICAL **: 22:29:32.387: g_type_register_static: assertion 'parent_type > 0' failed

(gmic_gimp:9072): GLib-GObject-WARNING **: 22:29:48.951: cannot register existing type 'GtkWidget'

(gmic_gimp:9072): GLib-GObject-CRITICAL **: 22:29:48.951: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(gmic_gimp:9072): GLib-GObject-WARNING **: 22:29:48.951: cannot register existing type 'GtkBuildable'

(gmic_gimp:9072): GLib-GObject-CRITICAL **: 22:29:48.952: g_type_interface_add_prerequisite: assertion 'G_TYPE_IS_INTERFACE (interface_type)' failed

(gmic_gimp:9072): GLib-CRITICAL **: 22:29:48.952: g_once_init_leave: assertion 'result != 0' failed

(gmic_gimp:9072): GLib-GObject-CRITICAL **: 22:29:48.952: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(gmic_gimp:9072): GLib-GObject-CRITICAL **: 22:29:48.952: g_type_register_static: assertion 'parent_type > 0' failed
joao@debian-asus:~$ gimp
GIMP-Erro: Unable to run plug-in "plugin-uncrop.py"
(/usr/lib/gimp/2.0/plug-ins/plugin-uncrop.py)

Failed to execute child process “python” (No such file or directory)

gimp: LibGimpBase-WARNING: gimp: gimp_wire_read(): error
GIMP-Erro: Unable to run plug-in "plugin-resynth-fill-pattern.py"
(/usr/lib/gimp/2.0/plug-ins/plugin-resynth-fill-pattern.py)

Failed to execute child process “python” (No such file or directory)

GIMP-Erro: Unable to run plug-in "plugin-resynth-enlarge.py"
(/usr/lib/gimp/2.0/plug-ins/plugin-resynth-enlarge.py)

Failed to execute child process “python” (No such file or directory)

GIMP-Erro: Unable to run plug-in "plugin-render-texture.py"
(/usr/lib/gimp/2.0/plug-ins/plugin-render-texture.py)

Failed to execute child process “python” (No such file or directory)

GIMP-Erro: Unable to run plug-in "plugin-map-style.py"
(/usr/lib/gimp/2.0/plug-ins/plugin-map-style.py)

Failed to execute child process “python” (No such file or directory)

GIMP-Erro: Unable to run plug-in "plugin-heal-transparency.py"
(/usr/lib/gimp/2.0/plug-ins/plugin-heal-transparency.py)

Failed to execute child process “python” (No such file or directory)

GIMP-Erro: Unable to run plug-in "plugin-heal-selection.py"
(/usr/lib/gimp/2.0/plug-ins/plugin-heal-selection.py)

Failed to execute child process “python” (No such file or directory)


(gmic_gimp:9838): GLib-GObject-WARNING **: 22:32:58.542: cannot register existing type 'GtkWidget'

(gmic_gimp:9838): GLib-GObject-CRITICAL **: 22:32:58.542: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(gmic_gimp:9838): GLib-GObject-WARNING **: 22:32:58.543: cannot register existing type 'GtkBuildable'

(gmic_gimp:9838): GLib-GObject-CRITICAL **: 22:32:58.543: g_type_interface_add_prerequisite: assertion 'G_TYPE_IS_INTERFACE (interface_type)' failed

(gmic_gimp:9838): GLib-CRITICAL **: 22:32:58.543: g_once_init_leave: assertion 'result != 0' failed

(gmic_gimp:9838): GLib-GObject-CRITICAL **: 22:32:58.543: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(gmic_gimp:9838): GLib-GObject-CRITICAL **: 22:32:58.543: g_type_register_static: assertion 'parent_type > 0' failed

Offline

#2 2021-03-18 00:32:57

damo
....moderator....
Registered: 2015-08-20
Posts: 6,572

Re: Can't launch G'MIC on Gimp

Did you already have some plug-ins installed?


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#3 2021-03-18 06:44:32

ohnonot
...again
Registered: 2015-09-29
Posts: 5,383
Website

Re: Can't launch G'MIC on Gimp

portaro wrote:
Failed to execute child process “python” (No such file or directory)

This is strange. Surely python is installed?
AFAICS the gimp gmic plugin does not depend on python, but this could have an impact on your problem nevertheless.


Please use CODE tags for code.
Search youtube without a browser: repo | thread
BL quote proposals to this thread please.
my repos / my repos

Offline

#4 2021-03-18 06:57:26

damo
....moderator....
Registered: 2015-08-20
Posts: 6,572

Re: Can't launch G'MIC on Gimp

ohnonot wrote:
portaro wrote:
Failed to execute child process “python” (No such file or directory)

This is strange. Surely python is installed?
AFAICS the gimp gmic plugin does not depend on python, but this could have an impact on your problem nevertheless.

But many plugins are .py files. If they haven't been updated then there will be python errors, which is why I suggest removing the offending ones.


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#5 2021-03-18 15:38:49

portaro
Member
Registered: 2020-01-03
Posts: 25

Re: Can't launch G'MIC on Gimp

I ave this python return version on my terminal →

joao@debian-asus:~$ python --version
Python 2.7.16
joao@debian-asus:~$

The problem around Gmic is start on the line

(gmic_gimp:9838): GLib-GObject-WARNING **: 22:32:58.542: cannot register existing type 'GtkWidget'

I think,
Because this appear on terminal when I click on the menu text of Gimp → Main Menu → Filters → G'MIC-Qt

I install all installed plugins or addons by search in Synaptic, so probably is a problem that will occur with other people, and probably is a problem with the version package of Debian repos maybe.

Last edited by portaro (2021-03-18 15:43:47)

Offline

#6 2021-03-19 00:07:17

hhh
Meep!
Registered: 2015-09-17
Posts: 11,448
Website

Re: Can't launch G'MIC on Gimp

portaro wrote:

(gmic_gimp:9838): GLib-GObject-WARNING **: 22:32:58.542: cannot register existing type 'GtkWidget'

You can ignore GTK3 warning messages, especially with a Qt app. It's something else.

Offline

#7 2021-03-19 12:00:44

portaro
Member
Registered: 2020-01-03
Posts: 25

Re: Can't launch G'MIC on Gimp

I download Gimp-appimage from here → https://appimage.github.io/GIMP/,

and G'MIC works if I launch Gimp-appimage program, so I think that the problem is in relation with the package of Gimp in the repositories of Debian.

Captura-de-ecr-2021-03-19-12-04-10.png

Captura-de-ecr-2021-03-19-12-05-35.png

Offline

#8 2021-03-22 01:40:40

portaro
Member
Registered: 2020-01-03
Posts: 25

Re: Can't launch G'MIC on Gimp

Now I have two entries of gimp on my menu How I can change the name of one to know what is the software that runs G'MIC and that not?

Where is the place to edit names of software installed and that appear on menu ?

Offline

#9 2021-03-22 02:04:30

damo
....moderator....
Registered: 2015-08-20
Posts: 6,572

Re: Can't launch G'MIC on Gimp

portaro wrote:

Now I have two entries of gimp on my menu How I can change the name of one to know what is the software that runs G'MIC and that not?

Where is the place to edit names of software installed and that appear on menu ?

If you are using the default jgmenu, then look for the desktop file associated with the executable. The default for GIMP is /usr/share/applications/gimp.desktop. Try editing it, and change to the menu entry of choice...

Name=GNU Image Manipulation Program

Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#10 2021-03-22 03:34:49

portaro
Member
Registered: 2020-01-03
Posts: 25

Re: Can't launch G'MIC on Gimp

Thanks it works.

Offline

#11 2021-04-01 16:34:56

ohnonot
...again
Registered: 2015-09-29
Posts: 5,383
Website

Re: Can't launch G'MIC on Gimp

portaro wrote:

I download Gimp-appimage from here → https://appimage.github.io/GIMP/,

and G'MIC works if I launch Gimp-appimage program, so I think that the problem is in relation with the package of Gimp in the repositories of Debian.

It is sad that people don't bother anymore to learn how to maintain repositories, update and install software within the constraints of a mature software package management system, and then come to erroneous conclusions like that.
sad


Please use CODE tags for code.
Search youtube without a browser: repo | thread
BL quote proposals to this thread please.
my repos / my repos

Offline

#12 2021-04-01 20:06:22

portaro
Member
Registered: 2020-01-03
Posts: 25

Re: Can't launch G'MIC on Gimp

In the Debian forum an user give me a solution to launch the Gimp with GMIC operational →

env QT_QPA_PLATFORMTHEME=gtk3 gimp-2.10

Link to the solution


It is sad that people don't bother anymore to learn how to maintain repositories, update and install software within the constraints of a mature software package management system, and then come to erroneous conclusions like that.
sad

Wasn't my intention commit any bad idea about package maintainers or the repositories of Debian, I only think in a possible problem, is not my intention do any problematic comments.

My apologize.

Last edited by portaro (2021-04-01 20:17:00)

Offline

Board footer

Powered by FluxBB