You are not logged in.

#1 2017-02-13 11:29:29

mi
Member
Registered: 2015-09-30
Posts: 70

tint2 icon tearing

Hi.

I've been having a problem with tearing of/ glitches on icons in tint2. I know it's an old issue (already since crunchbang age).
It has also been easily solved by setting compton to start in the end of the autostart script, or by restarting compton after making modifications on tint2.
Since a few weeks, I guess (didn't really pay attention), I've been experiencing these glitches again. These would only be solved by disabling compton (kill or bl-compositor --stop).
After some test with compton I went to check the /usr/bin/bl-compositor script and was able to solve the problem by swapping the order of the commands $EXECXCOMP and bl-tint2restart || true so it now look like

elif [[ $1 = '--start' ]]; then
    if ! pidof compton > /dev/null; then
        bl-tint2restart || true
        $EXECXCOMP
    else
        echo "$0 --start: compton already running" >&2
    fi

before and after:
(look at the systray. I must add that the tearing also occurred in the task bar when using another tint2rc)

scrot_20170213_125808_desktop_1366x768.th.png    scrot_20170213_125916_desktop_1366x768.th.png

This change will probably be overwritten after updates are done to it. If I'm not the only one experiencing this problem, I would like to ask you to consider implementing this fix upstream, in case it does solve the problem for others as well.

thanks guys

mi

Last edited by mi (2017-02-13 12:05:57)


It's milk time!
____________________________
Be excellent to each other!

Offline

#2 2017-02-13 19:10:09

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: tint2 icon tearing

Thanks for this mi, I will test soon on my Haswell machine.

Just to confirm, do you have Intel hardware?

lspci -knn | grep -iA2 'vga\|3d'

If so, have you tried switching to SNA?

See https://forums.bunsenlabs.org/viewtopic … 072#p20072 for details.

It may be useful to examine /var/log/Xorg.0.log and determine whether SNA or UXA acceleration is currently in use and switch to the other method — the Intel DDX driver is notoriously buggy, unfortunately hmm

I would actually advise upgrading your entire graphics stack if you have Haswell or newer, guide here:

https://forums.bunsenlabs.org/viewtopic.php?id=1185


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#3 2017-02-13 19:17:08

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: tint2 icon tearing

On a more general point:

mi wrote:

This change will probably be overwritten after updates are done to it.

To modify installed system scripts (such as bl-compositor), simply copy them to ~/bin first and modify that file instead:

cp /usr/bin/bl-compositor ~/bin
editor ~/bin/bl-compositor

Any executables in ~/bin will be run in preference to identically-named versions elsewhere in the system because that folder is first in the standard BunsenLabs user's $PATH and they will also survive package upgrades, although any updates should always be checked and any new changes "merged" with ~/bin/bl-compositor


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#4 2017-02-13 20:55:18

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: tint2 icon tearing

I have just tried re-ordering the lines in ~/bin/bl-compositor but it did not fix the issue for me on a fresh install (Intel HD4600 graphics card), selecting "restart compositing" from the Openbox menu does remove the artefacts though.

I can now confirm that BunsenLabs uses the UXA acceleration method for Intel cards as standard (ew was right!) and that switching to SNA fixes things for my hardware.

To do this, use these commands:

sudo mkdir -p /etc/X11/xorg.conf.d
sudo tee /etc/X11/xorg.conf.d/20-intel.conf <<!
Section "Device"
	Identifier "Intel Graphics"
	Driver "intel"
	Option "AccelMethod" "SNA"
EndSection
!

Then log out & back in again.


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#5 2017-02-14 08:43:14

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 5,731
Website

Re: tint2 icon tearing

Head_on_a_Stick wrote:

I have just tried re-ordering the lines in ~/bin/bl-compositor but it did not fix the issue for me on a fresh install (Intel HD4600 graphics card), selecting "restart compositing" from the Openbox menu does remove the artefacts though.

This compositing/tint2 issue keeps coming back. neutral There are many posts here, eg this.

We used to start tint2 before compton, but when re-writing openbox/autostart and the scripts, came to the conclusion that composition needed to be running before tint2 was started. The tint2 wiki says "Tint2 autodetects your compositing manager" which implies that. That's why we now trigger a tint2 restart after (re)starting compton. Behaviour might depend on different peoples' hardware though - the current default works fine for me.

I can now confirm that BunsenLabs uses the UXA acceleration method for Intel cards

Is this something we (BL) are doing (if so, where?), or standard Debian Jessie configuration?

switching to SNA fixes things for my hardware.
To do this, use these commands:

sudo mkdir -p /etc/X11/xorg.conf.d
sudo tee /etc/X11/xorg.conf.d/20-intel.conf <<!
Section "Device"
	Identifier "Intel Graphics"
	Driver "intel"
	Option "AccelMethod" "SNA"
EndSection
!

Then log out & back in again.

Should we be doing a hardware probe somewhere to set things like this?


John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
In case you forget, the rules.

Online

#6 2017-02-14 15:12:07

hhh
Meep!
Registered: 2015-09-17
Posts: 8,324
Website

Re: tint2 icon tearing

re: acceleration, xf86-video-intel defaults to sna unless overwritten as HoaS described.

Use what works best! You can test with glx --info, I think.

Offline

#7 2017-02-14 18:42:56

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: tint2 icon tearing

johnraff wrote:

I can now confirm that BunsenLabs uses the UXA acceleration method for Intel cards

Is this something we (BL) are doing (if so, where?), or standard Debian Jessie configuration?

That's the stock jessie configuration.

switching to SNA fixes things for my hardware

Should we be doing a hardware probe somewhere to set things like this?

Perhaps, the only problem with that would be determining the ideal setting for the various different hardware configurations.


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#8 2017-02-14 19:43:13

hhh
Meep!
Registered: 2015-09-17
Posts: 8,324
Website

Offline

#9 2017-02-14 19:43:45

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: tint2 icon tearing

hhh wrote:

where is your reference that uxa is the default?

/var/log/Xorg.0.log

smile


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#10 2017-02-14 19:44:50

hhh
Meep!
Registered: 2015-09-17
Posts: 8,324
Website

Re: tint2 icon tearing

Lol, I can't argue because my comp isn't booting ATM! 8D

Offline

#11 2017-04-01 10:45:29

jochen
Member
Registered: 2015-10-12
Posts: 17

Re: tint2 icon tearing

Head_on_a_Stick wrote:

I have just tried re-ordering the lines in ~/bin/bl-compositor but it did not fix the issue for me on a fresh install (Intel HD4600 graphics card), selecting "restart compositing" from the Openbox menu does remove the artefacts though.

I can now confirm that BunsenLabs uses the UXA acceleration method for Intel cards as standard (ew was right!) and that switching to SNA fixes things for my hardware.

To do this, use these commands:

sudo mkdir -p /etc/X11/xorg.conf.d
sudo tee /etc/X11/xorg.conf.d/20-intel.conf <<!
Section "Device"
	Identifier "Intel Graphics"
	Driver "intel"
	Option "AccelMethod" "SNA"
EndSection
!

Then log out & back in again.

I can confirm this bug and the workaround working on Lenovo Thinkpad X230. Thanks for this!

Offline

#12 2017-04-01 20:08:16

mufrious
Member
Registered: 2015-10-02
Posts: 10

Re: tint2 icon tearing

^ And on Dell XPS 13 l322x as well. The various workarounds I had applied were a bit erratic. Thanks also for this!

Online

#13 2017-12-23 06:45:04

DomOctober
New Member
From: New York
Registered: 2016-08-31
Posts: 1

Re: tint2 icon tearing

Head_on_a_Stick wrote:

I have just tried re-ordering the lines in ~/bin/bl-compositor but it did not fix the issue for me on a fresh install (Intel HD4600 graphics card), selecting "restart compositing" from the Openbox menu does remove the artefacts though.

I can now confirm that BunsenLabs uses the UXA acceleration method for Intel cards as standard (ew was right!) and that switching to SNA fixes things for my hardware.

To do this, use these commands:

sudo mkdir -p /etc/X11/xorg.conf.d
sudo tee /etc/X11/xorg.conf.d/20-intel.conf <<!
Section "Device"
	Identifier "Intel Graphics"
	Driver "intel"
	Option "AccelMethod" "SNA"
EndSection
!

Then log out & back in again.

Working on my Lenovo T440P -big improvement all around. Thank you!

Offline

Board footer

Powered by FluxBB