You are not logged in.

#1 2016-04-09 14:04:07

Pouletic
Member
Registered: 2015-10-25
Posts: 18

How to make lightdm autopopulate the user field

As per subject line, i'm trying to figure out how to fix lightdm settings so that my login username is already filled in when i have to unlock the screen during an existing session. I'm pretty sure that was default behavior in every previous linux installation i've had. It would be fine if that means the last user logged in is always in that field of the greeter. As it is, there's never a username shown there.

I'm poking around in lightdm.conf and don't see any obvious things to change.

Offline

#2 2016-04-09 14:35:03

porkpiehat
Member
Registered: 2015-10-27
Posts: 31

Re: How to make lightdm autopopulate the user field

Offline

#3 2016-04-11 02:45:19

Pouletic
Member
Registered: 2015-10-25
Posts: 18

Re: How to make lightdm autopopulate the user field

Thanks... well i tried that and it broke my X and i had to fix the file in nano from the terminal to get back in lol.

Maybe i put it in the wrong section? In any case i don't understand why the old default behavior i'm used to since, like, dapper drake isn't an option. It's annoying to have to type my username every time i unlock the screen. It's not like it's a huge deal, it's just and incomprehensible step backwards for ergonomics.

Offline

#4 2016-04-11 03:33:13

hhh
Ol' Pink Eyes
Registered: 2015-09-17
Posts: 12,777
Website

Re: How to make lightdm autopopulate the user field

Pouletic wrote:

As per subject line, i'm trying to figure out how to fix lightdm settings so that my login username is already filled in...

Edit line #100 in /etc/lightdm/lightdm.conf.bunsen, set the value to greeter-hide-users=false and reboot. The user should now be filled in as "Other..." Choose your name from the drop-down menu and login, it should autofill after that.

BTW, we have the default set like this for security, it's one more step for a hacker if your username isn't already filled in.


Does your physical disability preclude you from coming to the point?

Offline

#5 2016-04-11 04:09:53

Eraph
Member
From: /au/qld/bne
Registered: 2016-02-29
Posts: 282
Website

Re: How to make lightdm autopopulate the user field

Here's a question then, is BL's priority security, or is it usability? One would think that a user who values security over usability would have the know-how to make such a change themselves. Personally, I prefer to have the name autopopulated, I think the password is "secure enough".


Lenovo IdeaPad Yoga 13 | BunsenLabs Hydrogen (x64)
Intel Core i7-3537U | Intel HD4000 | 8GB DDR3 | 256GB SSD

Offline

#6 2016-04-11 04:12:54

hhh
Ol' Pink Eyes
Registered: 2015-09-17
Posts: 12,777
Website

Re: How to make lightdm autopopulate the user field

^Fair enough, but there are others who prefer the other option. We do what we can, namely reasonable-by-our-standards defaults and tutorials and support threads for custom defaults.

-edit- In this case, we're following the default login of "Official" Debian systems, which is a blank user field (at least the ones that use lightdm, I can't remember how GNOME and KDE's logins are set up).


Does your physical disability preclude you from coming to the point?

Offline

#7 2016-04-11 04:33:19

Eraph
Member
From: /au/qld/bne
Registered: 2016-02-29
Posts: 282
Website

Re: How to make lightdm autopopulate the user field

hhh wrote:

In this case, we're following the default login of "Official" Debian systems

I'm happy to take this as an answer smile


Lenovo IdeaPad Yoga 13 | BunsenLabs Hydrogen (x64)
Intel Core i7-3537U | Intel HD4000 | 8GB DDR3 | 256GB SSD

Offline

Board footer

Powered by FluxBB