You are not logged in.

#1 2020-03-05 23:22:52

luiznetto
Member
Registered: 2020-02-21
Posts: 9

Error message at boot, xscreensaver malfunction related?

Having installed BunsenLabs Helium on my Acer laptop a short time ago, I get the following error message right after I boot:

[    0.177888] ACPI BIOS Error (bug): \_SB.PCI0._OSC: Excess arguments - ASL declared 5, ACPI requires 4 (20160831/nsarguments-189)

Other than that, everything else seems to work fine, except for one thing: I installed xscreensaver, but it doesn't work the way it should. After a ten-minute absence from the computer, the screen gets dark, but xscreensaver fails to set in as expected. When I return, I press any key and get the login prompt; I get the message "the session is locked"; I input my password, I get the same message again, I have to input my password again to finally get back to the session. A weird behaviour, not what I expected.

I wonder if the xscreensaver package in this repository is buggy, or it's just the system that is malfunctioning, possibly related to the error message I get at boot.

Any help is appreciated, thanks in advance.

Offline

#2 2020-03-05 23:42:19

damo
....moderator....
Registered: 2015-08-20
Posts: 5,835

Re: Error message at boot, xscreensaver malfunction related?

It may be clashing with the default power manager settings?

Check your settings (r-click the power icon, or Menu -> Preferences);
Look in your logs (eg .xsession-errors, sudo dmesg, sudo journalctl -b)

And I suggest you google for " ACPI BIOS Error (bug): \_SB.PCI0._OSC: Excess arguments " - there are many, many links about it. I don't think it is of concern.


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

Board footer

Powered by FluxBB