You are not logged in.

#1 2020-02-10 14:44:33

jjanderson5
Member
Registered: 2016-05-10
Posts: 92

Turning off session timeout[RESOLVED]

I'm running Crunchbang Helium on a home computer. I often work at my desk and on the computer at the same time. My session keeps timing out. I did a search on the internet and found documentation that said to add the lines:

export TMOUT=0
typeset -r TMOUT

to the file /etc/profile.

I have done this and re-booted, and have also tried setting my login session TMOUT environment variable to 0. No luck, it keeps timing out.

Some has suggested trying:

xset s off

I inserted that statement into my $HOME/.config/openbox/autostart file, but that did not solve my problem either.

Can someone help me to turnoff the timeout? BTW, I am the only one with access to the computer, so security is not an issue.

Jim A.

Last edited by jjanderson5 (2020-02-11 22:13:15)

Offline

#2 2020-02-10 15:35:18

damo
....moderator....
Registered: 2015-08-20
Posts: 6,044

Re: Turning off session timeout[RESOLVED]

Do you mean the login screen appears after a while, on your Bunsenlabs Helium installation?

Menu -> Preferences -> Power management -> Display and change the timeouts as preferred.


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#3 2020-02-10 16:06:24

rbh
Member
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 447

Re: Turning off session timeout[RESOLVED]

Or maybe Tab Security: set "Lock session automaticley" to "Never"?


// Regards rbh

Offline

#4 2020-02-10 16:34:49

Sector11
Conky 1.9er Mod Squid
From: Upstairs
Registered: 2015-08-20
Posts: 6,154

Re: Turning off session timeout[RESOLVED]

OR are you talking the screen goes black after a while?

In your OB autostart file add these lines:

### Stop screen from going black ###
(xset -dpms && xset s off) &

Has worked for me since #! days.

I do NOT have a laptop and do not want my desktop screen going black.

I turn my computer on, leave it on all day, I want my monitor on and seen!  big_smile

Last edited by Sector11 (2020-02-10 16:36:04)


The sun will never set if you keep walking towards it. - my son
Being positive doesn't understand physics.
_______________________________
Debian 10 Buster = SharpBang ♯!

Online

#5 2020-02-10 18:49:23

jjanderson5
Member
Registered: 2016-05-10
Posts: 92

Re: Turning off session timeout[RESOLVED]

@damo

yes, my problem is that I get logged out and I am continually having to log back in again while I am still sitting at the desk.

@rbh

Or maybe Tab Security: set "Lock session automaticley" to "Never"?

That sounds like it may be what I am looking for, but I'm not sure exactly what you mean when you say

Tab Security: set

It sounds like I need to set something, but I'm not sure where to go to set it.

@Sector11

OR are you talking the screen goes black after a while?

I can live with the screen going blank, but what you have suggested will be useful. There are times when I will want to keep the screen alive, but having to log in over, and over and over has me climbing the walls smile

Thanks to all of you. I'm hoping rbh's thread will lead me to the solution.

Jim A.

Offline

#6 2020-02-10 19:20:51

Jimbo_G
Member
From: France
Registered: 2017-05-12
Posts: 168

Re: Turning off session timeout[RESOLVED]

That sounds like it may be what I am looking for, but I'm not sure exactly what you mean when you say

Tab Security: set

It sounds like I need to set something, but I'm not sure where to go to set it.

It's in the same place as mentioned by damo, just in the "Security" tab rather than the "Display" tab:
Menu -> Preferences -> Power management -> Display
Menu -> Preferences -> Power management -> Security

Offline

#7 2020-02-11 22:14:01

jjanderson5
Member
Registered: 2016-05-10
Posts: 92

Re: Turning off session timeout[RESOLVED]

Got it!  Thank you to all for the help.

Jim A.

Offline

#8 2020-02-11 22:29:12

Sector11
Conky 1.9er Mod Squid
From: Upstairs
Registered: 2015-08-20
Posts: 6,154

Re: Turning off session timeout[RESOLVED]

Can you explain what you did in case other have the same problem.


The sun will never set if you keep walking towards it. - my son
Being positive doesn't understand physics.
_______________________________
Debian 10 Buster = SharpBang ♯!

Online

Board footer

Powered by FluxBB