You are not logged in.

#1 2020-01-29 22:53:26

Sector11
Conky 1.9er Mod Squid
From: Upstairs
Registered: 2015-08-20
Posts: 6,396

Thunar - get back the "Execute" command for scripts

It was driving me crazy ... talked with Uncle GUGL who sent me to Linux Mint where it was said:

The linked post quoted here for convience:

xenopeek wrote:

How to fix Thunar not having option to run scripts

Post by xenopeek » Wed Aug 12, 2015 1:49 am
Linux Mint 17.2 ships with Thunar 1.6.10. You may have noticed you can no longer run executable text files (scripts) by double-clicking them in your file manager. It will always open the file in a text editor. There is no longer an option in the preferences windows of Thunar to change this behavior.

This behavior and you not being able to change it through Thunar preferences was an intentional change in Thunar 1.6.5. See the release notes at https://github.com/xfce-mirror/thunar/b ... /NEWS#L133 and the bug comments at https://bugzilla.xfce.org/show_bug.cgi?id=7596#c15. As I understand it this is a security measure. I'm not aware of what future plans for this are.

There is a hidden setting you can set to override this. Open "Settings Editor" from your menu or run the command xfce4-settings-editor. With the channel thunar selected in the left sidebar, click on New and add with:

  • name = /misc-exec-shell-scripts-by-default (mind the leading slash!)

  • type = Boolean

  • value = TRUE


(Other hidden Thunar settings documented here: http://docs.xfce.org/xfce/thunar/hidden-settings)

Double-clicking a script will run it and you can still edit it by right-clicking it and selecting to open it with your text editor. Possibly there is an alternative solution for this with a custom action script, perhaps somebody can add that if they know how.

First I had to install: xfce4-settings

Now I can click on my 150+ "ssc-name.sh" files

SSC-name = Start Stop Conky bash scripts


The sun will never set if you keep walking towards it. - my son
Being positive doesn't understand physics.
_______________________________
Debian 10 Buster = SharpBang ♯!

Offline

#2 2020-01-30 00:49:48

damo
....moderator....
Registered: 2015-08-20
Posts: 6,268

Re: Thunar - get back the "Execute" command for scripts

Or do this, without having to install the GUI frontend for xconf, (xfce4-settings):

First, close thunar with

thunar -q

then

xfconf-query --channel thunar --property /misc-exec-shell-scripts-by-default --create --type bool --set true

Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#3 2020-01-30 00:58:53

Sector11
Conky 1.9er Mod Squid
From: Upstairs
Registered: 2015-08-20
Posts: 6,396

Re: Thunar - get back the "Execute" command for scripts

^^ Did not know and searching found the other method.

Two ways better than no way.


The sun will never set if you keep walking towards it. - my son
Being positive doesn't understand physics.
_______________________________
Debian 10 Buster = SharpBang ♯!

Offline

Board footer

Powered by FluxBB