You are not logged in.

#1 2019-12-11 00:48:20

no
Member
From: PDX, OR, USA
Registered: 2019-11-26
Posts: 5

[SOLVED] syndaemon won't disable touchpad

Hi y'all!

So I spend the majority of my time in front of this machine learning to code in Python.
Yay for me!

But oh is it ever super aggravating and frustrating when I am a hundred lines in,
typing faster than I can think, and suddenly the heel of my hand ever so slightly brushes
my touchpad and somehow 14 lines of code are highlighted and replaced with whatever I was
in the process of typing.

It's not irreversible but it really destroys my flow every time.
I should modify my typing posture, but I know syndaemon in the autostart script should
be making this problem moot. But it's not. Nor does it have an affect when I manually call
'syndaemon -i .5 -K -t -R -d &'
in the terminal.

I've disabled touchpad drivers thinking there might be a couple installed and syndaemon is defaulting
to one that's not actually utilized, and quickly found that not to be the case.

On my older, much crappier Dell, I would just use synclient or xinput commands to manually switch
the touchpad off, but those same commands aren't effective on this machine.

My time spent trying to install/configure/run AL has me trained like a dog to exhaust all internet
resources and to really flex my Google-fu before running to forums to beg answers, but I'm kinda
at a loss.

I'm running Helium/AMD64 stable on a Lenovo Thinkpad T530.

Any and all help will be greatly appreciated, and I may even write you a two minute song
about how much it rains here and how dark it is at 4 pm.
Giri-1.jpg

Last edited by no (2019-12-11 05:40:38)


¯\_(ツ)_/¯

Offline

#2 2019-12-11 03:11:44

damo
....moderator....
Registered: 2015-08-20
Posts: 5,403

Re: [SOLVED] syndaemon won't disable touchpad

Anything here to help? Debian SynapticsTouchpad

libinput is now the preferred driver for touchpads, but synclient (synaptics) is easier to configure and has more options ATM.

See also /usr/share/X11/xorg.conf.d/70-synaptics.conf

You can get info of your setup with

synclient -l
or
sudo libinput list-devices

For example with libinput I get

Device:           SynPS/2 Synaptics TouchPad
...
Disable-w-typing: enabled

Some info on configuration here: LibinputTouchpad
and a thread here might offer some ideas.

A workaround in this post: https://forums.bunsenlabs.org/viewtopic.php?pid=84525


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

#3 2019-12-11 04:31:23

no
Member
From: PDX, OR, USA
Registered: 2019-11-26
Posts: 5

Re: [SOLVED] syndaemon won't disable touchpad

Ah, we meet again!

The link you posted containing the workaround as posted in this forum I somehow missed entirely. That user's workaround attached to a keybinding is working perfectly.

I had hoped to just have the functionality of the touchpad arrested while typing as a more automated function is always easier, but

synclient TouchpadOff=$(synclient -l | grep -c 'TouchpadOff.*=.*0')

emulates the the synclient and xinput commands I used on my older machine in effect, which is good enough for me.

I intend on working in vim or Emacs, and I already use keybindings as well as mostly terminal for everything else. While I also have the little red nub ubiquitous on all thinkpads, I do enjoy the speed of movement and mutlitouch gestures the touchpad affords me enough to want to be able to use it when necessary.

I didn't catch the bash file at the end of the Ubuntu Forums thread when I initially ran across it (I did flex my Google-fu, I swear!), which seems to be a great and almost as simple work around as well.

Looks like I need to limber up my search function skills; the Arch gurus would be scowling at me for letting the information you provided drop through my net.

Thanks, damo. I'll have a song for you forthcoming.

*edit*
for anyone who is interested, I added this to the end of the keybindings in my rc.xml, right before </keyboard>:

    <keybind key='A-space'>
    <action name='Execute'>
        <command>bash -c "synclient TouchpadOff=$(synclient -l | grep -c 'TouchpadOff.*=.*0')"</command>
    </action>
</keybind>

Last edited by no (2019-12-11 05:10:25)


¯\_(ツ)_/¯

Offline

#4 2019-12-11 05:37:10

damo
....moderator....
Registered: 2015-08-20
Posts: 5,403

Re: [SOLVED] syndaemon won't disable touchpad

If you think you have sorted your problem, then you can edit the title of your first post and add "[SOLVED]"


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

Board footer

Powered by FluxBB