You are not logged in.

#1 2019-12-01 10:08:42

Martin
Member
From: Stockholm, Sweden
Registered: 2015-10-01
Posts: 376
Website

Caps Lock and Numpad preferences don' work any longer

In my .config/openbox/autostart I have

## Disable CapsLock
setxkbmap -option ctrl:nocaps

and

## Numlock added by MS 190107
numlockx on

This used to work fine but now it doesn't. By "now" I mean after migrating to Debian Buster. I guess there must be some additional setting I need to add somewhere but what? I have browsed my pre-Buster backup for clues but to no avail so far.

/Martin


"Problems worthy of attack
prove their worth by hitting back."
Piet Hein

Offline

#2 2019-12-01 13:07:22

damo
....moderator....
Registered: 2015-08-20
Posts: 5,272

Re: Caps Lock and Numpad preferences don' work any longer

I'm using Buster, and numlockx works fine. What happens when you do

numlockx status
numlockx toggle
numlockx status

Did you upgrade BL as well as migrating to Buster? If so, you may now be using a different BL Openbox session, with the new autostart: ~/.config/bunsen/autostart. (You can use the Helium setup by choosing the Openbox session at the log-in screen)


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

#3 2019-12-01 20:55:32

Martin
Member
From: Stockholm, Sweden
Registered: 2015-10-01
Posts: 376
Website

Re: Caps Lock and Numpad preferences don' work any longer

numlockx was not installed...

But that does not explain why the setxkbmap command does not work. It does when I try it out manually.

I was (re-)installing Helium and then switched to Debian Buster right away. How do I check what Openbox session is running and how could that matter as I only have one .config/openbox/autostart file.

/Martin


"Problems worthy of attack
prove their worth by hitting back."
Piet Hein

Offline

#4 2019-12-01 21:54:28

damo
....moderator....
Registered: 2015-08-20
Posts: 5,272

Re: Caps Lock and Numpad preferences don' work any longer

Martin wrote:

numlockx was not installed...

But that does not explain why the setxkbmap command does not work. It does when I try it out manually.

I was (re-)installing Helium and then switched to Debian Buster right away. How do I check what Openbox session is running and how could that matter as I only have one .config/openbox/autostart file.

/Martin

I don't have answer for setxkbmap, sorry.

If you haven't upgraded from the BL test repos then you won't have the new BL-session setup. At the login screen there should be a settings icon at the top right, where your possible user session options are displayed in a dropdown list. If it says "Openbox" then that is what you can run...

(The next release will use .config/bunsen/autostart in a bunsenlabs session by default, although you can still choose Openbox session instead, which uses .config/openbox/autostart)


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

#5 2019-12-01 22:28:09

damo
....moderator....
Registered: 2015-08-20
Posts: 5,272

Re: Caps Lock and Numpad preferences don' work any longer

But that does not explain why the setxkbmap command does not work. It does when I try it out manually.

It seems that in the past some found that the command in autostart needed a sleep to work during the login process. So maybe try

(sleep 3;setxkbmap -option ctrl:nocaps)&

Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

#6 2019-12-02 04:40:32

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 6,088
Website

Re: Caps Lock and Numpad preferences don' work any longer

^I had to do that with some keyboard tweak (using CapsLock as Compose), but it also seemed sometimes to drop out during a session - no idea why. If there's no-one else using your computer who would need different keyboard settings then it would be more robust to add something to /etc/default/keyboard.
(I added: XKBOPTIONS="compose:caps" )


John
--------------------
( a boring Japan blog, idle Twitterings and GitStuff )
In case you forget, the rules.

Offline

#7 2019-12-02 07:21:17

Martin
Member
From: Stockholm, Sweden
Registered: 2015-10-01
Posts: 376
Website

Re: Caps Lock and Numpad preferences don' work any longer

It seems installing numlockx also fixed my Caps Lock issue. This is at least what a quick test just now indicates.

Apropos drop out during session. I have noticed lately that my system totally ignores the keyboard mid session. It has happened twice so far and within the last week or so. The mouse still works and the keyboard LEDs are still on but there is no response at all when I type. A little later all is well again.

Maybe an USB thing since I have started to 'loose' USB sticks (well a Sansa Clip to be precise so strictly not a stick) mid session -- just gone from the file manager.

/Martin


"Problems worthy of attack
prove their worth by hitting back."
Piet Hein

Offline

#8 2019-12-03 18:56:08

Martin
Member
From: Stockholm, Sweden
Registered: 2015-10-01
Posts: 376
Website

Re: Caps Lock and Numpad preferences don' work any longer

This Caps Lock thing is odd. It did not work this morning so I added the sleep instruction. Now it seems to work every second time I boot my computer.

??

/Martin


"Problems worthy of attack
prove their worth by hitting back."
Piet Hein

Offline

#9 2019-12-03 20:05:51

damo
....moderator....
Registered: 2015-08-20
Posts: 5,272

Re: Caps Lock and Numpad preferences don' work any longer

Martin wrote:

This Caps Lock thing is odd. It did not work this morning so I added the sleep instruction. Now it seems to work every second time I boot my computer.

??

/Martin

Increase the sleep until it works consistently?


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

#10 2019-12-04 07:28:55

Martin
Member
From: Stockholm, Sweden
Registered: 2015-10-01
Posts: 376
Website

Re: Caps Lock and Numpad preferences don' work any longer

I have tried that now but I think something else is going on here. This morning I played around a little and noticed the function of the Caps Lock key is toggling at random even during a session.

/Martin


"Problems worthy of attack
prove their worth by hitting back."
Piet Hein

Offline

#11 2019-12-06 02:51:03

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 6,088
Website

Re: Caps Lock and Numpad preferences don' work any longer

Repeat my suggestion of setting it in /etc/default/keyboard instead:
https://forums.bunsenlabs.org/viewtopic … 551#p94551
I had very similar problems which went away once that was done.


John
--------------------
( a boring Japan blog, idle Twitterings and GitStuff )
In case you forget, the rules.

Offline

Board footer

Powered by FluxBB