You are not logged in.

#1 2019-11-10 17:29:15

eight.bit.al
Member
From: The top of the World
Registered: 2015-10-01
Posts: 376

Dead Link

Dead Link:

Link to now defunct #! forum  RIP

https://forums.bunsenlabs.org/viewtopic.php?id=2009
Post #1

8bit

Last edited by eight.bit.al (2019-11-10 17:30:00)


A mind is a terrible thing not to change.
The problem lies not with new ideas, but in escaping the old ones.

Offline

#2 2019-11-10 18:30:06

rbh
Member
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 88

Re: Dead Link

eight.bit.al wrote:

Dead Link:
Link to now defunct #! forum  RIP

No, it is still upp: https://crunchbang.org/forums/index.php


// Regards rbh

Offline

#3 2019-11-10 18:50:17

twoion
ほやほや
Registered: 2015-08-10
Posts: 2,553

Re: Dead Link

rbh wrote:
eight.bit.al wrote:

Dead Link:
Link to now defunct #! forum  RIP

No, it is still upp: https://crunchbang.org/forums/index.php

What? Are you not getting this problem when browsing there:

Error 400

We're sorry, but we could not fulfill your request for /forums/index.php on this server.

An invalid request was received. If you are using a proxy server, bypass the proxy server or contact your proxy server administrator. This may also be caused by a bug in the Opera web browser.

Your technical support key is: 4d08-ad83-582e-c5e4

You can use this key to fix this problem yourself.

If you are unable to fix the problem yourself, please contact noreply at crunchbang.org and be sure to provide the technical support key shown above.

?


At the end of the river the sundown beams

Offline

#4 2019-11-10 19:53:36

damo
....moderator....
Registered: 2015-08-20
Posts: 5,272

Re: Dead Link

https://crunchbang.org/forums/index.php works for me still. Although many posts are blank sad


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

#5 2019-11-10 20:06:42

twoion
ほやほや
Registered: 2015-08-10
Posts: 2,553

Re: Dead Link

damo wrote:

https://crunchbang.org/forums/index.php works for me still. Although many posts are blank sad

Incredible. I always get a 400 page in Firefox 70.0.1...curl + elinks + chromium 78 works. Must be some SSL ciphers or key exchanges that Mozilla deactivated in Firefox which the server only supports? Because the problem also occurs with a blank profile and no addons...and Qualsys only gives a B mark in the key exchange department.

Well, then things are less wrong than I assumed smile Always thought the #! forum archive was down completely.

Perhaps eight.bit.al sees the same thing (400 error in Firefox)?


At the end of the river the sundown beams

Offline

#6 2019-11-10 20:10:48

damo
....moderator....
Registered: 2015-08-20
Posts: 5,272

Re: Dead Link

I use Palemoon, but I've just tried the link the link with Chromium (OK) and Firefox (400 error).


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

#7 2019-11-10 20:36:36

eight.bit.al
Member
From: The top of the World
Registered: 2015-10-01
Posts: 376

Re: Dead Link

Firefox (400 error).

I was looking for Openbox pipe menu info.

8bit


A mind is a terrible thing not to change.
The problem lies not with new ideas, but in escaping the old ones.

Offline

#8 2019-11-10 22:13:06

twoion
ほやほや
Registered: 2015-08-10
Posts: 2,553

Re: Dead Link

Could reproduce using curl, and probably found the culprit!

Firefox makes the GET request to https://crunchbang.org/forums/index.php with the following headers:

Host: crunchbang.org
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en
Accept-Encoding: gzip, deflate, br
Connection: keep-alive
Upgrade-Insecure-Requests: 1
Pragma: no-cache
Cache-Control: no-cache
TE: Trailers
DNT: 1

resulting in a 400.

Invoking curl with the aforementioned headers also yields the 400 error:

cat >headers <<EOF
Host: crunchbang.org
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en
Accept-Encoding: gzip, deflate, br
Connection: keep-alive
Upgrade-Insecure-Requests: 1
Pragma: no-cache
Cache-Control: no-cache
TE: Trailers
DNT: 1
EOF
curl -H @headers -I https://crunchbang.org/forums/index.php
HTTP/2 400 
server: nginx/1.10.3
date: Sun, 10 Nov 2019 22:04:30 GMT
content-type: text/html; charset=UTF-8

If you remove the line

TE: Trailers

from the headers file, the request is successful!

curl  -H @headers https://crunchbang.org/forums/index.php -I
HTTP/2 200 
server: nginx/1.10.3
date: Sun, 10 Nov 2019 22:06:00 GMT
content-type: text/html; charset=utf-8
set-cookie: bb2_screener_=1573423560+77.8.173.131; path=/
expires: Thu, 21 Jul 1977 07:30:00 GMT
last-modified: Sun, 10 Nov 2019 22:06:00 GMT
cache-control: post-check=0, pre-check=0
pragma: no-cache
content-encoding: gzip

To get the content with the remaining headers

curl -s  -H @headers https://crunchbang.org/forums/index.php | gunzip

Chromium does NOT send this header (see MDN). So I'm wondering if that's a problem with the specific nginx configuration and/or version that is used. Looking to find some hints or bug reports...still not 100% sure if this is a client or a server problem, though. Will ask around.

The TE header is http2 specific, however crunchbang.org is so far the only HTTP2 site giving me this kind of trouble (and a lot of sites do HTTP2 nowadays).


At the end of the river the sundown beams

Offline

#9 2019-11-13 01:14:05

DeepDayze
Member
From: In Linux Land
Registered: 2017-05-28
Posts: 761

Re: Dead Link

Would be nice if there was a setting in Firefox to act similar to Chromium in sending headers...that can fix a lot of issues with FF in accessing HTTP2 sites that are broken.


Real Men Use Linux

Offline

#10 2019-11-13 01:35:25

hhh
Meep!
Registered: 2015-09-17
Posts: 8,743
Website

Re: Dead Link

Try the WayBack Machine...

https://web.archive.org/web/20150907235 … /index.php

BTW, we have a thread on this from 2015, @ohnonot FTW...

https://forums.bunsenlabs.org/viewtopic.php?id=94

Offline

Board footer

Powered by FluxBB