You are not logged in.

#1 2017-12-17 22:32:13

BLizgreat!
Resident Babbler - vll!
Registered: 2015-10-03
Posts: 1,180

Adjusting some of the settings in the ondemand governor, babble style!

First off, am not overly sure in this subject and am still a bit aggravated by how poorly documented this subject is. Certainly isn't going to break anything on your OS, though as yet don't have enough experience with this topic to really know ideal settings or tweaks. First off install the cpufrequtils package and afterwards check out the output of the following command, "cpufreq-info" it lists out much interesting information about your cpu(s), the range of frequencies they have available, the minimum and maximum your cpu(s) are capable of and the current cpu frequency they're at. Even tells you the % of time each cpu has spent in whichever of those frequencies. While running this command, noticed that my dual-core(s) capable of 2.17ghz were staying at 1mhz vast majority of the time, as in 88% or so. Here's my output for it.

cpufreq stats: 2.17 GHz:5.33%, 1.67 GHz:0.00%, 1.33 GHz:94.65%, 1000 MHz:0.02%

Now that I've reset the cpu(s) min freq, as shown below, it's still keeping my cores @ 1.33ghz 94% of the time.

The ondemand governor tends to be default in a great many gnu/Linux OS's, it is in Debian and certainly based as well. However I don't agree with many of the default configuration choices in how it's setup out-of-box and so I endeavored to figure out how to change them. That's what's going to be covered in this babble how-to. In particular in the config files for ondemand, which you'll find at the following location /sys/devices/system/cpu/cpufreq/ondemand/ These 7 files, some googling will explain what each does for anyone curious.

ignore_nice_load default value is 0
io_is_busy default 1
min_sampling_rate 10000
powersave_bias 0
sampling_down_factor 1
sampling_rate 10000
up_threshold 95

Mentioned there are/were a couple things I didn't like and wanted to change. In particular the up_threshold value, 95 means the cpu(s) have to be at 95% load before the frequency gets pushed up, I wanted it at 30% and am now considering 20-25%. I also wanted to increase the minimum frequency in my case from 1mhz to something higher. Though again ... it's a poorly documented subject from what I was able to find.

You'll find min/max and your cpu(s) frequency range in files in the following location. /sys/devices/system/cpu/cpufreq/policy0/, scaling_available_frequencies will list the range of freqs available in your cpu(s) ie: In my case

2167000 1667000 1334000 1000000

The others of interest(to me, this tute) are scaling_max_freq and scaling_min_freq. Which are pretty much what they sound like. Ok so to start, mentioned I intended to raise the min freq from 1mhz ... I opted to put it at the next step up for me, 1.33ghz as shown above = 1334000. To do this I edited the following file (as root) /etc/init.d/cpufrequtils in it there's an uncommented section like so.

ENABLE="true"
GOVERNOR="ondemand"
MAX_SPEED="0"
MIN_SPEED="0"

I changed it to be ...

ENABLE="true"
GOVERNOR="ondemand"
MAX_SPEED="2167000"
MIN_SPEED="1334000"

Whatever you set the max/min above there to, apparently has to be one of the frequencies available in your scaling_available_frequencies file, at least that's what the docs indicated.

After a reboot, ran "cpufreq-info" again and sure enough both cpu-cores are now showing up as "current CPU frequency is 1.33 GHz." Well this solved one part of the puzzle. Next up, how to reset the value of ondemands up_threshold. To do this I opted to get rc.local working in Debian Stretch. Which gratefully doesn't take much. Basically all I had to do was create it (as root again) in /etc/rc.local (that being create a file named rc.local in that location)then chmod'ed the sucker "sudo chmod +x /etc/rc.local" to make it executable.

Here's the contents of my rc.local file.

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

echo 30 > /sys/devices/system/cpu/cpufreq/ondemand/up_threshold

exit 0


The line above in bold is the one that echo's the value I wanted to the up_threshold file at that location. Then just to be sure used systemd's systemctl command to enable the rc-local.service so it starts at boot and then start it, although it would've started at next boot anyway.

Enable rc-local.service

sudo systemctl enable rc-local.service

Start it with ...

sudo systemctl start rc-local.service

Next reboot checked the up_threshold file with "cat /sys/devices/system/cpu/cpufreq/ondemand/up_threshold" Sure enough returns the expected value of 30 in the output and I have noticed more shifting in cpu frequencies, though still have much to learn and tweak in regards to additional settings. Also as mentioned thinking of lowering the up_threshold further and perhaps bumping up the cpu-cores minimum frequency to the next highest up. Though it's a start, not all that big a gain, system seems a tad more responsive overall though, shrugs and not much by way of change in temps/sensors, load avgs/top etc. Still need to tweak things and try different settings/values for them.

That's a wrap fellow nixers n Vll! smile

Offline

#2 2017-12-17 22:46:56

BLizgreat!
Resident Babbler - vll!
Registered: 2015-10-03
Posts: 1,180

Re: Adjusting some of the settings in the ondemand governor, babble style!

Bonus babble, well ... errr, yeah I guess.

Check what driver is in use, it'll be listed in the output of "cpufreq-info" For me it's

driver: acpi-cpufreq

I also checked with "lsmod |grep cpu" and it listed that several governors kernel modules were loading, even though they weren't in use. I actually have ondemand and the performance governor built into the custom kernel I compiled for this old laptop but I was getting this ...

cpufreq_userspace      16384  0
cpufreq_powersave      16384  0
cpufreq_conservative    16384  0
acpi_cpufreq           20480  1

I didn't want the userspace, powersave or conservative governors, didn't want their modules loading every boot. Not that it costs much by way of additional RAM-etc. So I ended up blacklisting them in the following file "/etc/modprobe.d/intel-microcode-blacklist.conf" it was there by default, so went ahead and used it. Otherwise if a similar file isn't present, it can be created, though it'd be simply blacklist.conf vs what I have on this laptop. Here's the Debian link though notice how dated it is, more recent on the subject is available via google-etc if unsure.

Though I went ahead and added the governor modules in this file, with the following syntax, one module per line.

blacklist cpufreq_userspace
blacklist cpufreq_powersave
blacklist cpufreq_conservative

Yep ... worked, as they no longer show up as loaded when lsmod command is run.

Random update: Though of course these modules can be taken off the blacklist at some later time, if someone were wanting to use them obviously. Atm I don't so on the blacklist they'll stay.

Last edited by BLizgreat! (2017-12-18 15:47:25)

Offline

#3 2017-12-18 02:24:33

BLizgreat!
Resident Babbler - vll!
Registered: 2015-10-03
Posts: 1,180

Re: Adjusting some of the settings in the ondemand governor, babble style!

Also note, you can set more than one of the relevant tweaks via something like rc.local ( or any other way someone were to go about running a script or commands at startup ie: Like an @boot crontab, not sure why I went with rc.local just the way it worked out.) What I mean is my actual rc.local also has another. The snippet taken from the full rc.local contents shown above.

# By default this script does nothing.

echo 30 > /sys/devices/system/cpu/cpufreq/ondemand/up_threshold
echo 20 > /sys/devices/system/cpu/cpufreq/ondemand/sampling_down_factor

exit 0

The sampling_down_factor from what I understand just makes the OS take a bit longer in checking whether it needs to step the cpu(s) frequencies down. Which is also supposed to be good mojo for performance. Atm ... as above have it set to 20, considering increasing it a bit to be like 40 or so.

Last edited by BLizgreat! (2017-12-18 02:25:43)

Offline

#4 2017-12-18 02:37:15

stevep
MX Linux Developer
Registered: 2016-08-08
Posts: 375

Re: Adjusting some of the settings in the ondemand governor, babble style!

You may also note that modern Debian kernels use the p-state driver for modern Intel processors, and that ends up giving us almost nothing to tweak.  Though that can be switched to cpufreq with a simple kernel command at boot time...or the Liquorix kernel still defaults to cpufreq.

Offline

#5 2017-12-18 03:16:16

BLizgreat!
Resident Babbler - vll!
Registered: 2015-10-03
Posts: 1,180

Re: Adjusting some of the settings in the ondemand governor, babble style!

^Yeah mentioned that in the HEY HOAS!!! thread. big_smile Though thanks and thinking the same, that being someone can always fallback to this type of thing. Question is, I have no idea if it's worth it ? I mean if you have a more modern Intel processor, I have zero idea how they stack-up the latest driver vs other approaches. Would be glad to hear your opinion on it stevep ? I mean the p_state situation, worth reverting or does it do it's job well ?

For me this is definitely a work in progress but am happy with the results thus far on this old laptop. Ah still have more questions than answers on this topic. Seen plenty of various suggestions here and there regarding this (different settings and tweaks suggested.) Still overall unsure of what's best and will cross the p_state bridge when I get there.

Gnu/Linux has a new governor on the horizon too this schedutil thing, have it built into this current kernel too, though know less than nothing about it atm. Do know, ondemand on this old box made very lil sense as it was default. Kinda like they were suggesting in order to conserve power on this laptop, I should just downgrade to a single-core, as pretty much the equivalent of 1 full core was almost never being used ? Errrrr, nah ... bought a dual-core for a reason dang it !

Last edited by BLizgreat! (2017-12-18 03:23:45)

Offline

#6 2017-12-18 03:31:37

BLizgreat!
Resident Babbler - vll!
Registered: 2015-10-03
Posts: 1,180

Re: Adjusting some of the settings in the ondemand governor, babble style!

Odd observation about this and system's it applies to, when the up_threshold was left default at 95%, seems that's about how often the top cpu(s) freq was being used, about 5% of the time. Now that I've got it set to 30% seems it hits top end fairly close to that. Well a lil less output of "cpufreq-info" atm.

cpufreq stats: 2.17 GHz:26.54%, 1.67 GHz:0.00%, 1.33 GHz:73.46%, 1000 MHz:0.00%  (7941)

Also kinda disturbed to see that the freq above 1.33ghz is showing 0% usage ? Was under the assumption that ondemand would step up to the next freq when x-load was reached. Though clearly it's not doing that, goes from min to max and skips 1.67ghz altogether. Weird but am still happier with this, as at least the cores are actually getting to use some of this old laptops processing muscle vs sitting idle 88% of the time.

Not really sure I want to but thinking about bumping min freq up to 1.67ghz instead of 1.33. Kind of like it the way it is now, 1.33ghz is a nice back-off and 2.17ghz is a good top-end freq. Still though, not getting why 0% of the freq in-between the two !?!? Maybe I need to increase the up_threshold back to being something like 50% ? Though afterthought guessing that would just result in 1.33ghz being used even more and more of the core(s) not hitting the freq's they should. Arghhhhh, yeah will probably bump it up to 1.67ghz and see how that works out for awhile.


Ah Vll! smile

Yep ... nother random update: Think I get why it was jumping over 1.67ghz. Say something pushed the cpu(s) to like 60% while they were running at 1.33ghz, with the up_threshold set to 30%, think to the ondemand governor it interpreted that as 30% threshold is hit + another 30% threshold hit again = 60%, so it just bumped up to the top freq in response. Also definitely setting it to 50% would've ended up leaving the cpu(s) @ 1.33ghz even more often and I don't like/want that at all.

Last edited by BLizgreat! (2017-12-18 15:50:57)

Offline

#7 2017-12-18 05:38:48

BLizgreat!
Resident Babbler - vll!
Registered: 2015-10-03
Posts: 1,180

Re: Adjusting some of the settings in the ondemand governor, babble style!

This link looks to have some good info about this topic, dated 2014 though. Still interesting to look over and as usual READ THE COMMENTS ! tongue A snippet from one person at the time.

Something is really wrong with scaling governors on linux... hmm How can "On-demand" be faster and much more power consuming than "Performance"? What kind of bulls**t is this?

Priceless ! big_smile

Still have much dorking to do, to even somewhat understand all this. Though again, have to say, based on the stats I was seeing from "cpufreq-info" not at all happy with default ondemand. All this time, I've been assuming by increases cpu freq's based on workload, meant it was doing a 1/2 arse job of doing it well. Which clearly is NOT the case fellow nixers ! Arghhhh.

Still with enough dorking around and googling, it's showing progress. Still many things to tweak and play with, still much happier with it overall with a bit of optimization too. Also not like these can't be easily switched between for a given situation etc.

Offline

#8 2017-12-18 05:46:53

BLizgreat!
Resident Babbler - vll!
Registered: 2015-10-03
Posts: 1,180

Re: Adjusting some of the settings in the ondemand governor, babble style!

Additional griping about this, this is the previous output from "cpufreq-info" on this old laptop and while on AC adapter too.

analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  hardware limits: 1000 MHz - 2.17 GHz
  available frequency steps: 2.17 GHz, 1.67 GHz, 1.33 GHz, 1000 MHz
  available cpufreq governors: userspace, powersave, conservative, ondemand, performance, schedutil
  current policy: frequency should be within 1000 MHz and 2.17 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 1.09 GHz.
  cpufreq stats: 2.17 GHz:3.35%, 1.67 GHz:2.06%, 1.33 GHz:7.63%, 1000 MHz:86.96%  (21406)
analyzing CPU 1:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 1
  CPUs which need to have their frequency coordinated by software: 1
  maximum transition latency: 10.0 us.
  hardware limits: 1000 MHz - 2.17 GHz
  available frequency steps: 2.17 GHz, 1.67 GHz, 1.33 GHz, 1000 MHz
  available cpufreq governors: userspace, powersave, conservative, ondemand, performance, schedutil
  current policy: frequency should be within 1000 MHz and 2.17 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 1.32 GHz.
  cpufreq stats: 2.17 GHz:3.69%, 1.67 GHz:2.05%, 1.33 GHz:8.61%, 1000 MHz:85.65%  (21775)

So again ... judging from that, I may have well been on a single-core pc 85% of the time !??!!! hmm

With some tweakage: (the aforementioned changes.)

analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  hardware limits: 1000 MHz - 2.17 GHz
  available frequency steps: 2.17 GHz, 1.67 GHz, 1.33 GHz, 1000 MHz
  available cpufreq governors: ondemand, performance, schedutil
  current policy: frequency should be within 1.33 GHz and 2.17 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 1.33 GHz.
  cpufreq stats: 2.17 GHz:14.04%, 1.67 GHz:0.00%, 1.33 GHz:85.95%, 1000 MHz:0.01%  (3165)
analyzing CPU 1:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 1
  CPUs which need to have their frequency coordinated by software: 1
  maximum transition latency: 10.0 us.
  hardware limits: 1000 MHz - 2.17 GHz
  available frequency steps: 2.17 GHz, 1.67 GHz, 1.33 GHz, 1000 MHz
  available cpufreq governors: ondemand, performance, schedutil
  current policy: frequency should be within 1.33 GHz and 2.17 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 1.40 GHz.
  cpufreq stats: 2.17 GHz:16.33%, 1.67 GHz:0.00%, 1.33 GHz:83.65%, 1000 MHz:0.01%  (3653)

Somewhat better but still not great, arghhhh !!!

Last edited by BLizgreat! (2017-12-18 05:53:11)

Offline

#9 2017-12-18 13:50:51

BLizgreat!
Resident Babbler - vll!
Registered: 2015-10-03
Posts: 1,180

Re: Adjusting some of the settings in the ondemand governor, babble style!

Random babble update: This is more a tip kind of thread than a how-to I guess. Though did go ahead and bump up min freq to the next step up, 1.67ghz and settings in rc.local now set to this.

echo 40 > /sys/devices/system/cpu/cpufreq/ondemand/up_threshold
echo 40 > /sys/devices/system/cpu/cpufreq/ondemand/sampling_down_factor

Liking this better, at least for default ondemand config. Idea being that yeppers, at least my cpu(s) are staying at a reasonable freq 3.34ghz majority of the time, keeping 1ghz in reserve(max freq 4.34ghz), so they aren't going full throttle all the time either. Anything pushes the processor beyond 40% at these settings figure may as well tell it to go ahead and step on the gas for awhile. big_smile Also want to calm all this stupe freq jumping all over the place activity, want it to stay at a reasonable speed consistently but scale up to it's max when/if needed. Without all the ping-ponging around the frequency range. Think something like that has to be a tad harder on the cpu(s). Now it looks like about 80% 1.67 +/- 20% 2.17ghz. Feel this is better.

Still have to play around with the sampling rate and the sampling_down_factor to hopefully find a sweet spot for them and a few other config's, though now am much happier with the setup and there is a noticeable difference in applications response time etc. Kinda painfully obvious now that I'm aware of what was going on, running a dual-core pc/laptop, like it's a single just would never make sense to me. Still clearly much to learn about this and associated subjects but am a happier dork and hopefully this inspires some others to optimize or take more of an interest in such junk to get better computing for themselves too.

Vll! smile

Last edited by BLizgreat! (2017-12-18 14:37:00)

Offline

#10 2017-12-23 00:39:44

BLizgreat!
Resident Babbler - vll!
Registered: 2015-10-03
Posts: 1,180

Re: Adjusting some of the settings in the ondemand governor, babble style!

More general babblings about the ondemand governor and optimizing it or setting it up as x-user prefers. Again ... not at all happy with the defaults choosen for it and frustrated by how poorly documented it seems to be, so here goes.

Contents of /etc/rc.local are now as follows:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

echo 40 > /sys/devices/system/cpu/cpufreq/ondemand/up_threshold
echo 5 > /sys/devices/system/cpu/cpufreq/ondemand/sampling_down_factor
echo 100000 > /sys/devices/system/cpu/cpufreq/ondemand/sampling_rate

exit 0

Explanation and some general info about these files and values. Ok well as noted up_threshold is the percentage of the cpu-load a systems processor(s) have to be under for ondemand to decide to increase frequency, in the above I elected 40%.

Sampling_down_factor is a multiple of whatever value is set for sampling_rate, so in my case that's 100000 x/times 5 = 500000, sampling_rate is calculated in microseconds, 1/1000000th of a sec !!! So 500k = 1/2 sec. Sampling_down_factor is how often the governor checks to see if the cpu/cores freq's should be lowered.

Sampling_rate, this is the file where you actually can choose your processor(s) sampling rate, that being how often cpu load is checked to determine if the cpu-freq's should be increased. Again ... in microseconds, so 100000 = 1/10th of a sec. As for the other file in /sys/devices/system/cpu/cpufreq/ondemand named min_sampling_rate, apparently this is set by the bios or hardware, as it cannot be adjusted itself. It's just telling you the absolute minimum sampling rate that system can handle. On this laptop it was set to 10000 default. Which is ridiculously fast eh, 1/100th of a sec.

Took a bit of digging around to even determine the unit of time ondemand uses, though seen enough credible sources of info on it to conclude that yes, it's in microseconds.

Offline

#11 2017-12-23 01:57:59

BLizgreat!
Resident Babbler - vll!
Registered: 2015-10-03
Posts: 1,180

Re: Adjusting some of the settings in the ondemand governor, babble style!

Also am not advocating these particular values/settings. Still an ongoing dork project and am playing around with them for the time being. Seems to me these are some of the key files someone will want to dork with, should they want to adjust or optimize ondemand's settings as they come out-of-box.

Last edited by BLizgreat! (2017-12-23 02:06:18)

Offline

#12 2017-12-24 21:23:07

BLizgreat!
Resident Babbler - vll!
Registered: 2015-10-03
Posts: 1,180

Re: Adjusting some of the settings in the ondemand governor, babble style!

More updated babble, as mentioned work in progress. Kinda did a bit of about face on this. Present settings are currently this in rc.local.

echo 25 > /sys/devices/system/cpu/cpufreq/ondemand/up_threshold
echo 5 > /sys/devices/system/cpu/cpufreq/ondemand/sampling_down_factor
echo 50000 > /sys/devices/system/cpu/cpufreq/ondemand/sampling_rate

I went ahead and set minimum cpu/core freq back down to 1.33ghz as it seemed wasteful to me to have it always running at 166 anyway. Wasn't really necessary most the time for it to stay at that freq, so more heat/stress on my old cpu(s) for no reason. Though also went ahead and lowered the up_threshold too, so it bumps up to max freq sooner when needed. Now output of "cpufreq-info" looks as follows ...

current CPU frequency is 2.16 GHz.
  cpufreq stats: 2.17 GHz:13.34%, 1.67 GHz:0.00%, 1.33 GHz:86.66%, 1000 MHz:0.01%  (2373)

Generally now uses max freq about 20% or so of the time and that lower freq +/- 80%. Liking this better overall. Plenty fast, reasonable compromise between running full out and staying at lower freq's and thus would be conserving power and reducing heat-etc when it's not needed. Output of "iostat -c", tells me my cpu(s) are idle 90% or so of the time.

Last edited by BLizgreat! (2017-12-24 21:24:48)

Offline

#13 2017-12-24 22:51:55

BLizgreat!
Resident Babbler - vll!
Registered: 2015-10-03
Posts: 1,180

Re: Adjusting some of the settings in the ondemand governor, babble style!

Actually liking it as mentioned, this setup is like a cross between performance and the ondemand governor's, me likey. Also one thing about up_threshold, believe when this is reached, that tells the ondemand governor to hit max core freq, obviously there has to be incremental calculations in there which tell it to increase freq to something in between on that freq-scale to the next highest freq. Not exactly sure how it works or what the stats involved are though.

Overall don't really care, I like it this way for now. While again ... it's also easy enough to set it to another governor if someone wants and quickly switch between them. Sticking with this for the time being.

vll! smile

Last edited by BLizgreat! (2017-12-24 22:53:44)

Offline

#14 2019-10-26 07:39:49

BLizgreat!
Resident Babbler - vll!
Registered: 2015-10-03
Posts: 1,180

Re: Adjusting some of the settings in the ondemand governor, babble style!

Random babble update for this nonsense. Mentioned am opting to use cpufrequtils, even though it's really outdated and there are many newer with hopefully improved features but anyway on with the babble.

Decided to go ahead and cap out a max freq in /etc/init.d/cpufrequtils as mentioned in the junk above it needs to be one of the available freq shown in the relevant file. This is the pertinent part of the file.

ENABLE="true"
GOVERNOR="ondemand"
MAX_SPEED="1667000"
MIN_SPEED="0"

Clearly opting for the ondemand power governor there. Also the MAX speed I set is one step down from the max-freq available on this dual-core laptop. Here's the output of "cpufreq-info".

cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  hardware limits: 1000 MHz - 2.17 GHz
  available frequency steps: 2.17 GHz, 1.67 GHz, 1.33 GHz, 1000 MHz
  available cpufreq governors: ondemand, performance, schedutil
  current policy: frequency should be within 1000 MHz and 1.67 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 998 MHz.
  cpufreq stats: 2.17 GHz:0.14%, 1.67 GHz:15.23%, 1.33 GHz:4.81%, 1000 MHz:79.82%  (14691)
analyzing CPU 1:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 1
  CPUs which need to have their frequency coordinated by software: 1
  maximum transition latency: 10.0 us.
  hardware limits: 1000 MHz - 2.17 GHz
  available frequency steps: 2.17 GHz, 1.67 GHz, 1.33 GHz, 1000 MHz
  available cpufreq governors: ondemand, performance, schedutil
  current policy: frequency should be within 1000 MHz and 1.67 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 1.33 GHz.
  cpufreq stats: 2.17 GHz:0.14%, 1.67 GHz:16.19%, 1.33 GHz:4.75%, 1000 MHz:78.91%  (15120)

Reason for doing this jazz ? Was just decided there's no reason for hitting 2.17ghz very often. Just didn't/don't want the extra heat and note that the cpu-cores are staying at the lowest freq almost 80% of the time anyway here. Really no point to this post, am just babbling. smile

Offline

#15 2019-11-12 03:40:42

BLizgreat!
Resident Babbler - vll!
Registered: 2015-10-03
Posts: 1,180

Re: Adjusting some of the settings in the ondemand governor, babble style!

Me again ... this topic is still a massive pain in de arse and hopefully as noted (SteveP etc) the Intel pstate driver makes this unnecessary on newish Intel chips. Can fiddle endlessly with this and still won't be so much satisfied or sure I'm going with the best, more appropriate settings in it's config's. No matter what I do dang it ! Making it so a 2.17ghz core, never gets to use that speed is also somewhat stupid in my view. Am going for a balance between performance vs unwanted heat and stress on my old laptops cpu-core(s.) Still not overly happy with it and will have to continue messing with it. Oh well ...

Real reason for doubling back to review this nonsense wasn't so much that I wanted to bytch about ondemand (though felt good and feel a bit better. big_smile .)Is really just to mention that I'm planning on doing away with rc.local and switching to the more systemd approved methods of doing what it did. Leaves me/you with a couple of choices. Creating a systemd unit/service file or an @reboot crontab to run a script. Haven't exactly decided which at the moment though. May update babble tute at such time as I do and have a solid understanding of setting them up.

Okay, hope all the good nixers here are doing well and having a good dy/night-both. See ya's fellow nixers. smile

Offline

Board footer

Powered by FluxBB