You are not logged in.

#1 2019-10-02 09:57:26

Registered: 2015-09-30
Posts: 49

[SOLVED] Set xorg video driver

Hi Bunsen team! Im configuring Helium in my new laptop. Video works and X starts correctly, but i cant set brightness (/sys/class/backlight/ is empty) and cant change resolution using ARandR tool.
This is the output of xrand.

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1920 x 1080, current 1920 x 1080, maximum 1920 x 1080
default connected 1920x1080+0+0 0mm x 0mm
   1920x1080     77.00* 

Ubuntu detects all resolutions and not use defualt name, eDP1 instead.

This is the VGA section of lspci -knn output:

00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:3185] (rev 03)
	Subsystem: Intel Corporation Device [8086:2212]
00:0e.0 Audio device [0403]: Intel Corporation Device [8086:3198] (rev 03)
	Subsystem: Device [1c6c:122a]
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel

Not show kernel driver in use line, but Ubuntu shows i915 driver.

I have installed last version of packages firmware-misc-nonfree and xserver-xorg-video-intel.

This is the output of modinfo i915:

filename:       /lib/modules/4.9.0-11-amd64/kernel/drivers/gpu/drm/i915/i915.ko
license:        GPL and additional rights
description:    Intel Graphics
author:         Intel Corporation
author:         Tungsten Graphics, Inc.
firmware:       i915/bxt_dmc_ver1_07.bin

But when i try to load the module i get an error:

insmod /lib/modules/4.9.0-11-amd64/kernel/drivers/gpu/drm/i915/i915.ko
insmod: ERROR: could not insert module /lib/modules/4.9.0-11-amd64/kernel/drivers/gpu/drm/i915/i915.ko: Unknown symbol in module

Any suggestions? Thanks!

Last edited by pepemopap (2019-10-02 10:47:32)


#2 2019-10-02 10:48:40

Registered: 2015-09-30
Posts: 49

Re: [SOLVED] Set xorg video driver

Ok, I solve it updating to kernel 4.19.67-2~bpo9+1 from Debian Stretch backports.
Touchpad works too (not in 4.9).
Thanks to all.


Board footer

Powered by FluxBB