You are not logged in.

#1 2019-08-04 10:03:10

woof
Member
Registered: 2015-10-01
Posts: 32

[SOLVED] lubuntu drop down menu not displaying correctly

Hi,
Im having trouble with some applications in lubuntu not displaying menus properly. Only a few apps have had this problem, things Ive downloaded not the standard lubuntu apps.
The picture shows a black box where the help menu should be. Right click menu shows as a black box too.

mz96Izbm.jpg

In the past when I have had this problem I have tried to find a solution to no avail so I have had to abandon the affected software. Then it happened again today when I installed  OPENSCAD and I thought maybe some BL users have a solution. Any advice appreciated, thank you.

Ubuntu 18.04.2 LTS
-Display-
Resolution        : 2560x1440 pixels
Vendor        : The X.Org Foundation
Version        : 1.19.6
Current Display Name        : :0.0
-Monitors-
Monitor 0        : 2560x1440 pixels
-OpenGL-
Vendor        : nouveau
Renderer        : NV134
Version        : 4.3 (Compatibility Profile) Mesa 19.0.2
Direct Rendering        : Yes

Last edited by woof (2019-08-05 04:56:21)

Offline

#2 2019-08-04 11:17:44

malm
jgmenu developer
Registered: 2016-10-13
Posts: 531
Website

Re: [SOLVED] lubuntu drop down menu not displaying correctly

Does it apply to Qt apps only?

Have you set any variables with * in Xresources?

Or try starting with different theme.

Offline

#3 2019-08-04 12:33:51

woof
Member
Registered: 2015-10-01
Posts: 32

Re: [SOLVED] lubuntu drop down menu not displaying correctly

HI, thanks, It could be just Qt apps, it happens in qps, I cant find other examples. I have next to zero knowledge of Xresources, wouldnt know where to start. The theme made no change ill try reboot.

Offline

#4 2019-08-04 15:44:57

malm
jgmenu developer
Registered: 2016-10-13
Posts: 531
Website

Re: [SOLVED] lubuntu drop down menu not displaying correctly

I’m a bit out of touch with Lubuntu. Are you running LXDE or LXQT?

Try installing some other qt apps to determine if that the common denominator.

If you post your ~/.Xresources
that give us a clue (but I might be barking up the wrong tree).

I’ve seen problems before with Qt and .Xresources lines beginning with *

Offline

#5 2019-08-04 16:32:16

ohnonot
...again
Registered: 2015-09-29
Posts: 4,165
Website

Re: [SOLVED] lubuntu drop down menu not displaying correctly

It looks very much like a themeing problem the sort I'ver had when older GTK3 themes become incompatible with newer GTK3 versions.

What GUI toolkit does OpenSCAD use? GTK? 3 or 2? or Qt? 4 or 5?

Offline

#6 2019-08-05 04:53:48

woof
Member
Registered: 2015-10-01
Posts: 32

Re: [SOLVED] lubuntu drop down menu not displaying correctly

I solved this while looking for Qt apps to try in the software centre. I found Appearance settings for LXQt.  It said it was installed so I launched it and widget style was the first setting I changed, It was set to bb10dark. This was the problem, also bb10bright has the menu problem but a white box. gtk2 is the widget style I chose and problem is gone.

I dont know where i can find that appearance setting for Qt apart from in the software centre. It is unfamiliar to me. When i changed the theme as suggested by malm initially i was changing a setting in Customise look and feel / window border / Theme. This had no effect.

Thanks for the help, much appreciated !

Offline

Board footer

Powered by FluxBB