You are not logged in.

#1 2019-05-16 09:38:17

linux_user
Member
Registered: 2016-11-04
Posts: 338

Basic font redering is thin

The rendering of basic fonts on BL is thin now. Applies to Main menu fonts, file manager fonts, galternative fonts etc. https://imgur.com/a/lDYaptC

I have been trying rxvt-unicode and made some changes in the .Xresources file in terms of fonts, then I did

xrdb -merge ~/.Xresources
xrdb .Xresources

This is the only change pertaining to the fonts I remember doing in my system. Since I have uninstalled urxvt, I have emptied .Xresources file and executed above commands again, but still the fonts are thin.

Edit
``````
The following is the ~/.config/fontconfig/fonts.conf

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
    <match target="font">
        <edit mode="assign" name="hinting" >
            <bool>true</bool>
        </edit>
        <edit mode="assign" name="autohint" >
            <bool>true</bool>
        </edit>
        <edit mode="assign" name="hintstyle" >
            <const>hintslight</const>
        </edit>
        <edit mode="assign" name="rgba" >
            <const>rgb</const>
        </edit>
        <edit mode="assign" name="antialias" >
            <bool>true</bool>
        </edit>
        <edit mode="assign" name="lcdfilter">
            <const>lcddefault</const>
        </edit>
    </match>

<!--
    This section allows the user to define the fonts used for the
    "serif", "sans-serif" and "monospace" aliases.

    These aliases can then be set in lxappearance (the theme-changing
    GUI used by BunsenLabs) and also in individual programs to allow
    this file to be used for desktop-wide font configuration.

    By default, BunsenLabs uses one of these aliases everywhere
    a font needs to be specified. Set your favourite fonts here
    to ensure consistency across your working environment.
    You can still change fonts on a per-application basis if you want.
-->

    <alias>
        <family>serif</family>
        <prefer>
            <family>Noto Serif</family>
        </prefer>
    </alias>
    <alias>
        <family>sans-serif</family>
        <prefer>
            <family>Noto Sans</family>
        </prefer>
    </alias>
    <alias>
        <family>monospace</family>
        <prefer>
            <family>Noto Mono</family>
        </prefer>
    </alias>

</fontconfig>

Noto Sans, Noto Serif and Noto Mono are available in the system. I confirmed it using Libreoffice.

Last edited by linux_user (2019-05-16 11:02:20)


"Blind faith to authority is the greatest enemy of truth."

Offline

#2 2019-05-17 04:50:10

ohnonot
...again
Registered: 2015-09-29
Posts: 3,671
Website

Re: Basic font redering is thin

the screenshot shows an application that currently runs as the root user, i think.
so it doesn't help with user settings.

maybe you want to show us what the thin font problem is?
is the thin font Noto Sans?
some fonts come with ridiculously thin variants, maybe your system chooses that for some reason?

please try to isolate what causes the "thin font issue" - e.g. by renaming ~/.config/fontconfig/fonts.conf or ~/.Xresources.

you shouldn't need to do 'xrdb .Xresources' - the first command you used is usually better.

Offline

Board footer

Powered by FluxBB