You are not logged in.

#1 2018-11-08 12:26:03

cherkie
Member
From: UK(still...)
Registered: 2018-08-09
Posts: 93

Dual monitor set up going crazy when locking screen

I run BL in a VM at work. I have two screen set up.

My xrandr is following:

xrandr --output VGA-1 --mode 1920x1080 --pos 1920x0 --rotate normal --output VGA-2 --primary --mode 1920x1080 --pos 0x0 --rotate normal

And I have added it to autostart as well.

Works great. I use

physlock -u albert

for locking my screen (I have it bound to a key combination) when I step away from my desk. It has been working great until yesterday when I hooked up second monitor.

After I come back to my PC and log in the screens switch places to (presumably) their "native" set up.

Does anyone have an idea how I can fix this?

Thanks

- edit. I have tried swapping the way cables are connected to my PC - same problem.

Last edited by cherkie (2018-11-08 12:48:32)


I don't have patience or skill to dig deep enough every time system breaks itself or when I break something because of lack of patience and skill.
nore, 23 Feb 2019

Offline

#2 2019-05-01 20:49:33

jp734
Member
Registered: 2019-05-01
Posts: 7

Re: Dual monitor set up going crazy when locking screen

I've used a simpler xrandr command for years and never had any problem.

xrandr --auto --output VGA-1 --left-of VGA-2 (change as necessary. you can switch VGA # or use --right-of instead of --left-of)

try and let us know. Good luck

Offline

Board footer

Powered by FluxBB