You are not logged in.

#1 2019-04-13 16:50:57

SunTzuTech
Member
Registered: 2019-04-03
Posts: 6

USB Realtek Wifi not connecting

Have a 300n Realtek USB Wifi Adapter running latest 32-bit PAE. 

I don't see a popup for the WPA key, and I seem to recall seeing a popup during install, but also refused to connect with the correct WPA key.

Per the recommendation, here's info  (2 of the commands don't show relevant info, like the wired via_rhine device)

rfkill list =  0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

dmesg | grep -Ei 'wlan|firmw|dhc' =
[144881.849532] usb 2-4: rtl8xxxu: Loading firmware rtlwifi/rtl8192eu_nic.bin
[144881.882876] usb 2-4: firmware: direct-loading firmware rtlwifi/rtl8192eu_nic.bin
[144881.882943] usb 2-4: Firmware revision 19.0 (signature 0x92e1)
[144883.464520] rtl8xxxu 2-4:1.0 wlx70f11c1a44e7: renamed from wlan0


I removed the info for my via-rhine connected through a wifi-bridge...

cat /var/log/syslog | grep -Ei 'net|wpa|dhc' =

Apr 13 12:14:34 asrocka7vta NetworkManager[387]: <info>  [1555172074.2576] rfkill0: found WiFi radio killswitch (at /sys/devices/pci0000:00/0000:00:10.4/usb2/2-4/2-4:1.0/ieee80211/phy0/rfkill0) (driver rtl8xxxu)
Apr 13 12:14:34 asrocka7vta NetworkManager[387]: <info>  [1555172074.2909] (wlx70f11c1a44e7): using nl80211 for WiFi device control
Apr 13 12:14:34 asrocka7vta NetworkManager[387]: <info>  [1555172074.3312] manager: (wlx70f11c1a44e7): new 802.11 WiFi device (/org/freedesktop/NetworkManager/Devices/3)
Apr 13 12:14:34 asrocka7vta dbus[354]: [system] Activating via systemd: service name='fi.w1.wpa_supplicant1' unit='wpa_supplicant.service'
Apr 13 12:14:34 asrocka7vta systemd[1]: Starting WPA supplicant...
Apr 13 12:14:34 asrocka7vta NetworkManager[387]: <info>  [1555172074.5623] devices added (path: /sys/devices/pci0000:00/0000:00:10.4/usb2/2-4/2-4:1.0/net/wlx70f11c1a44e7, iface: wlx70f11c1a44e7)
Apr 13 12:14:34 asrocka7vta NetworkManager[387]: <info>  [1555172074.5624] device added (path: /sys/devices/pci0000:00/0000:00:10.4/usb2/2-4/2-4:1.0/net/wlx70f11c1a44e7, iface: wlx70f11c1a44e7): no ifupdown configuration found.
Apr 13 12:14:34 asrocka7vta NetworkManager[387]: <info>  [1555172074.5633] device (wlx70f11c1a44e7): state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Apr 13 12:14:34 asrocka7vta kernel: [144883.915441] IPv6: ADDRCONF(NETDEV_UP): wlx70f11c1a44e7: link is not ready
Apr 13 12:14:34 asrocka7vta kernel: [144883.936654] IPv6: ADDRCONF(NETDEV_UP): wlx70f11c1a44e7: link is not ready
Apr 13 12:14:34 asrocka7vta NetworkManager[387]: <info>  [1555172074.6782] device (wlx70f11c1a44e7): set-hw-addr: set MAC address to 16:A9:F9:5D:41:55 (scanning)
Apr 13 12:14:34 asrocka7vta dbus[354]: [system] Successfully activated service 'fi.w1.wpa_supplicant1'
Apr 13 12:14:34 asrocka7vta wpa_supplicant[18180]: Successfully initialized wpa_supplicant
Apr 13 12:14:34 asrocka7vta systemd[1]: Started WPA supplicant.
Apr 13 12:14:34 asrocka7vta kernel: [144884.057761] IPv6: ADDRCONF(NETDEV_UP): wlx70f11c1a44e7: link is not ready
Apr 13 12:14:34 asrocka7vta NetworkManager[387]: <info>  [1555172074.7155] supplicant: wpa_supplicant running
Apr 13 12:14:34 asrocka7vta NetworkManager[387]: <info>  [1555172074.7171] device (wlx70f11c1a44e7): supplicant interface state: init -> starting
Apr 13 12:14:34 asrocka7vta NetworkManager[387]: <info>  [1555172074.7591] sup-iface[0x246a878,wlx70f11c1a44e7]: supports 4 scan SSIDs
Apr 13 12:14:34 asrocka7vta NetworkManager[387]: <info>  [1555172074.7667] device (wlx70f11c1a44e7): supplicant interface state: starting -> ready
Apr 13 12:14:34 asrocka7vta NetworkManager[387]: <info>  [1555172074.7683] device (wlx70f11c1a44e7): state change: unavailable -> disconnected (reason 'supplicant-available') [20 30 42]
Apr 13 12:14:34 asrocka7vta kernel: [144884.121435] IPv6: ADDRCONF(NETDEV_UP): wlx70f11c1a44e7: link is not ready
Apr 13 12:14:35 asrocka7vta wpa_supplicant[18180]: wlx70f11c1a44e7: CTRL-EVENT-REGDOM-CHANGE init=BEACON_HINT type=UNKNOWN
Apr 13 12:14:35 asrocka7vta NetworkManager[387]: <info>  [1555172075.9348] device (wlx70f11c1a44e7): supplicant interface state: ready -> inactive
Apr 13 12:20:17 asrocka7vta NetworkManager[387]: <info>  [1555172417.7996] device (wlx70f11c1a44e7): set-hw-addr: set MAC address to B6:83:7E:3A:A7:97 (scanning)
Apr 13 12:20:17 asrocka7vta kernel: [145227.168867] IPv6: ADDRCONF(NETDEV_UP): wlx70f11c1a44e7: link is not ready
Apr 13 12:25:32 asrocka7vta NetworkManager[387]: <info>  [1555172732.8087] device (wlx70f11c1a44e7): set-hw-addr: set MAC address to F6:AB:EA:A0:EE:40 (scanning)
Apr 13 12:25:32 asrocka7vta kernel: [145542.177545] IPv6: ADDRCONF(NETDEV_UP): wlx70f11c1a44e7: link is not ready

Offline

#2 2019-04-13 20:01:20

ohnonot
...again
Registered: 2015-09-29
Posts: 3,987
Website

Re: USB Realtek Wifi not connecting

i think the lspci -k output is missing.
and

uname -a

please.

Last edited by ohnonot (2019-04-13 20:01:36)

Online

Board footer

Powered by FluxBB