You are not logged in.

#51 2017-07-18 22:49:27

Sector11
Tpyo Knig
From: 77345 ¡#
Registered: 2015-08-20
Posts: 5,319

Re: conky v1.9.0-6 for BunsenLabs Helium

Yes, I saw where that was necessary.

I'm using Cv1:1.9-0 here, in D8 as well as D9.  But I got it out of the xed.list you made because I wanted to try xed.  So sad it didn't work in D8

Looks like pluma is a rewrite (fork) of gedit and xed is made from pluma  smile  One thing I'd miss is the Terminal that Medit has:
2017-07-18_192850_Scrot11.th.jpg

Colour me 'happy' for pluma though - it has spel cheker and because of my setup, in English (Canada) and Spanish (Argentina).  cool

What other X Files are in your repo?


BunsenLabs Forum Rules ---== I'm a Conky 1.9'er ==---
System:    Host: d67 Kernel: 4.9.0-9-amd64 x86_64 (64 bit gcc: 6.3.0)
Desktop: Openbox 3.6.1 Distro: Debian GNU/Linux 9 (stretch)

Offline

#52 2017-07-19 05:09:13

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: conky v1.9.0-6 for BunsenLabs Helium

Sector11 wrote:

What other X Files are in your repo?

No others at the moment, I keep getting distracted  big_smile

I'm like British Rail — I get there eventually...


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#53 2017-07-19 16:20:34

Sector11
Tpyo Knig
From: 77345 ¡#
Registered: 2015-08-20
Posts: 5,319

Re: conky v1.9.0-6 for BunsenLabs Helium

big_smile  Love it!  Gotta go looking for the quote thread and submit that.  No rush

And may I make a note here, from some of the comments you've made over the past couple of years, I think HoaS on his bike would be faster than British Rail  smile


BunsenLabs Forum Rules ---== I'm a Conky 1.9'er ==---
System:    Host: d67 Kernel: 4.9.0-9-amd64 x86_64 (64 bit gcc: 6.3.0)
Desktop: Openbox 3.6.1 Distro: Debian GNU/Linux 9 (stretch)

Offline

#54 2019-04-12 01:57:05

dove
Member
Registered: 2016-03-21
Posts: 48

Re: conky v1.9.0-6 for BunsenLabs Helium

I' have problems with the APT key

dove@blender:~$ wget -nv http://download.opensuse.org/repositories/home:Head_on_a_Stick:conky/Debian_9.0/Release.key -O Release.key
Release.key: Permission denied

Offline

#55 2019-04-12 02:01:45

dove
Member
Registered: 2016-03-21
Posts: 48

Re: conky v1.9.0-6 for BunsenLabs Helium

I seem to have fixed it with "sudo su -"

Offline

#56 2019-04-12 17:14:15

ohnonot
...again
Registered: 2015-09-29
Posts: 3,735
Website

Re: conky v1.9.0-6 for BunsenLabs Helium

careful, Head_on_a_Stick is AWOL, so no guarantees for the above repo.
also, who still needs conky 1.9?
even I have moved on to 1.10...

Offline

#57 2019-04-12 17:33:21

Sector11
Tpyo Knig
From: 77345 ¡#
Registered: 2015-08-20
Posts: 5,319

Re: conky v1.9.0-6 for BunsenLabs Helium

ohnonot wrote:

careful, Head_on_a_Stick is AWOL, so no guarantees for the above repo.
also, who still needs conky 1.9?
even I have moved on to 1.10...

Not a case of "need" it's a matter of choice.


BunsenLabs Forum Rules ---== I'm a Conky 1.9'er ==---
System:    Host: d67 Kernel: 4.9.0-9-amd64 x86_64 (64 bit gcc: 6.3.0)
Desktop: Openbox 3.6.1 Distro: Debian GNU/Linux 9 (stretch)

Offline

#58 2019-04-13 04:52:28

ohnonot
...again
Registered: 2015-09-29
Posts: 3,735
Website

Re: conky v1.9.0-6 for BunsenLabs Helium

^ please explain, what do you get with 1.9?
conky 1.10 can read the old syntax, too.

Offline

#59 2019-04-13 13:09:16

Sector11
Tpyo Knig
From: 77345 ¡#
Registered: 2015-08-20
Posts: 5,319

Re: conky v1.9.0-6 for BunsenLabs Helium

Oh no ... I'm not going to do that again  I have a few thousand conky's here and trust me if you read through all the threads here there are various things I explained that conky v1.10 did not do.

Also there are a few conkys that I currently run that v1.10 does NOT read and run correctly.

When it first came out there were 2 things that caught my attention:

no ${pre_exec}, which I use a lot in a few conky's and
no [Alt]+"Click-&-Hold" to move the conky

Cleaned up a little

TEXT
    E V E N T S ${goto 305}Days\
${image /media/5/Conky/images/deep_skyblue_1.png -p 290,21 -s 1x700}
${membar 0,42} A ${membar 0}
  : 13/11/02: ${color1}${pre_exec conkyDateDiff 20021113}${goto 305}${pre_exec conkyDaysDiff 20021113}
  ANN: 19/08/03: ${color1}${pre_exec conkyDateDiff 20030819}${goto 305}${pre_exec conkyDaysDiff 20030819}
  : 15/01/86: ${color1}${pre_exec conkyDateDiff 19860115}${goto 305}${pre_exec conkyDaysDiff 19860115}

${membar 0,42} Q ${membar 0}
  : 08/06/09: ${color1}${pre_exec conkyDateDiff 20090608}${goto 305}${pre_exec conkyDaysDiff 20090608}
  : 29/06/09: ${color1}${pre_exec conkyDateDiff 20090629}${goto 305}${pre_exec conkyDaysDiff 20090629}

${membar 0,42} S ${membar 0}
  : 08/03/16: ${color1}${pre_exec conkyDateDiff 20160308}${goto 305}${pre_exec conkyDaysDiff 20160308}

${membar 0,42} B ${membar 0}
  : 12/05/49: ${color1}${pre_exec conkyDateDiff 19490512}${goto 305}${pre_exec conkyDaysDiff 19490512}
  : 13/08/72: ${color1}${pre_exec conkyDateDiff 19620813}${goto 305}${pre_exec conkyDaysDiff 19620813}
  : 29/11/37: ${color1}${pre_exec conkyDateDiff 19371129}${goto 305}${pre_exec conkyDaysDiff 19371129}

  : 15/04/47: ${color1}${pre_exec conkyDateDiff 19470415}${goto 305}${pre_exec conkyDaysDiff 19470415}
  : 08/01/73: ${color1}${pre_exec conkyDateDiff 19730108}${goto 305}${pre_exec conkyDaysDiff 19730108}
  : 06/04/75: ${color1}${pre_exec conkyDateDiff 19750406}${goto 305}${pre_exec conkyDaysDiff 19750406}
  : 04/07/78: ${color1}${pre_exec conkyDateDiff 19780704}${goto 305}${pre_exec conkyDaysDiff 19780704}

  : 10/03/68: ${color1}${pre_exec conkyDateDiff 19680704}${goto 305}${pre_exec conkyDaysDiff 19780704}
  : 07/02/69: ${color1}${pre_exec conkyDateDiff 19690207}${goto 305}${pre_exec conkyDaysDiff 19690207}
  : 28/09/03: ${color1}${pre_exec conkyDateDiff 20030928}${goto 305}${pre_exec conkyDaysDiff 20030928}
  : 22/10/08: ${color1}${pre_exec conkyDateDiff 20081022}${goto 305}${pre_exec conkyDaysDiff 20081022}

  : 11/11/83: ${color1}${pre_exec conkyDateDiff 19831111}${goto 305}${pre_exec conkyDaysDiff 19831111}
  : 22/05/11: ${color1}${pre_exec conkyDateDiff 20110522}${goto 305}${pre_exec conkyDaysDiff 20110222}
  : 18/08/10: ${color1}${pre_exec conkyDateDiff 20100818}${goto 305}${pre_exec conkyDaysDiff 20100818}
  : 07/12/89: ${color1}${pre_exec conkyDateDiff 19891207}${goto 305}${pre_exec conkyDaysDiff 19891207}

  : 13/09/07: ${color1}${pre_exec conkyDateDiff 20070913}${goto 305}${pre_exec conkyDaysDiff 20070913}
  : 29/08/14: ${color1}${pre_exec conkyDateDiff 20140829}${goto 305}${pre_exec conkyDaysDiff 20140829}

${membar 0}
  : ${color1}${pre_exec conkyDateDiff 20170120}${goto 305}${pre_exec conkyDaysDiff 20170120}
${membar 0}

${membar 0,42} BunsenLabs Hydrogen (Jessie) ${membar 0}
  RC1  09/09/15: ${color1}${pre_exec conkyDateDiff 20150909}${goto 305}${pre_exec conkyDaysDiff 20150909}
  RC2  16/02/16: ${color1}${pre_exec conkyDateDiff 20160216}${goto 305}${pre_exec conkyDaysDiff 20160216}
       27/08/17: ${color1}${pre_exec conkyDateDiff 20170827}${goto 305}${pre_exec conkyDaysDiff 20170827}

Now as I said before: Not a case of "need" it's a matter of choice.
And I have made my choice.  It's that simple.
I accept that you and many thousands have moved on to v1.10, please accept that I have not.


BunsenLabs Forum Rules ---== I'm a Conky 1.9'er ==---
System:    Host: d67 Kernel: 4.9.0-9-amd64 x86_64 (64 bit gcc: 6.3.0)
Desktop: Openbox 3.6.1 Distro: Debian GNU/Linux 9 (stretch)

Offline

#60 2019-04-13 14:26:57

unklar
Member
Registered: 2015-10-31
Posts: 853

Re: conky v1.9.0-6 for BunsenLabs Helium

ohnonot wrote:

conky 1.10 can read the old syntax, too.

It took him a long time (1.10) to do it.

I bet it wasn't his original intention to run the old syntax. Maybe he (the developer) was alone and the big fan community is still missing. Quasi, insight into the necessity if Conky is to continue to exist.
I remember the cheers in archlinux to have Conky1.10 in lua. However, the poor execution of many ingenious Lua scripts of the Conky Gurus has not changed until today. Concise example: draw_bg.lua

But for me the most important point is, a large part of the Conky community is deprived of the possibility to act on the configuration files themselves, because the corresponding Lua knowledge is missing.
The goal is probably to create a kind of app, similar to the "Conky Manager" for the user.
...and, I don't think that's good at all, but I'm of the opinion that I won't experience it anymore.



Thank you, Sector11.   smile

Offline

#61 2019-04-13 15:18:50

Sector11
Tpyo Knig
From: 77345 ¡#
Registered: 2015-08-20
Posts: 5,319

Re: conky v1.9.0-6 for BunsenLabs Helium

And actually there was a beta version of conky v1.10 called conky v2.0-something.  I still have the .deb file here for that.

It was HORRIBLE! and was the start of the trip down the LUA road.

I will admit Brandon really cleaned it up but why the change to lua is well beyond me when the old format was/is so simple that this "non-programmer" could create and help people with conkys for 9 or 10 years without problems.

@unklar  you are welcome my friend.

Last edited by Sector11 (2019-04-13 15:19:32)


BunsenLabs Forum Rules ---== I'm a Conky 1.9'er ==---
System:    Host: d67 Kernel: 4.9.0-9-amd64 x86_64 (64 bit gcc: 6.3.0)
Desktop: Openbox 3.6.1 Distro: Debian GNU/Linux 9 (stretch)

Offline

Board footer

Powered by FluxBB