You are not logged in.

#1 2019-02-05 19:44:17

rodeoflea
Member
Registered: 2015-10-09
Posts: 13

hplip 3.19.1

Does anyone know if it possible to install the latest hplip? 

I can get all dependencies installed except it chokes on pyqt5 and pyqt5-dbus.  I'm not sure how to install these.  I've installed python-pyqt5 but that doesn't seem to satisfy it.

Offline

#2 2019-02-05 19:56:51

damo
....moderator....
Registered: 2015-08-20
Posts: 5,008

Re: hplip 3.19.1

rodeoflea wrote:

Does anyone know if it possible to install the latest hplip? 

I can get all dependencies installed except it chokes on pyqt5 and pyqt5-dbus.  I'm not sure how to install these.  I've installed python-pyqt5 but that doesn't seem to satisfy it.

What do you mean by "latest"? Latest stable, or are you trying to mix your sources? How are you trying to install it, and from where?

Have you tried to install from stretch-backports, which has helium-compatible packages built from newer libraries?


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#3 2019-02-05 20:10:48

rodeoflea
Member
Registered: 2015-10-09
Posts: 13

Re: hplip 3.19.1

Sorry. I may be out of my depth here.  I forgot about backports.

Backports gets to 3.18.12 so that's probably fine for me.

To answer you question though :

I downloaded it from HP

https://developers.hp.com/hp-linux-imag … g/gethplip

When you run the install script you pick your distro (Debian) and distro version (Stretch 9.6)

This is what it spits back when checking dependencies.

Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not installed and some of the HPLIP features will not work if OPTIONAL dependencies are not installed.

Package-Name         Component            Required/Optional   
pyqt5-dbus           gui_qt5              OPTIONAL            
pyqt5                gui_qt5              REQUIRED 

Cheers.

Offline

#4 2019-02-05 20:24:10

damo
....moderator....
Registered: 2015-08-20
Posts: 5,008

Re: hplip 3.19.1


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#5 2019-02-05 21:44:53

rodeoflea
Member
Registered: 2015-10-09
Posts: 13

Re: hplip 3.19.1

I did read that. PDFs are printing extraordinarily slow.  New drivers apparently fix it for windows users.  Hoping the same was true for linux.

Offline

#6 2019-02-05 23:00:44

rodeoflea
Member
Registered: 2015-10-09
Posts: 13

Re: hplip 3.19.1

The 3.18 update fixed my problem.

Just for the record :

sudo apt install -t stretch-backports hplip

Offline

Board footer

Powered by FluxBB