You are not logged in.

#1 2018-12-30 20:09:53

Laadna
Member
Registered: 2017-09-15
Posts: 24

Conky outside of the maximized window area

Hello,

I used to run a conky with the own_window_type override and an openbox margin, looking like this (the bottom bar displaying network information) :
Capture-d-cran-30122018-20-55-24.png

As I am now using xfdesktop, own_window_type override does not work properly (see https://forums.bunsenlabs.org/viewtopic.php?pid=79087 for details), nor  does desktop. If I use own_window_type normal, my conky is anchored above the margin, like this :
Capture-d-cran-30122018-20-54-41.png

So, my issue is to get this conky back at the bottom of the screen.

I found out that if I reload this conky (and only this one, ie not using bl-conky-session), it goes where I want it to go. That's how I got the first screenshot.

So, I have two ways of dealing with this issue : either make this conky reload automatically when opening a session, or find a way to overlapping the openbox margins.

The first one may have to do with ~/.config/openbox/autostart, but I don't know what to type there and where to type it.

About the second one, I tried a lot of things with own_window_hints and own_window_type (and a few other ones), with no result. I thought that own_window_type panel (or dock, I can't see the difference) might be a good idea (with removing openbox margins), but for an unknown reason with this one change on the conky file my desktop then looks like this (geany is supposed to be maximized on the screenshot) :
Capture-d-cran-30122018-20-55-53.png

Although fully understanding what is messed up is not my priority, it could definitely help.

Last edited by Laadna (2018-12-30 20:11:19)

Offline

#2 2018-12-30 21:27:51

PackRat
jgmenu user Numero Uno
Registered: 2015-10-02
Posts: 832

Re: Conky outside of the maximized window area

I thought that own_window_type panel (or dock, I can't see the difference) might be a good idea (with removing openbox margins), but for an unknown reason with this one change on the conky file my desktop then looks like this (geany is supposed to be maximized on the screenshot) :

With own_window_type set to panel or dock, conky will be placed in the openbox dock and gets a border. Looks like the dock is set to be at the top of the screen. You can move the dock to the bottom of the screen and the conky should move with it.

Last edited by PackRat (2018-12-30 21:31:45)


You must unlearn what you have learned.
    -- yoda

Offline

#3 2018-12-30 21:31:07

PackRat
jgmenu user Numero Uno
Registered: 2015-10-02
Posts: 832

Re: Conky outside of the maximized window area

So, I have two ways of dealing with this issue : either make this conky reload automatically when opening a session, ...

You might be able to do that by re-ordering the applications in the openbox autostart file. Have conky start last after xfdesktop; may need to tinker with sleep times for the conky so it starts long enough after xfdesktop.


You must unlearn what you have learned.
    -- yoda

Offline

#4 2019-01-04 11:22:16

Laadna
Member
Registered: 2017-09-15
Posts: 24

Re: Conky outside of the maximized window area

PackRat wrote:

You might be able to do that by re-ordering the applications in the openbox autostart file. Have conky start last after xfdesktop; may need to tinker with sleep times for the conky so it starts long enough after xfdesktop.

I do not need to load all of my conkys after xfdesktop. I need to re-load one of my four conkys after everything is loaded.

I don't know why, I just found out that this is working when I do it manually. I expect it to work automatically and I am looking for a way to do it.

PackRat wrote:

With own_window_type set to panel or dock, conky will be placed in the openbox dock and gets a border. Looks like the dock is set to be at the top of the screen. You can move the dock to the bottom of the screen and the conky should move with it.

I can't move the conky this way if you mean "move" like "drag'n drop". Besides, the alignment bl stays so I don't know why this conky moves itself on top, nor do I know why it moves my other windows on the right part of the screen when they are supposed to be maximized.

Last edited by Laadna (2019-01-04 11:23:21)

Offline

#5 2019-01-04 12:11:59

Bearded_Blunder
Member
From: /home/bedroom/computer/uk
Registered: 2015-09-29
Posts: 470

Re: Conky outside of the maximized window area

Try putting whatever command you'd use to reload it from a terminal at the end of the openbox autostart file?


Blessed is he who expecteth nothing, for he shall not be disappointed...
If there's an obscure or silly way to break it, but you don't know what.. Just ask me

Online

#6 2019-01-04 13:09:50

Laadna
Member
Registered: 2017-09-15
Posts: 24

Re: Conky outside of the maximized window area

You precisely point out what I'm asking for.

Offline

#7 2019-01-04 19:29:38

Bearded_Blunder
Member
From: /home/bedroom/computer/uk
Registered: 2015-09-29
Posts: 470

Re: Conky outside of the maximized window area

Laanda wrote:

I don't know why, I just found out that this is working when I do it manually. I expect it to work automatically and I am looking for a way to do it.

Suggested to me you knew the command.  My apologies.
The file it needs to go at the end of can be accessed from the menu Preferences > Openbox > Edit autostart.

As for what the command is.. I'm afraid I don't know myself, and

man conky

is a tad long to pick out the details from given I don't need to know myself since I don't usually switch from the default config, much less create & run multiple conkys.

Hopefully one of the conky experts will pass by.. I tried looking at the menu entry for restarting conky.. but it's one of those damned pipemenu things, & right now I can't recall where bunsen hides the scripts for those & whatever gets done gets done in said script.

myself I'd start them individually from autostart with

conky --config=/path/to/config1.rc &
conky --config=/path/to/config2.rc &
conky --config=/path/to/config3.rc &

And try starting the last one at the end of autostart with something like:

sleep 5
conky --config=/path/to/config4.rc &

Hopefully the delay means whatever causes you to currently need to restart it has finished loading after the 5 second wait.. and just starting it instead of restarting it will do.


Blessed is he who expecteth nothing, for he shall not be disappointed...
If there's an obscure or silly way to break it, but you don't know what.. Just ask me

Online

#8 2019-01-05 08:09:05

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 4,796
Website

Re: Conky outside of the maximized window area

Bearded_Blunder wrote:

I tried looking at the menu entry for restarting conky.. but it's one of those damned pipemenu things, & right now I can't recall where bunsen hides the scripts for those & whatever gets done gets done in said script.

It can be a bit tedious to track down, yes, but just for future reference:

Look at ~/.config/openbox/menu.xml to find the command. In this case it's bl-conky-pipemenu. They're all in /usr/bin but you can check:

john@helium:~$ which bl-conky-pipemenu
/usr/bin/bl-conky-pipemenu
geany $(which bl-conky-pipemenu)

To see the pipemenu. The loadReloadMenu function in turn calls $CSESSION which turns out to be bl-conky-session, another script. roll

OK repeat the process:

geany $(which bl-conky-session)

to eventually discover that it's running 'killall conky' and then restarting either the conkys in the session file, or else the default conky.


John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
In case you forget, the rules.

Offline

#9 2019-01-05 11:38:31

ohnonot
...again
Registered: 2015-09-29
Posts: 3,281
Website

Re: Conky outside of the maximized window area

Laadna wrote:

You precisely point out what I'm asking for.

from 'man conky':

killall -SIGUSR1 conky

will reload all currently running conkys.

Offline

#10 2019-01-07 16:50:45

Laadna
Member
Registered: 2017-09-15
Posts: 24

Re: Conky outside of the maximized window area

Bearded_Blunder wrote:

[...]

conky --config=/path/to/config1.rc &
conky --config=/path/to/config2.rc &
conky --config=/path/to/config3.rc &

And try starting the last one at the end of autostart with something like:

sleep 5
conky --config=/path/to/config4.rc &

Hopefully the delay means whatever causes you to currently need to restart it has finished loading after the 5 second wait.. and just starting it instead of restarting it will do.

Nice try, but it didn't work. It just loaded another conky on top of the others, one I didn't asked to.

johnraff wrote:

to eventually discover that it's running 'killall conky' and then restarting either the conkys in the session file, or else the default conky.

ohnonot wrote:

from 'man conky':

killall -SIGUSR1 conky

will reload all currently running conkys.

I'm trying to reload one conky only, not all of them.

Offline

#11 2019-01-07 17:50:11

damo
....moderator....
Registered: 2015-08-20
Posts: 4,482

Re: Conky outside of the maximized window area

Laadna wrote:

...
I'm trying to reload one conky only, not all of them.

If you have started the conky explicitly, eg with

conky -c /path/to/conkyrc

(NB The "-xf" switches require the exact pattern match for the original command) then you can stop and reload it with

pkill -xf /path/to/conkyrc && conky -c /path/to/conkyrc

Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

#12 2019-01-07 20:26:43

ohnonot
...again
Registered: 2015-09-29
Posts: 3,281
Website

Re: Conky outside of the maximized window area

^ damo, that's very clunky but a good step closer to what op wants (who apparently insists on being spoonfed).
anyhow, pkill can issue the same signals as kill, so it IS possible to reload only one conky.

man pkill

Offline

Board footer

Powered by FluxBB