You are not logged in.

#1 2018-11-11 08:41:17

strodog
New Member
Registered: 2018-11-11
Posts: 3

how to install GNU Octave

Hi, my previous version  of Bunsen labs Linux has been running fine and I never had any issue installing GNu Octave, wxmaxima, etc.

I installed the latest helium version, added the debian stretch backport repository and I have tried both  synaptic & apt-get to install octave. I get a list of (libraries, etc) packages that are required but cannot be installed, apparently.

How can I get around this??
Thanks in advance

Offline

#2 2018-11-11 08:55:36

damo
....moderator....
Registered: 2015-08-20
Posts: 4,382

Re: how to install GNU Octave

What is the output of

apt-cache policy <app 1> <app 2> <etc>

and what are the error messages when you try to apt-get them?  (Please wrap the output with [ code ] tags)


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#3 2018-11-12 08:19:57

strodog
New Member
Registered: 2018-11-11
Posts: 3

Re: how to install GNU Octave

Damo, thanks for your help. I have run the commands and here is the outputs.

MOD EDIT: added code tags!

t@o:~$ sudo apt-get install octave
[sudo] password for tom: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 octave : Depends: libamd2 (>= 4.5.2) but it is not installable
          Depends: libarpack2 (>= 2.1) but it is not installable
          Depends: libcamd2 (>= 4.5.2) but it is not installable
          Depends: libccolamd2 (>= 4.5.2) but it is not installable
          Depends: libcholmod3 (>= 4.5.2) but it is not installable
          Depends: libcolamd2 (>= 4.5.2) but it is not installable
          Depends: libcxsparse3 (>= 4.5.2) but it is not installable
          Depends: libfltk-gl1.3 (>= 1.3.0) but it is not installable
          Depends: libfltk1.3 (>= 1.3.3) but it is not installable
          Depends: libglpk40 (>= 4.59) but it is not installable
          Depends: libklu1 (>= 4.5.2) but it is not installable
          Depends: liboctave6 (= 4.4.1-2~bpo9+1) but it is not going to be installed
          Depends: libportaudio2 (>= 19+svn20101113) but it is not installable
          Depends: libqhull7 but it is not installable
          Depends: libqrupdate1 (>= 1.0) but it is not installable
          Depends: libqt5help5 (>= 5.6.0~beta) but it is not installable
          Depends: libqt5opengl5 (>= 5.0.2) but it is not installable
          Depends: libqt5printsupport5 (>= 5.0.2) but it is not installable
          Depends: libqt5scintilla2-12v5 (>= 2.8.4) but it is not installable
          Depends: libsuitesparseconfig4 (>= 4.5.2) but it is not installable
          Depends: libumfpack5 (>= 4.5.2) but it is not installable




    t@o:~$ sudo apt-cache policy octave

octave:
  Installed: (none)
  Candidate: 4.4.1-2~bpo9+1
  Version table:
     4.4.1-2~bpo9+1 100
        100 [url]http://deb.debian.org/debian[/url] stretch-backports/main i386 Packages
      Depends: texinfo but it is not installable
          Depends: libqt5sql5-sqlite but it is not installable
          Recommends: gnuplot-qt but it is not installable or
                      gnuplot-x11 but it is not installable or
                      gnuplot-nox but it is not installable
          Recommends: libopenblas-base but it is not installable or
                      libatlas3-base but it is not installable
          Recommends: pstoedit but it is not installable
          Recommends: epstool but it is not installable
          Recommends: default-jre-headless but it is not installable
          Recommends: octave-doc but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I have downloaded the 1gb installation file

Last edited by damo (2018-11-12 11:30:07)

Offline

#4 2018-11-12 11:35:42

damo
....moderator....
Registered: 2015-08-20
Posts: 4,382

Re: how to install GNU Octave

https://packages.debian.org/stretch-backports/octave

It looks like you need newer versions of some dependencies as well.


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#5 2018-11-12 14:39:12

brontosaurusrex
Middle Office
Registered: 2015-09-29
Posts: 1,595

Re: how to install GNU Octave

sudo apt install -t stretch-backports octave

did work for me.

octave --version
GNU Octave, version 4.4.1
apt-cache policy octave
octave:
  Installed: 4.4.1-2~bpo9+1
  Candidate: 4.4.1-2~bpo9+1
  Version table:
 *** 4.4.1-2~bpo9+1 100
        100 https://deb.debian.org/debian stretch-backports/main amd64 Packages
        100 /var/lib/dpkg/status
     4.0.3-3 500
        500 https://deb.debian.org/debian stretch/main amd64 Packages

Last edited by brontosaurusrex (2018-11-12 14:40:49)

Offline

#6 2018-11-12 15:51:17

damo
....moderator....
Registered: 2015-08-20
Posts: 4,382

Re: how to install GNU Octave

Something is off somewhere. OP has no reference to the stretch version:

t@o:~$ sudo apt-cache policy octave

octave:
  Installed: (none)
  Candidate: 4.4.1-2~bpo9+1

@strodog   Please post your sources (and please use code tags this time wink )


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#7 2018-11-12 18:09:21

DeepDayze
Member
From: In Linux Land
Registered: 2017-05-28
Posts: 541

Re: how to install GNU Octave

OP did you try:

~$ sudo apt -t stretch-backports install octave

Real Men Use Linux

Offline

#8 2018-11-16 09:41:44

strodog
New Member
Registered: 2018-11-11
Posts: 3

Re: how to install GNU Octave

Thank you all .
I managed to get it all installed. The trick was to rerun alt-get update after the bl-welcome script adds the additional repositories.

Offline

Board footer

Powered by FluxBB