You are not logged in.

#1 2018-09-12 22:31:10

RogerThat
Member
Registered: 2018-09-12
Posts: 6

How to set up auto login? (Tried the usual fixes.) [SOLVED]

I have been unable to set up auto login for BunsenLabs on my laptop, an old Dell Inspiron 6000.

I searched the BunsenLabs forum on the subject and tried the relevant suggestions, but no joy. I also looked at Debian website posts; they were duplicative or beyond my capabilities (I can edit config files and fiddle here and there, but not much beyond that).

Anyway, I tried the following BunsenLabs forum suggestions, with results as indicated. Many thanks to those participants—I stripped out their usernames and condensed the material to simplify and shorten the content below:

Re: Autologin
Try this method:
https://wiki.debian.org/LightDM#Enable_autologin :

Enable autologin
Look up these lines in lightdm configuration file, uncomment them and customize to your preference.
[Seat:*]
#autologin-user=<insert username>
#autologin-user-timeout=0
(DID NOT WORK)

Re: Autologin
What you may be missing is the command at the top of the page that you have to run after any changes to the conf file. Be sure to run the following in a terminal after making the changes to get them to take effect:
sudo dpkg-reconfigure lightdm
(DID NOT WORK)
Re: Autologin
To disable the autolocking :
rename or delete
/etc/xdg/autostart/light-locker.desktop
(DID NOT WORK)

Re: Autologin
In addition to uncommenting:

[SeatDefaults]
#autologin-user=<insert username>
#autologin-user-timeout=0

You should also uncomment the following line:

#pam-autologin-service=lightdm-autologin
(DID NOT WORK)

Re: Autologin
rename or delete
/etc/xdg/autostart/light-locker.desktop
(DID NOT WORK)

Better to just remove light-locker entirely, as an update/upgrade of light-locker will re-install that file:

sudo apt purge light-locker
(DID NOT DO)

If you don't want to remove it for some reason like you're using it in another session, copy light-locker.desktop to ~/.config/autostart , open it with a text editor and add or edit the Hidden= line to read:

Hidden=true
(DID NOT DO)

That will override the /etc/xdg file even after upgrades to light-locker.

Re: Autologin
The first link tells to uncomment:

[SeatDefaults]
#autologin-user=<insert username>
#autologin-user-timeout=0

Obviously you should also uncomment the following line:

#pam-autologin-service=lightdm-autologin

Autologin works great for me without uncommenting the "pam-autologin-service" line.

If [you don’t want to type the username on the] login screen (e.g. after suspend), uncomment the line:

greeter-hide-users=false
(DID NOT WORK)

Re: Autologin
I originally configured my system for autologin, then somewhere along the way with an update, something over wrote my config. Using the info above, the method that worked for me was to create a new file (something that isn't going to get over written with a future update):

/usr/share/lightdm/lightdm.conf.d/60_glaw.conf:
# BunsenLabs specific defaults
#
# - invoke user setup script on login
[SeatDefaults]
autologin-user=glaw
autologin-user-timeout=0
pam-autologin-service=lightdm-autologin
(DID NOT WORK)
(pam-autologin-service needed - I dunno) …
----=
I had used CrunchBang before, and was happy to find that some kept the torch burning after its demise by creating BunsenLabs as one of its successors. It’s a great OS. Less is more, as they say.
Thanks for any suggestions.

Last edited by RogerThat (2018-09-13 17:48:42)

Offline

#2 2018-09-12 22:59:58

damo
....moderator....
Registered: 2015-08-20
Posts: 4,207

Re: How to set up auto login? (Tried the usual fixes.) [SOLVED]

You say "DID NOT WORK" a few times, without saying the exact process you followed.

I just altered the conf file myself to check:

[Seat:*]
autologin-user=damo
autologin-user-timeout=0

It worked fine after rebooting.


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#3 2018-09-13 00:46:55

RogerThat
Member
Registered: 2018-09-12
Posts: 6

Re: How to set up auto login? (Tried the usual fixes.) [SOLVED]

"Did not work" refers to my implementing the specific procedure described above, in each case, recommended variously by earlier posts in this forum.

My lightdm.conf file currently has the following two uncommented lines:

autologin-user=(xxxxx)   [where xxxxx = my username]
autologin-user-timeout=0


and the laptop still booted into a login window.

In the dozens of distros I've used or tried through the years, I always could enable auto login. Not so, this time (so far).

Offline

#4 2018-09-13 01:37:43

damo
....moderator....
Registered: 2015-08-20
Posts: 4,207

Re: How to set up auto login? (Tried the usual fixes.) [SOLVED]

RogerThat wrote:

My lightdm.conf file currently has the following two uncommented lines:

autologin-user=(xxxxx)   [where xxxxx = my username]

It should be

autologin-user=xxxxx

...no brackets.  And did you try rebooting?


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#5 2018-09-13 01:42:48

RogerThat
Member
Registered: 2018-09-12
Posts: 6

Re: How to set up auto login? (Tried the usual fixes.) [SOLVED]

I did not use brackets.

Offline

#6 2018-09-13 02:24:37

damo
....moderator....
Registered: 2015-08-20
Posts: 4,207

Re: How to set up auto login? (Tried the usual fixes.) [SOLVED]

Well it would be helpful if you posted the exact code you used hmm

NB Using [ code ] tags for terminal output makes things much easier to read

And I'll ask again - have you rebooted?


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#7 2018-09-13 04:22:16

RogerThat
Member
Registered: 2018-09-12
Posts: 6

Re: How to set up auto login? (Tried the usual fixes.) [SOLVED]

The current state of the lightdm.conf file includes the following uncommented lines:

autologin-user=gregg
autologin-user-timeout=0

and (per one of the other proposed fixes suggested in my initial post that I tried, with no joy):

pam-autologin-service=gregg

I did reboot, but still got the login screen.

Sorry, but I don't understand what you mean by code tags. The above snippets are what I see on the screen, along with, of course, their line numbers.

Here is a screenshot slice of that file:

https://scrot.moe/image/94Nr6

Offline

#8 2018-09-13 05:09:38

damo
....moderator....
Registered: 2015-08-20
Posts: 4,207

Re: How to set up auto login? (Tried the usual fixes.) [SOLVED]

RogerThat wrote:

...
Sorry, but I don't understand what you mean by code tags. The above snippets are what I see on the screen, along with, of course, their line numbers.

Above the Message editor window is a list of BBCode tags for text formatting, (presumably you used the 'url' one for your image link).
Just click on 'Code' and paste the terminal output in the window that opens. Or type the tags yourself within the message...

[code]
autologin-user=gregg
autologin-user-timeout=0
[/code]

It has the advantages of being much easier to read, and long pieces of code can be scrolled in the code window.

As regards your lightdm.conf the entries are exactly as I tried, with a successful result. I can't think of anything else, other than trying the light-locker edits (I don't use it personally).


Be Excellent to Each Other...

FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Offline

#9 2018-09-13 05:51:17

ohnonot
...again
Registered: 2015-09-29
Posts: 2,951
Website

Re: How to set up auto login? (Tried the usual fixes.) [SOLVED]

RogerThat wrote:

The current state of the lightdm.conf file includes the following uncommented lines:

autologin-user=gregg
autologin-user-timeout=0

yes, but are they also in the correct section, under the correct header?
maybe best if you copy-paste the whole file (and use code tags please).

Offline

#10 2018-09-13 07:11:35

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 4,477
Website

Re: How to set up auto login? (Tried the usual fixes.) [SOLVED]

If you run this command in a terminal, it might help to show where the problem is:

lightdm --show-config

John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
In case you forget, the rules.

Offline

#11 2018-09-13 16:22:42

RogerThat
Member
Registered: 2018-09-12
Posts: 6

Re: How to set up auto login? (Tried the usual fixes.) [SOLVED]

Bingo! You nailed it, John. Success!

Per your suggestion, I ran

lightdm –show-config

in Terminal, and got:
------
gregg@debian:~$ lightdm --show-config
   [Seat:*]
A  greeter-session=lightdm-greeter
B  greeter-hide-users=false
A  session-wrapper=/etc/X11/Xsession
D  autologin-user=glaw
D  autologin-user-timeout=0
C  pam-autologin-service=lightdm-autologin

   [LightDM]
D  pam-autologin-service=gregg
D  greeter-hide-users=False
D  autologin-user=gregg
D  autologin-user-timeout=0

Sources:
A  /usr/share/lightdm/lightdm.conf.d/01_debian.conf
B  /usr/share/lightdm/lightdm.conf.d/50_bunsen.conf
C  /usr/share/lightdm/lightdm.conf.d/60_glaw.conf
D  /etc/lightdm/lightdm.conf
------

Looking at the above output, I noticed this line under the [Seat:*] subsection of the lightdm.conf file:

D  autologin-user=glaw

I went there, uncommented that line, and changed it to:

D  autologin-user=gregg

and I also uncommented the next line under it:

D  autologin-user-timeout=0

I rebooted and auto login happened. Problem solved!

I see, with chagrin, that this very fix had been proposed earlier among the suggestions I cobbled together, from another earlier forum thread, in my original post. But I misunderstood it. That is, I thought it “did not work” but did not realize—although it was staring me in the face—that the fix applied specifically to lines under the [Seat:*] subsection of the lightdm.conf file in addition to similar lines under the LightDM subsection. One wonders why those lines have to be used twice, but then code is complex, I suppose. . . .

Thanks to John, damo, and ohnonot for their feedback and efforts.

Last edited by RogerThat (2018-09-13 17:49:04)

Offline

#12 2018-09-13 23:25:49

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 4,477
Website

Re: How to set up auto login? (Tried the usual fixes.) [SOLVED]

RogerThat wrote:

...did not realize—although it was staring me in the face—that the fix applied specifically to lines under the [Seat:*] subsection of the lightdm.conf file in addition to similar lines under the LightDM subsection. One wonders why those lines have to be used twice

They don't. Only the [Seat:*] subsection applies - the lines in the LightDM subsection are probably being ignored.


John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
In case you forget, the rules.

Offline

#13 2018-09-14 16:07:05

RogerThat
Member
Registered: 2018-09-12
Posts: 6

Re: How to set up auto login? (Tried the usual fixes.) [SOLVED]

John, what you say makes sense, because the applicable lines of code should be only needed once to do their task, and adding identical parallel lines of code elsewhere that also execute that task could theoretically cause discombobulation (though apparently not in this case--as you say, the lines in the LightDM subsection were apparently not enabled, or were superseded by those under the [Seat:*] subsection). One wonders, then, why the lines are repeated in the LightDM subsection, even if they originally also were commented out. So much for lean code.

Offline

#14 2018-09-15 06:11:39

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 4,477
Website

Re: How to set up auto login? (Tried the usual fixes.) [SOLVED]

RogerThat wrote:

One wonders, then, why the lines are repeated in the LightDM subsection, even if they originally also were commented out. So much for lean code.

Why indeed. The default /etc/lightdm/lightdm.conf shows in the comments what values are appropriate for each section.


John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
In case you forget, the rules.

Offline

Board footer

Powered by FluxBB