You are not logged in.

#1 2018-08-09 21:13:24

hhh
That's easy!
Registered: 2015-09-17
Posts: 5,966
Website

gtk-3.0 - install sass to recompile themes

I need confirmation that this will install the packages required to run the parse-sass.sh script present in BL's theme's gtk-3.0 folder, and in the same folder in other themes on helium/stretch...

sudo apt install ruby-sass gem
sudo gem install bundle

You should now be able to make changes to the _*.scss files in the gtk-3.0 folder and recompile the theme by cd-ing to the gtk-3.0 folder and running...

./parse-sass.sh

That's locally, use sudo if the theme is in /usr/share/themes.

Please report your results here.

Online

#2 2018-08-10 05:35:57

ohnonot
...again
Registered: 2015-09-29
Posts: 3,129
Website

Re: gtk-3.0 - install sass to recompile themes

i cannot confirm, but oomox does essentially the same and has a list of dependencies, and a .deb package that could be inspected.

Offline

#3 2018-08-28 02:11:57

hhh
That's easy!
Registered: 2015-09-17
Posts: 5,966
Website

Re: gtk-3.0 - install sass to recompile themes

hhh wrote:

I need confirmation that this will install the packages required to run the parse-sass.sh script present in BL's theme's gtk-3.0 folder, and in the same folder in other themes on helium/stretch...

sudo apt install ruby-sass gem
sudo gem install bundle

You should now be able to make changes to the _*.scss files in the gtk-3.0 folder and recompile the theme by cd-ing to the gtk-3.0 folder and running...

./parse-sass.sh

That's locally, use sudo if the theme is in /usr/share/themes.

Confirmed...

Screenshot_2018-08-27_22-07-25.th.png

Theme in progress...

Online

#4 2018-09-03 01:38:28

DeepDayze
Member
From: In Linux Land
Registered: 2017-05-28
Posts: 531

Re: gtk-3.0 - install sass to recompile themes

Is it possible to test this recompiled theme? If so then that would be great to have something like a bunsen-themes-legacy package.


Real Men Use Linux

Offline

#5 2018-09-03 02:06:40

vasa1
Member
Registered: 2015-09-29
Posts: 169

Re: gtk-3.0 - install sass to recompile themes

I use Greybird and followed the README @ https://github.com/shimmerproject/Greyb … er/gtk-3.0. There's a typo in that `bundler` should be `bundle`.

I'm guessing that not all "compiled" themes can be modified the same way. IIRC, oomox was good for themes related to numix.


Using the Openbox (3.5.2) session of Lubuntu 14.04 LTS but very interested in BL :)

Offline

#6 2018-09-03 02:48:43

DeepDayze
Member
From: In Linux Land
Registered: 2017-05-28
Posts: 531

Re: gtk-3.0 - install sass to recompile themes

vasa1 wrote:

I use Greybird and followed the README @ https://github.com/shimmerproject/Greyb … er/gtk-3.0. There's a typo in that `bundler` should be `bundle`.

I'm guessing that not all "compiled" themes can be modified the same way. IIRC, oomox was good for themes related to numix.

Were you able to successfully recompile the theme and getting it to work?


Real Men Use Linux

Offline

#7 2018-09-04 01:45:40

hhh
That's easy!
Registered: 2015-09-17
Posts: 5,966
Website

Re: gtk-3.0 - install sass to recompile themes

vasa1 wrote:

I use Greybird and followed the README @ https://github.com/shimmerproject/Greyb … er/gtk-3.0. There's a typo in that `bundler` should be `bundle`.

If you're talking about my posts, bundler is the debian package but the gem command to install is bundle...

https://bundler.io/

Online

#8 2018-09-04 05:00:06

ohnonot
...again
Registered: 2015-09-29
Posts: 3,129
Website

Re: gtk-3.0 - install sass to recompile themes

vasa1 wrote:

I'm guessing that not all "compiled" themes can be modified the same way. IIRC, oomox was good for themes related to numix.

they have expanded that since to Arc and Materia themes as well.
I cannot recommend oomox enough; GTK3 theme hacking, or even creation, is crazy to do manually.
I created a personal slightly modified plugin, even including conky colors. it isn't too hard (though i must say the code is a mess).

Offline

#9 2018-09-04 13:58:54

vasa1
Member
Registered: 2015-09-29
Posts: 169

Re: gtk-3.0 - install sass to recompile themes

hhh wrote:
vasa1 wrote:

I use Greybird and followed the README @ https://github.com/shimmerproject/Greyb … er/gtk-3.0. There's a typo in that `bundler` should be `bundle`.

If you're talking about my posts, bundler is the debian package but the gem command to install is bundle...

https://bundler.io/

@hhh, No, I was talking specifically about the link I provided.

@DeepDayze, yes, I could. If I did something stupid, the parser pointed it out.


Using the Openbox (3.5.2) session of Lubuntu 14.04 LTS but very interested in BL :)

Offline

Board footer

Powered by FluxBB