You are not logged in.

#1 2018-07-03 07:57:30

wammes
Member
From: Krupka, ČR
Registered: 2018-06-23
Posts: 27
Website

USB devices SOLVED

I often use USB sticks and external USB devices. They get mounted alright in bunsenlabs but can only be used after I click on them in the filemanager. That is inconvinient. Does anybody has a tip on a good small utility that automounts on connect? I used udiskie but it's a little slow.

Last edited by wammes (2018-07-04 08:15:14)

Offline

#2 2018-07-03 08:48:07

brontosaurusrex
Middle Office
Registered: 2015-09-29
Posts: 1,817
Website

Re: USB devices SOLVED

I use usbmount on raspbian, but no idea if mount speed is any better.

Offline

#3 2018-07-03 12:16:34

earlybird
ほやほや
Registered: 2015-12-16
Posts: 717
Website

Re: USB devices SOLVED

udevil is a solution that's based on event polling, so it should automount without user action.

Offline

#4 2018-07-03 16:37:11

ohnonot
...again
Registered: 2015-09-29
Posts: 3,917
Website

Re: USB devices SOLVED

i'm pretty sure thunar's volume manager can be configured to do just that.

Offline

#5 2018-07-04 04:12:37

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 5,740
Website

Re: USB devices SOLVED

Make sure thunar is running as a daemon in your ~/.config/openbox/autostart file.
Add:

## Start Thunar Daemon, if set as bl-file-manager
if [ "$(readlink -f $(which bl-file-manager))" = "$(which thunar)" ]
then
    thunar --daemon &
fi

Then log out and back in. This will be in the next release of bunsen-configs, but existing users still need to add it manually.


John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
In case you forget, the rules.

Offline

#6 2018-07-04 07:38:03

wammes
Member
From: Krupka, ČR
Registered: 2018-06-23
Posts: 27
Website

Re: USB devices SOLVED

@Johnraff : this works. Only 'problem' is that thunar also opens a window showing the drive contents. Is there a way to avoid this window opening?

Last edited by wammes (2018-07-04 07:38:20)

Offline

#7 2018-07-04 07:51:14

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 5,740
Website

Re: USB devices SOLVED

Yes, in a Thunar window: Edit>Preferences>Advanced>(check "enable volume management")>Configure the management....
and choose the behaviour you want.


John
--------------------
( a boring Japan blog , Japan Links, idle twitterings  and GitStuff )
In case you forget, the rules.

Offline

#8 2018-07-04 08:14:52

wammes
Member
From: Krupka, ČR
Registered: 2018-06-23
Posts: 27
Website

Re: USB devices SOLVED

So simple. Blsuh blush. I should have found this out myself. It works great now. Thank you!

Offline

Board footer

Powered by FluxBB