You are not logged in.

#1 2018-06-10 11:20:43

New Member
Registered: 2018-06-10
Posts: 4

printer Brother MFC-J5730DW

I had installed the latest version of bunsenlabs.
It works nearly perfect.
My problem is the installation of the printer.
Here is the installation from brother:

Step1. Download the tool.(linux-brprinter-installer-*.*.*-*.gz)

The tool will be downloaded into the default "Download" directory.
(The directory location varies depending on your Linux distribution.)
e.g. /home/(LoginName)/Download

Step2. Open a terminal window.

Step3. Go to the directory you downloaded the file to in the last step. By using the cd command.

e.g. cd Downloads

Step4. Enter this command to extract the downloaded file:

Command: gunzip linux-brprinter-installer-*.*.*-*.gz

e.g. gunzip linux-brprinter-installer-2.1.1-1.gz

Step5. Get superuser authorization with the "su" command or "sudo su" command.

Step6. Run the tool:

Command: bash linux-brprinter-installer-*.*.*-* Brother machine name
e.g. bash linux-brprinter-installer-2.1.1-1 MFC-J880DW

Step7. The driver installation will start. Follow the installation screen directions.

When you see the message "Will you specify the DeviceURI ?",

For USB Users: Choose N(No)
For Network Users: Choose Y(Yes) and DeviceURI number.

The install process may take some time. Please wait until it is complete.

I come till step 5.
If I run step 6, I get this error:

aiko@debian-laptop:~$ cd Downloads
aiko@debian-laptop:~/Downloads$ gunzip linux-brprinter-installer-2.2.0-1.gz
aiko@debian-laptop:~/Downloads$ sudo -i
[sudo] Passwort für aiko: 
root@debian-laptop:~# bash linux-brprinter-installer-2.2.0-1 MFC-J5730DW
bash: linux-brprinter-installer-2.2.0-1: No such file or directory

I tried it with cups.
I entered http://localhost:631/ and tried to add the printer.
I logged in and click on Management and then "add printer".
When I try it, this error is shown:

Drucker hinzufügen
Drucker hinzufügen Error
Drucker konnte nicht hinzugefügt werden:


or the english version:

add Printer
Add Printer Error
Printer could not be added:


It seems to be a problem with the rights.
But at bunsenlabs there is only one user with one password.
I log in with the same data which I use, when I log in at bunsenlabs.
Then I will also be logged in at cups, but I can't add the printer.
Does anyone know what I have to do to install the printer?

Thanks a lot


You could also answer in german. smile


#2 2018-06-10 15:00:27

From: Edrychwch o'ch cwmpas
Registered: 2015-09-29
Posts: 767

Re: printer Brother MFC-J5730DW

For the CUPS-route: add your user name to the line 'lpadmin...' in /etc/group:

$ sudo nano /etc/group

# before (note: '123' might be different on your setup; leave it as it was on your setup):

# should be:

Now, you should be able to supply your user/pass when CUPS asks it.

HTH and good luck with the printer setup.

Postpone all your duties; if you die, you won't have to do them ..


#3 2018-06-10 17:48:31

Registered: 2015-08-10
Posts: 3,173

Re: printer Brother MFC-J5730DW

The `sudo -i` changed the working directory! Change back to the correct directory, then execute the installer according to the vendor's instructions.

There is no competition between bugs. When you combine two awesome bugs, you get a totally awesome bug.


#4 2018-06-14 11:20:12

New Member
Registered: 2018-06-10
Posts: 4

Re: printer Brother MFC-J5730DW


thanks for the answers.

@ iMBeCil
Thanks to your help, I can now configure and maintain the printer via CUPS.
He prints without problems.

@ twoion
After typing 'sudo -i' I can't change the directory.
It is always said that no file or directory is found.
No matter in which directory I want to change.
I have to write as root each time at first 'sudo' before the actual order.
Then it works.

But there's another problem: the scanner isn't find.
The printer was detected under CUPS and bunsenlabs. Printing is not a problem. Only the scanner. It seems, as there isn't a scanner.
The driver for the printer also includes the scanner driver. This has been installed correctly.
Does anyone know why that is?
Under debian stretch cinnamon it works correctly.
I do not understand, because bunsenlabs is based on debian.




#5 2018-06-14 11:39:32

From: Edrychwch o'ch cwmpas
Registered: 2015-09-29
Posts: 767

Re: printer Brother MFC-J5730DW

^You're welcome.

As for the scanner, what program are you using for scanning?

Postpone all your duties; if you die, you won't have to do them ..


Board footer

Powered by FluxBB