You are not logged in.

#1 2018-05-01 00:35:31

jjanderson5
Member
Registered: 2016-05-10
Posts: 62

[RESOLVED] Wifi is not working on HP Probook 6540b

I have an HP probook 6540b that has been sitting on the side, but I need to start using it now for traveling. Everything is working fine, except the wife is not working. The 'wifi' status light on PC seems to be working properly, i.e. when I swipe my finger over the status light, it toggles the wife on(blue light)/off(orange light).

I'm running 'nm-applet' and when I click on the nm-applet icon, it shows that my ethernet connection is good, but it shows 'Wifi is disabled by hardware switch' when the status light is orange and 'device not ready' when the status light is blue.

The output from 'lshw -C network is:

  *-network               
       description: Wireless interface
       product: Centrino Wireless-N 1000 [Condor Peak]
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:45:00.0
       logical name: wlan0
       version: 00
       serial: 00:26:c7:24:4b:2c
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=3.16.0-4-amd64 firmware=39.31.5.1 build 35138 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:51 memory:d0200000-d0201fff
  *-network
       description: Ethernet interface
       product: 88E8072 PCI-E Gigabit Ethernet Controller
       vendor: Marvell Technology Group Ltd.
       physical id: 0
       bus info: pci@0000:46:00.0
       logical name: eth0
       version: 10
       serial: 70:5a:b6:ac:a2:f6
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=sky2 driverversion=1.30 duplex=full ip=192.168.0.237 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:46 memory:d0100000-d0103fff ioport:2000(size=256) memory:d0120000-d013ffff

The output from 'ifconfig' is:

eth0      Link encap:Ethernet  HWaddr 70:5a:b6:ac:a2:f6  
          inet addr:192.168.0.237  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fd00:1cab:c076:b142:a4ca:9d7c:87de:8f34/64 Scope:Global
          inet6 addr: fd00:1cab:c076:b142:725a:b6ff:feac:a2f6/64 Scope:Global
          inet6 addr: fe80::725a:b6ff:feac:a2f6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:25338 errors:0 dropped:0 overruns:0 frame:0
          TX packets:20774 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:21678325 (20.6 MiB)  TX bytes:2520397 (2.4 MiB)
          Interrupt:17 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:167 errors:0 dropped:0 overruns:0 frame:0
          TX packets:167 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:10842 (10.5 KiB)  TX bytes:10842 (10.5 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:26:c7:24:4b:2c  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

When I run:  ps -elf | fgrep netw

I get:

4 S root       692     1  0  80   0 - 94474 -      19:24 ?        00:00:01 /usr/sbin/NetworkManager --no-daemon

Can anyone help with suggestions?

Last edited by jjanderson5 (2018-05-02 00:54:01)

Offline

#2 2018-05-01 06:07:17

Head_on_a_Stick
Moderator
From: London
Registered: 2015-09-29
Posts: 8,683
Website

Re: [RESOLVED] Wifi is not working on HP Probook 6540b

Is this with BunsenLabs Helium?

If not then you should probably try that:

https://forums.bunsenlabs.org/viewtopic.php?id=4772

If it doesn't work with that then please post the output of:

lspci -knn | grep -iA2 net

“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Online

#3 2018-05-01 09:42:54

ohnonot
...again
Registered: 2015-09-29
Posts: 2,558
Website

Re: [RESOLVED] Wifi is not working on HP Probook 6540b

jjanderson5 wrote:

Everything is working fine, except the wife is not working.

Best Typo Ever!
(scnr)

Offline

#4 2018-05-01 13:40:02

jjanderson5
Member
Registered: 2016-05-10
Posts: 62

Re: [RESOLVED] Wifi is not working on HP Probook 6540b

@Head_on_a_Stick

The problem is with hydrogen. I will upgrade to helium and report back. It will take me a few days to do the upgrade.

Jim

Offline

#5 2018-05-01 13:42:06

jjanderson5
Member
Registered: 2016-05-10
Posts: 62

Re: [RESOLVED] Wifi is not working on HP Probook 6540b

@ohnonot

Obviously, my finger missed on that one. I read your message to my wife and now she wants to slap me around until I can spell 'wifi'.

Jim

Last edited by jjanderson5 (2018-05-01 13:42:25)

Offline

#6 2018-05-01 16:44:25

altman
Member
From: Canada
Registered: 2015-10-24
Posts: 122

Re: [RESOLVED] Wifi is not working on HP Probook 6540b

lol; forums are a little bit dangerous !


HP Pavilion dv7 Notebook/Intel Core i7-2670QM/ BunsenLab Helium
Dell Inspiron 1720/Intel Core2 Duo T5450/ ArchLabs 2018.05

Offline

#7 2018-05-01 23:00:46

DeepDayze
Member
From: In Linux Land
Registered: 2017-05-28
Posts: 370

Re: [RESOLVED] Wifi is not working on HP Probook 6540b

altman wrote:

lol; forums are a little bit dangerous !

Yup they can sure be...especially if autocorrect misbehaves haha.


Real Men Use Linux

Offline

#8 2018-05-02 00:55:28

jjanderson5
Member
Registered: 2016-05-10
Posts: 62

Re: [RESOLVED] Wifi is not working on HP Probook 6540b

I have started installed the Helium release. The good news is that the wifi is now working.
The bad news is that there are several new problems, but I will address those in a new thread

Offline

#9 2018-05-02 10:25:01

altman
Member
From: Canada
Registered: 2015-10-24
Posts: 122

Re: [RESOLVED] Wifi is not working on HP Probook 6540b

DeepDayze wrote:
altman wrote:

lol; forums are a little bit dangerous !

Yup they can sure be...especially if autocorrect misbehaves haha.


lol, you bet mate !


HP Pavilion dv7 Notebook/Intel Core i7-2670QM/ BunsenLab Helium
Dell Inspiron 1720/Intel Core2 Duo T5450/ ArchLabs 2018.05

Offline

#10 2018-05-02 10:26:00

altman
Member
From: Canada
Registered: 2015-10-24
Posts: 122

Re: [RESOLVED] Wifi is not working on HP Probook 6540b

jjanderson5 wrote:

I have started installed the Helium release. The good news is that the wifi is now working.
The bad news is that there are several new problems, but I will address those in a new thread


Glad that you got it fixed.


HP Pavilion dv7 Notebook/Intel Core i7-2670QM/ BunsenLab Helium
Dell Inspiron 1720/Intel Core2 Duo T5450/ ArchLabs 2018.05

Offline

#11 2018-05-02 18:17:13

ohnonot
...again
Registered: 2015-09-29
Posts: 2,558
Website

Re: [RESOLVED] Wifi is not working on HP Probook 6540b

jjanderson5 wrote:

The bad news is that there are several new problems, but I will address those in a new thread

i hope your relationship hasn't suffered too much.  big_smile
(ok i'll stop this now)

Offline

Board footer

Powered by FluxBB