You are not logged in.

#1 2018-03-13 03:34:54

ab90
Member
Registered: 2017-09-06
Posts: 81

Tuxguitar - [apt-get install timidity] works, but cant be selected

https://wiki.ubuntuusers.de/TuxGuitar/

no-sound issue...
common thing for tuxguitar, but the usuall setting cant be selected after successful installation of timidity

Last edited by ab90 (2018-03-13 03:35:52)

Offline

#2 2018-03-13 17:26:47

ohnonot
...again
Registered: 2015-09-29
Posts: 2,951
Website

Re: Tuxguitar - [apt-get install timidity] works, but cant be selected

are you refering to this https://wiki.ubuntuusers.de/TuxGuitar/#Kein-Sound ?
shouldn't you be installing tuxguitar-alsa? why timidity?
you aren't really explaining your problem very well.

Offline

#3 2018-03-15 17:14:19

ab90
Member
Registered: 2017-09-06
Posts: 81

Re: Tuxguitar - [apt-get install timidity] works, but cant be selected

was used to timidity.

In 'Tools' -> Plugins: is alsa-output plugin already checkmarked.

But ill install tuxguitar- alsa now.
lets see...

Thanks for the tip!


Update: 'tuxguitar-alsa is already newest version.'

Last edited by ab90 (2018-03-15 17:16:56)

Offline

#4 2018-08-20 08:06:21

cherkie
Member
Registered: 2018-08-09
Posts: 32

Re: Tuxguitar - [apt-get install timidity] works, but cant be selected

I have had the same issue, workaround is.

Open new terminal, start

timidity -iA -Os

start tuxguitar, go to tools -> sound -> midi output, voila, timidity is available.

Then if you want custom soundfonts change the:

plugins -> java sound application (or something starting with A, acronym is jsa) -> configure, navigate to your custom soundfonts.

Offline

#5 2018-08-20 17:10:36

ab90
Member
Registered: 2017-09-06
Posts: 81

Re: Tuxguitar - [apt-get install timidity] works, but cant be selected

Hey cherkie,

i got sound out of that software now! Thank you very much.
Will it only work if the terminal is running the command that you gave? It stoped working as soon as i closed the terminal....

Offline

#6 2018-08-22 06:20:38

ohnonot
...again
Registered: 2015-09-29
Posts: 2,951
Website

Re: Tuxguitar - [apt-get install timidity] works, but cant be selected

cherkie wrote:

I have had the same issue, workaround is.

Open new terminal, start

timidity -iA -Os

start tuxguitar, go to tools -> sound -> midi output, voila, timidity is available.

oh yes, i have noticed that with various applications.
midi synth ouput is only available when the software providing it is running.
makes a lot of sense once you groked it.

i guess there's different ways to achieve getting that software running:
- when needed (start in terminal or from launcher), or
- via a systemd service unit, or
- ...

Offline

#7 2018-08-22 13:41:41

cherkie
Member
Registered: 2018-08-09
Posts: 32

Re: Tuxguitar - [apt-get install timidity] works, but cant be selected

ab90 wrote:

Hey cherkie,

i got sound out of that software now! Thank you very much.
Will it only work if the terminal is running the command that you gave? It stoped working as soon as i closed the terminal....

holy crap I helped someone with linux having been a noob myself!

this is my proudest linuxday to date.

ohnonot wrote:

- via a systemd service unit, or

how would you do that? I was thinking about making it start with starting tuxguitar, the only idea that came to my mind was writing a super simple bash script but I didn't know how to start so I settled on starting it in terminal whenever needed.

Offline

#8 2018-08-23 04:43:04

ohnonot
...again
Registered: 2015-09-29
Posts: 2,951
Website

Re: Tuxguitar - [apt-get install timidity] works, but cant be selected

cherkie wrote:
ohnonot wrote:

- via a systemd service unit, or

how would you do that?

it would require a little research, into systemd user units, but often the installed package already provides some mechanism, so looking for that should be the first step.

I was thinking about making it start with starting tuxguitar, the only idea that came to my mind was writing a super simple bash script

that would probably be sufficient.
try:

#!/bin/sh

timidity & pid=$!
tuxguitar
kill $pid

(not tested)

Last edited by ohnonot (2018-08-23 04:43:56)

Offline

#9 2018-08-23 10:13:43

cherkie
Member
Registered: 2018-08-09
Posts: 32

Re: Tuxguitar - [apt-get install timidity] works, but cant be selected

ohnonot wrote:
#!/bin/sh

timidity & pid=$!
tuxguitar
kill $pid

(not tested)

is it possible to add two switches in bash to timidity: -iA -iO ?

so code would be

#!/bin/sh

timidity -iA -iO & pid=$!
tuxguitar
kill $pid

I am not on my home BL and don't have tuxguitar at work.

Offline

#10 2018-08-24 12:23:11

ab90
Member
Registered: 2017-09-06
Posts: 81

Re: Tuxguitar - [apt-get install timidity] works, but cant be selected

I just tried the last code mentioned.
It opened tuxguitar but i had to go to the settings myself again, then i did not show al the midi ports like before. infact, no sound yield.



(but i was thinking i need a triggered switch on the event of tuxguitar, but still i would have to browse the settings myself each time...)

Offline

#11 2018-08-25 11:18:53

ohnonot
...again
Registered: 2015-09-29
Posts: 2,951
Website

Re: Tuxguitar - [apt-get install timidity] works, but cant be selected

PS: a delay (sleep) might be required before launching tuxguitar in the above script.
and i say it again, i didn't test it. it's simple & self-explanatory, and so should be its debugging.

Offline

Board footer

Powered by FluxBB