You are not logged in.

#1 2017-10-04 14:24:29

tknomanzr
BL Die Hard
From: Around the Bend
Registered: 2015-09-29
Posts: 1,029

<SOLVED> xserver-share=false in /etc/liglightdm.conf fixes accessibili

I was wanting to get an onscreen keyboard working in Bunsenlabs. I tried installing several and none of them worked. They all threw the same exception:

(florence:755): WARNING : Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
(florence:755): WARNING : Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
WARNING: AT-SPI has been disabled at run time: auto-hide mode is disabled.
(florence:753): WARNING : Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
(florence:753): ERROR : AT-SPI: COuldn't connect to accessibility bus. Is at-spi-bus-launcher running?

After doing some digging, I read that lightdm was starting the on-screen keyboard as user lightdm. After following this debian bug thread.

Hello again.

When working to solve bug 760740 (at least on bleeding-edge versions of
lightdm and lightdm-gtk-greeter) I found a different workaround than the
one employed by Samuel: setting the xserver-share option to false in
lightdm.conf lets AT-SPI die after the Lightdm greeter session
terminates and the X server exits; I suppose restarting the X server
wouldn't be unacceptable, even if in this case the issue is not moot, as
we have a fix.

After a quick check in htop, it was apparent that at-spi-bus-launcher was indeed running as user lightdm. Changing /etc/lightdm/lightdm.conf xserver-share=True to xserver-share=False allows onboard to run. Additionally all accessibility bus errors in ~/.xsession-errors stop.  I am not sure what the implications in changing this are. It seems to me however, that lightdm has to restart the xserver after login but before starting up openbox. I believe logging out, then back in causes onboard's gtk.StatusIcon to disappear from the system tray, however. There are other bugs that show a lack of platform abstraction, in that apps like google-chrome-stable do not respond to at-spi events. However, these issues have nothing to do with lightdm's settings.

So I guess the question I have is what are the implications of changing this in lightdm? Additionally, do we change lightdm's default config or just document the bug given that most users don't use the accessibility toolkit?

For reference, I am working on a tablet mode for this Surface Pro IV using a combination of tint2 and the oncreen keyboard. The touch screen already works. I am not sure if it is possible to get the pen working but it would be nice for use in the GIMP, etc.

Last edited by tknomanzr (2017-10-07 18:04:10)

Offline

#2 2017-10-05 06:22:01

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: <SOLVED> xserver-share=false in /etc/liglightdm.conf fixes accessibili

tknomanzr wrote:

That was marked fixed for version 1.8.5-2 of lightdm-gtk-greeter:

https://bugs.debian.org/cgi-bin/bugrepo … =760740#60

Debian stretch has v2.0.2-1, is that what you're using?

Just out of interest, rather than changing /etc/lightdm/lightdm.conf, try editing /etc/systemd/logind.conf and change the "KillUserProcesses" line to:

KillUserProcesses=yes

Does that fix your problem?


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#3 2017-10-05 15:51:49

tknomanzr
BL Die Hard
From: Around the Bend
Registered: 2015-09-29
Posts: 1,029

Re: <SOLVED> xserver-share=false in /etc/liglightdm.conf fixes accessibili

This works with some changes. I had to autostart it via the .desktop file in /etc/xdg/autostart, with some modifications:

Original

[Desktop Entry]
Name=Onboard
Exec=onboard --not-show-in=GNOME,GNOME-Classic:GNOME --startup-delay=3.0
Type=Application
NoDisplay=true
X-Ubuntu-Gettext-Domain=onboard
AutostartCondition=GSettings org.gnome.desktop.a11y.applications screen-keyboard-enabled
X-GNOME-AutoRestart=true
OnlyShowIn=GNOME;Unity;MATE;

Edited Version

[Desktop Entry]
Name=Onboard
Exec=onboard
Type=Application
NoDisplay=true
X-Ubuntu-Gettext-Domain=onboard
AutostartCondition=GSettings org.gnome.desktop.a11y.applications screen-keyboard-enabled
X-GNOME-AutoRestart=true
OnlyShowIn=

Anything started via ~/.config/openbox/autostart is unable to connect to the accessibility bus, throwing errors such as:

* (onboard:1579): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-Vgp0whSnVF: Connection refused
** (onboard:1579): ERROR **: AT-SPI: Couldn't connect to accessibility bus. Is at-spi-bus-launcher running?
** (volumeicon:1404): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-p6082szEZ7: Connection refused
** (clipit:1406): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-p6082szEZ7: Connection refused
** (polkit-gnome-authentication-agent-1:1306): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-p6082szEZ7: Connection refused
** (nitrogen:1307): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-p6082szEZ7: Connection refused

It looks to me like the connection to the accessibility bus works when started via a .desktop launcher in /etc/xdg/autostart but not via ~/.config/openbox/autostart.

apt-cache policy shows me:

tknomanzr@testbed:~$ apt-cache policy lightdm-gtk-greeter
lightdm-gtk-greeter:
  Installed: 2.0.2-1
  Candidate: 2.0.2-1
  Version table:
 *** 2.0.2-1 500
        500 http://deb.debian.org/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status

Last edited by tknomanzr (2017-10-05 15:53:38)

Offline

#4 2017-10-05 16:52:01

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: <SOLVED> xserver-share=false in /etc/liglightdm.conf fixes accessibili

tknomanzr wrote:

I was wanting to get an onscreen keyboard working in Bunsenlabs. I tried installing several and none of them worked.

florence works for me in a fresh install:

2017-10-05-164910_1920x1080_scrot.th.png

empty@testbed:~ $ apt-cache policy lightdm-gtk-greeter                             
lightdm-gtk-greeter:
  Installed: 2.0.2-1
  Candidate: 2.0.2-1
  Version table:
 *** 2.0.2-1 500
        500 https://cdn-aws.deb.debian.org/debian stretch/main amd64 Packages
        100 /var/lib/dpkg/status
empty@testbed:~ $

“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#5 2017-10-07 18:02:45

tknomanzr
BL Die Hard
From: Around the Bend
Registered: 2015-09-29
Posts: 1,029

Re: <SOLVED> xserver-share=false in /etc/liglightdm.conf fixes accessibili

After much testing, I have decided that onboard works best for my needs. I am going to mark the OP as <SOLVED>. If a mod could pick this up and move it into a help & support channel, that would probably be a better place for it.

Offline

#6 2017-10-07 18:41:53

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: <SOLVED> xserver-share=false in /etc/liglightdm.conf fixes accessibili

tknomanzr wrote:

If a mod could pick this up and move it into a help & support channel, that would probably be a better place for it.

Done!

Thanks for reporting back.


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

Board footer

Powered by FluxBB