You are not logged in.

#1 2016-12-29 14:28:16

redsearch
Member
Registered: 2015-11-17
Posts: 16

Disable touchpad while typing automatically

How to disable touchpad while typing automatically?

Offline

#2 2016-12-29 14:40:38

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Disable touchpad while typing automatically

Add this line to ~/.config/openbox/autostart:

syndaemon -i .5 -K -t -R -d &

This should be a commented option in the next release:

https://github.com/BunsenLabs/bunsen-co … ostart#L45

smile


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#3 2016-12-30 01:25:52

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 7,418
Website

Re: Disable touchpad while typing automatically

^ "should be" in this case meaning "will probably be" rather than "is desired to be". cool


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Offline

#4 2016-12-30 12:13:42

martix
Kim Jong-un Stunt Double
Registered: 2016-02-19
Posts: 1,267

Re: Disable touchpad while typing automatically

These details make a distro much more polished. Like having the username in the login window on default (if I'm not mistaken, this was the case on #!). Not crucial, but still more convenient.

Offline

#5 2016-12-31 09:40:57

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 7,418
Website

Re: Disable touchpad while typing automatically

martix wrote:

having the username in the login window

It's open to discussion whether there's a possible privacy issue with that, so we've kept with the Debian default.


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Offline

#6 2016-12-31 11:15:37

martix
Kim Jong-un Stunt Double
Registered: 2016-02-19
Posts: 1,267

Re: Disable touchpad while typing automatically

@John Ok, I see. In concreto: Is it about a potential attacker, who knows the username e.g. on a lock-screen, so only the password has to be guessed (instead of username+password)?

Anyhow, it's easy to change: Edit 'greeter hide user' to 'false' in /etc/lightdm.conf as root. Save it, reboot. I like it this way, even though it's indeed less secure, password protection is ok for me.

Offline

#7 2017-01-03 13:22:48

redsearch
Member
Registered: 2015-11-17
Posts: 16

Re: Disable touchpad while typing automatically

Head_on_a_Stick wrote:

Add this line to ~/.config/openbox/autostart:

syndaemon -i .5 -K -t -R -d &

This should be a commented option in the next release:

https://github.com/BunsenLabs/bunsen-co … ostart#L45

smile


I used syndaemon, works great.

Offline

#8 2017-01-04 05:47:02

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 7,418
Website

Re: Disable touchpad while typing automatically

martix wrote:

@John Ok, I see. In concreto: Is it about a potential attacker, who knows the username e.g. on a lock-screen, so only the password has to be guessed (instead of username+password)?

I think it's more about privacy in multi-user systems in an environment where you don't necessarily want every user to know the names of all the other people using the system.


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Offline

#9 2017-01-04 19:23:18

martix
Kim Jong-un Stunt Double
Registered: 2016-02-19
Posts: 1,267

Re: Disable touchpad while typing automatically

@john Indeed, valid point, there is a list of registered user available in the login window. I'm wondering if it would be possible to show only the name of the user who logged in for the session. In that case a log-in after a screen lock would be more convenient without privacy concerns.

Offline

#10 2017-01-05 08:09:04

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 7,418
Website

Re: Disable touchpad while typing automatically

If the above privacy issue is unimportant in your case then you've already posted how to display user names. I don't know of any way to configure LightDm to display only the name of the last logged-in user though.


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Offline

#11 2017-01-22 23:35:12

KrunchTime
Member
Registered: 2015-09-29
Posts: 857

Re: Disable touchpad while typing automatically

^ This is Linux.  There's gotta be a way, but maybe only programmatically.

Offline

#12 2017-01-24 01:39:03

martix
Kim Jong-un Stunt Double
Registered: 2016-02-19
Posts: 1,267

Re: Disable touchpad while typing automatically

Yes, I'm sure this will be available some time later. I have seen some posts on other distro's forums where users were trying to figure out such a configuration (without success). At this point of time - as John mentioned - LightDM does not offer this feature yet (at least this is what some research showed me too).

Offline

#13 2017-02-08 21:53:18

dbvolvox
Member
From: England
Registered: 2015-09-29
Posts: 87
Website

Re: Disable touchpad while typing automatically

redsearch wrote:
Head_on_a_Stick wrote:

Add this line to ~/.config/openbox/autostart:

syndaemon -i .5 -K -t -R -d &

This should be a commented option in the next release:

https://github.com/BunsenLabs/bunsen-co … ostart#L45

smile


I used syndaemon, works great.

+1 smile smile

Offline

#14 2017-02-12 11:32:22

hhh
Meep!
Registered: 2015-09-17
Posts: 10,758
Website

Re: Disable touchpad while typing automatically

re: login name autocomplete, we're leaving that for the user to change. A quick web search or forum post will take care of those who find it a nuisance.

Offline

Board footer

Powered by FluxBB