You are not logged in.

#1 2016-10-03 19:57:04

CooKiECruNChEr43
Member
Registered: 2015-10-17
Posts: 64

Problems with internet connection

Sometimes, when I start my computer, the internet connection gets lost after a few seconds.
Restarting the computer solves the problem. I think it is a DHCP problem.

I have searched the internet for a solution and I came across this url:
http://www.ubuntugeek.com/ubuntu-networ … -line.html

Especially, the heading: "Configuring DHCP address for your network card" interest me, because I believe this is the cause of my problem. According to this webpage, one should change the file /etc/network/interfaces to:

gksudo gedit /etc/network/interfaces

# The primary network interface -- use DHCP to find our address
auto eth0
iface eth0 inet dhcp

My /etc/network/interfaces file is now:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

What is the difference between the two configurations? And where is the information "interfaces(5)" to be found?

Last edited by CooKiECruNChEr43 (2016-10-13 13:37:13)

Offline

#2 2016-10-03 20:04:34

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Problems with internet connection

What is your hardware?

lspci -knn | grep -iA2 net

Adding that stanza to /etc/network/interfaces will still result in dhclient being run, to use static IPs instead see https://wiki.debian.org/NetworkConfigur … e_manually


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#3 2016-10-03 20:07:12

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Problems with internet connection

CooKiECruNChEr43 wrote:

where is the information "interfaces(5)" to be found?

That is a man page reference, the number in brackets is the section in which the page can be found.

To read it, use:

man 5 interfaces

As there are no "interfaces" pages in any other sections you could also use:

man interfaces

See man(1) for more...


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#4 2016-10-03 20:22:15

CooKiECruNChEr43
Member
Registered: 2015-10-17
Posts: 64

Re: Problems with internet connection

The command: lspci -knn | grep -iA2 net gives:

40:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express [14e4:1677] (rev 01)
    Subsystem: Hewlett-Packard Company DC7100 SFF(DX878AV) [103c:3006]
    Kernel driver in use: tg3

Offline

#5 2016-10-03 20:27:53

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Problems with internet connection

Try unplugging the cable then run these commands (in order):

sudo -i
modprobe -r tg3
modprobe broadcom
modprobe tg3
exit

Is the problem then fixed if you connect the cable again?

https://wiki.archlinux.org/index.php/Ne … m_BCM57780


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#6 2016-10-03 20:29:25

CooKiECruNChEr43
Member
Registered: 2015-10-17
Posts: 64

Re: Problems with internet connection

I am not an expert but I think that a static IP is only necessary when you want to run a server.

I ran man 5 interfaces in my terminal. A lot of stuff to be read.

But Head_on_a_Stick, if it is indeed a DHCP-problem, is changing the code in the etc/network/interfaces file as described on the ubuntugeek website a solution to my problem?

Or are there any others, better ones?

I tried to run:
sudo dhclient eth0
but that didn't work.

Offline

#7 2016-10-03 20:33:13

CooKiECruNChEr43
Member
Registered: 2015-10-17
Posts: 64

Re: Problems with internet connection

Regarding your last comment, Head_on_a_Stick, I will give it a try next time the problem occurs.

Offline

#8 2016-10-03 20:45:24

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Problems with internet connection

CooKiECruNChEr43 wrote:

I think that a static IP is only necessary when you want to run a server.

If you do not wish to use a DHCP client then a static IP must be assigned.

Using "dhcp" in /etc/network/interfaces will cause `dhclient` to be run; as you believe that DHCP is the problem then "dhcp" should *not* be used in the interfaces file and "static" should be used instead.

Note that static IPs can be set (and thus DHCP disabled) via NetworkManager, there is no need to edit /etc/network/interfaces at all.


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#9 2016-10-03 20:49:21

CooKiECruNChEr43
Member
Registered: 2015-10-17
Posts: 64

Re: Problems with internet connection

Okay, Head_on_a_Stick, ty for your answers. Like I said, I will give it a try next time the problem occurs.

Offline

#10 2016-10-04 06:10:35

CooKiECruNChEr43
Member
Registered: 2015-10-17
Posts: 64

Re: Problems with internet connection

Well, it happened again and your solution worked Head_on_a_Stick. Ty again.

Offline

#11 2016-10-04 06:18:46

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Problems with internet connection

That fix will not persist after a reboot.

To make that behavior permanent, create a file at /etc/modprobe.d/broadcom.conf (as root!) with the following content:

softdep tg3 pre: broadcom

This should ensure that the modules are always loaded in the correct order wink


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#12 2016-10-04 09:43:39

CooKiECruNChEr43
Member
Registered: 2015-10-17
Posts: 64

Re: Problems with internet connection

Okay, done. smile

Offline

#13 2016-10-04 15:17:04

Horizon_Brave
Operating System: Linux-Nettrix
Registered: 2015-10-18
Posts: 1,473

Re: Problems with internet connection

Cookie did you ever figure out *why* you're DHCP server was the issue? Do you know what the root cause of this was? Were you pulling DHCP leases from two different servers or something, causing a conflict? Are your leases set on your router for an ultra small period of time?


"I have not failed, I have found 10,000 ways that will not work" -Edison

Offline

#14 2016-10-04 17:45:57

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Problems with internet connection

@H_B: the problem was not DHCP, please read the ArchWiki link I supplied in post #5 -- the Broadcom card has two modules and they must be loaded in the correct order for the card to work; it's just another Broadcom SNAFU...

You may also want to read http://xyproblem.info/


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#15 2016-10-04 21:28:15

Horizon_Brave
Operating System: Linux-Nettrix
Registered: 2015-10-18
Posts: 1,473

Re: Problems with internet connection

Head_on_a_Stick wrote:

@H_B: the problem was not DHCP, please read the ArchWiki link I supplied in post #5 -- the Broadcom card has two modules and they must be loaded in the correct order for the card to work; it's just another Broadcom SNAFU...

You may also want to read http://xyproblem.info/

Oh whoops... a bit hard to follow, the dhcp thing was mentioned even passed the 5th post,  that's why I thought it was still the problem..

lol, I've seen that link before.. a bit condescending, but funny  smile


"I have not failed, I have found 10,000 ways that will not work" -Edison

Offline

#16 2016-10-13 13:42:46

CooKiECruNChEr43
Member
Registered: 2015-10-17
Posts: 64

Re: Problems with internet connection

I thought that your solution had solved the problem, Head_on_a_Stick, but it didn't. I created the /etc/modprobe.d/broadcom.conf file with the aforementioned content but it doesn't last.
The solution under the fifth post works though. I have to close my browsers and then run the commands. Internet connection is restored.

Last edited by CooKiECruNChEr43 (2016-11-19 09:42:30)

Offline

#17 2016-12-11 09:40:02

CooKiECruNChEr43
Member
Registered: 2015-10-17
Posts: 64

Re: Problems with internet connection

I have made a similar question on this forum: https://forums.bunsenlabs.org/viewtopic.php?id=2830.

The problem is still the same with something added to it:
My internet connection falls away and can only be restored by running these commands at root:

sudo -i
modprobe -r tg3
modprobe broadcom
modprobe tg3

Every time I use the computer I have to use these commands several times to maintain connection with the internet.

I also get a kernel error:

Message from syslogd@debian1 at Dec  7 14:48:51 ...
 kernel:[ 2548.672013] NMI: PCI system error (SERR) for reason b1 on CPU 0.

Message from syslogd@debian1 at Dec  7 14:48:51 ...
 kernel:[ 2548.672013] Dazed and confused, but trying to continue

It annoys the heck out of me.

Last edited by CooKiECruNChEr43 (2016-12-11 09:40:57)

Offline

#18 2016-12-11 10:43:05

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Problems with internet connection

CooKiECruNChEr43 wrote:

I have made a similar question on this forum: https://forums.bunsenlabs.org/viewtopic.php?id=2830.

The problem is still the same with something added to it

Threads merged.


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#19 2016-12-11 10:49:16

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Problems with internet connection

CooKiECruNChEr43 wrote:

Every time I use the computer I have to use these commands several times to maintain connection with the internet.

As the /etc/modprobe.d file does not appear to work, you could try adding the modules (in the correct order) to the initramfs, as described in the ArchWiki link I provided:

https://wiki.archlinux.org/index.php/Ne … m_BCM57780

I've never tried reconfiguring the initrd in Debian, here is an overview of the differences between the linked Arch method and the Debian Way:

http://unix.stackexchange.com/questions … -on-debian

Good luck!


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

Board footer

Powered by FluxBB