You are not logged in.

#1 2016-11-13 13:53:25

mobeus
Member
Registered: 2016-11-13
Posts: 5

Problem installing Broadcom wl driver with kernel 4.7.0-0.bpo.1-amd64

Hi,
Please bear with me, as I am a bit of a newbie, but here is my problem...
I installed Bunsenlabs (Hydrogen) from a USB into a Macbook Air 6,1 - and everything worked apart from the wireless adapter, and the screen had some artifacts (jittering and odd colours in places). After some research , I enabled non-free and installed broadcom-sta-dkms successfully and got the wifi working.
Then, in my hubris, I tried improving the screen performance, which required my updating the kernel to the one in backports. This sorted the screen, but broke the wifi (in both old an new kernels, indeed). Fine, I thought, I'll just get the broadcom-sta-dkms from backports too and re-install as before.

Nope, I get what appear to be compilation errors, and am now at the limits of my rather limited expertise.

Can anyone advise please?

Here is the problem I get..

mobeus@Ghost:~$ sudo apt-get install -t jessie-backports linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,')
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  dkms fakeroot libfakeroot
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  linux-headers-amd64
0 upgraded, 1 newly installed, 0 to remove and 106 not upgraded.
Need to get 0 B/5,726 B of archives.
After this operation, 6,144 B of additional disk space will be used.
Selecting previously unselected package linux-headers-amd64.
(Reading database ... 191518 files and directories currently installed.)
Preparing to unpack .../linux-headers-amd64_4.7+75~bpo8+1_amd64.deb ...
Unpacking linux-headers-amd64 (4.7+75~bpo8+1) ...
Setting up linux-headers-amd64 (4.7+75~bpo8+1) ...
mobeus@Ghost:~$ sudo apt-get install -t jessie-backports broadcom-sta-dkms
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  broadcom-sta-dkms
0 upgraded, 1 newly installed, 0 to remove and 106 not upgraded.
Need to get 0 B/2,208 kB of archives.
After this operation, 14.4 MB of additional disk space will be used.
Selecting previously unselected package broadcom-sta-dkms.
(Reading database ... 191521 files and directories currently installed.)
Preparing to unpack .../broadcom-sta-dkms_6.30.223.271-2~bpo8+1_all.deb ...
Unpacking broadcom-sta-dkms (6.30.223.271-2~bpo8+1) ...
Setting up broadcom-sta-dkms (6.30.223.271-2~bpo8+1) ...
Loading new broadcom-sta-6.30.223.271 DKMS files...
Building only for 4.7.0-0.bpo.1-amd64
Building initial module for 4.7.0-0.bpo.1-amd64
Error! Bad return status for module build on kernel: 4.7.0-0.bpo.1-amd64 (x86_64)
Consult /var/lib/dkms/broadcom-sta/6.30.223.271/build/make.log for more information.

That log is quite large, and I don't know if it's acceptable to post it all here, but here are some bits from the top and bottom of it to give you an idea of the issues it contains...

DKMS make.log for broadcom-sta-6.30.223.271 for kernel 4.7.0-0.bpo.1-amd64 (x86_64)
Sun 13 Nov 13:34:18 GMT 2016
/bin/sh: 1: [: Illegal number:
/bin/sh: 1: [: Illegal number:
Wireless Extension is the only possible API for this kernel version
Using Wireless Extension API
KBUILD_NOPEDANTIC=1 make -C /lib/modules/4.7.0-0.bpo.1-amd64/build M=`pwd`
make[1]: Entering directory '/usr/src/linux-headers-4.7.0-0.bpo.1-amd64'
CFG80211 API is prefered for this kernel version
Using CFG80211 API
Kernel architecture is X86_64
  LD      /var/lib/dkms/broadcom-sta/6.30.223.271/build/built-in.o
  CC [M]  /var/lib/dkms/broadcom-sta/6.30.223.271/build/src/shared/linux_osl.o
  CC [M]  /var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_linux.o
  CC [M]  /var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_iw.o
  CC [M]  /var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.o
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c:239:12: error: ‘IEEE80211_BAND_2GHZ’ undeclared here (not in a function)
  .band   = IEEE80211_BAND_2GHZ,  \
            ^
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c:285:2: note: in expansion of macro ‘CHAN2G’
  CHAN2G(1, 2412, 0),
  ^
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c:248:12: error: ‘IEEE80211_BAND_5GHZ’ undeclared here (not in a function)
  .band   = IEEE80211_BAND_5GHZ,  \
            ^
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c:302:2: note: in expansion of macro ‘CHAN5G’
  CHAN5G(34, 0), CHAN5G(36, 0),
  ^
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c:302:2: error: initializer element is not constant
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c:302:2: error: (near initialization for ‘__wl_5ghz_a_channels[0].band’)
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c:302:2: error: initializer element is not constant
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c:302:2: error: (near initialization for ‘__wl_5ghz_a_channels[1].band’)
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c:303:2: error: initializer element is not constant
  CHAN5G(38, 0), CHAN5G(40, 0),
  ^
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c:303:2: error: (near initialization for ‘__wl_5ghz_a_channels[2].band’)
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c:303:2: error: initializer element is not constant
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c:303:2: error: (near initialization for ‘__wl_5ghz_a_channels[3].band’)
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c:304:2: error: initializer element is not constant
  CHAN5G(42, 0), CHAN5G(44, 0),
  ^
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c:304:2: error: (near initialization for ‘__wl_5ghz_a_channels[4].band’)

and at the tail of it...

/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c: In function ‘wl_inform_single_bss’:
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c:2001:9: error: incompatible type for argument 2 of ‘ieee80211_channel_to_frequency’
  freq = ieee80211_channel_to_frequency(notif_bss_info->channel,
         ^
In file included from /var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c:33:0:
/usr/src/linux-headers-4.7.0-0.bpo.1-common/include/net/cfg80211.h:3648:5: note: expected ‘enum nl80211_band’ but argument is of type ‘struct ieee80211_channel *’
 int ieee80211_channel_to_frequency(int chan, enum nl80211_band band);
     ^
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c:2001:7: warning: assignment makes integer from pointer without a cast
  freq = ieee80211_channel_to_frequency(notif_bss_info->channel,
       ^
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c: In function ‘wl_notify_connect_status’:
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c:2119:9: warning: assignment makes integer from pointer without a cast
    band = (chan <= CH_MAX_2G_CHANNEL) ? IEEE80211_BAND_2GHZ : IEEE80211_BAND_5GHZ;
         ^
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c: In function ‘wl_ch_to_chanspec’:
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c:2253:18: warning: comparison between pointer and integer
   if (chan->band == IEEE80211_BAND_2GHZ) {
                  ^
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c:2256:23: warning: comparison between pointer and integer
   else if (chan->band == IEEE80211_BAND_5GHZ) {
                       ^
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c: In function ‘wl_update_wiphybands’:
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c:2888:15: error: array subscript is not an integer
   wiphy->bands[IEEE80211_BAND_5GHZ] = &__wl_band_5ghz_n;
               ^
/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.c:2888:3: warning: statement with no effect [-Wunused-value]
   wiphy->bands[IEEE80211_BAND_5GHZ] = &__wl_band_5ghz_n;
   ^
/usr/src/linux-headers-4.7.0-0.bpo.1-common/scripts/Makefile.build:294: recipe for target '/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.o' failed
make[4]: *** [/var/lib/dkms/broadcom-sta/6.30.223.271/build/src/wl/sys/wl_cfg80211_hybrid.o] Error 1
/usr/src/linux-headers-4.7.0-0.bpo.1-common/Makefile:1475: recipe for target '_module_/var/lib/dkms/broadcom-sta/6.30.223.271/build' failed
make[3]: *** [_module_/var/lib/dkms/broadcom-sta/6.30.223.271/build] Error 2
Makefile:150: recipe for target 'sub-make' failed
make[2]: *** [sub-make] Error 2
Makefile:8: recipe for target 'all' failed
make[1]: *** [all] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.7.0-0.bpo.1-amd64'
Makefile:177: recipe for target 'all' failed
make: *** [all] Error 2
mobeus@Ghost:~$ uname -rv
4.7.0-0.bpo.1-amd64 #1 SMP Debian 4.7.8-1~bpo8+1 (2016-10-19)

mobeus@Ghost:~$ lspci -knn | grep -EiA2 net
02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 09)
	Subsystem: ASUSTeK Computer Inc. P8 series motherboard [1043:8505]
	Kernel driver in use: r8169
--
05:00.0 Network controller [0280]: Broadcom Corporation BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03)
	Subsystem: Broadcom Corporation Device [14e4:0619]

Some other points - due to the lack of internet on my macbook air, I'm running the above steps on my wife's machine (where everything works perfectly) and then testing on my own afterwards - this approach worked out fine for the older kernel.

It's quite possible I'm doing something really dappy, so any advice would be wonderful!

I get the impression that the wl Broadcom drivers are known to be problematic, so if this cannot be resolved, would just getting a wifi dongle solve the problem? if so, can anyone recommend one which is Linux friendly?

Thanks,

Dean.

Offline

#2 2016-11-13 16:10:02

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Problem installing Broadcom wl driver with kernel 4.7.0-0.bpo.1-amd64

mobeus wrote:

I enabled non-free

That should not be needed, the non-free component is already enabled in a stock BL system.

Did you select a mirror during the installation process?

You may be missing some critical parts of your system, please post the output of:

apt-cache policy

In respect of the Broadcom card, use this to install all the packages needed to build the custom kernel module:

sudo -i # attain root shell
apt install module-assistant broadcom-sta-source
m-a prepare
m-a build broadcom-sta-source
exit # drop elevated privileges

There are sometimes issues with the backported kernel and custom modules, for example:

http://forums.debian.net/viewtopic.php?f=7&t=130041


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#3 2016-11-13 17:58:53

mobeus
Member
Registered: 2016-11-13
Posts: 5

Re: Problem installing Broadcom wl driver with kernel 4.7.0-0.bpo.1-amd64

Hi Head on a Stick,
Thanks for getting back to me so fast!

Here is the output..

mobeus@Ghost:~$ apt-cache policy
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://dl.google.com/linux/chrome/deb/ stable/main amd64 Packages
     release v=1.0,o=Google, Inc.,a=stable,n=stable,l=Google,c=main
     origin dl.google.com
 500 http://httpredir.debian.org/debian/ jessie-backports/non-free Translation-en
 500 http://httpredir.debian.org/debian/ jessie-backports/main Translation-en
 500 http://httpredir.debian.org/debian/ jessie-backports/contrib Translation-en
 100 http://httpredir.debian.org/debian/ jessie-backports/non-free amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=non-free
     origin httpredir.debian.org
 100 http://httpredir.debian.org/debian/ jessie-backports/contrib amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=contrib
     origin httpredir.debian.org
 100 http://httpredir.debian.org/debian/ jessie-backports/main amd64 Packages
     release o=Debian Backports,a=jessie-backports,n=jessie-backports,l=Debian Backports,c=main
     origin httpredir.debian.org
 500 http://pkg.bunsenlabs.org/debian/ bunsen-hydrogen/main amd64 Packages
     release o=bunsenlabs,n=bunsen-hydrogen,l=bunsenlabs,c=main
     origin pkg.bunsenlabs.org
 100 http://pkg.bunsenlabs.org/debian/ jessie-backports/main amd64 Packages
     release o=bunsenlabs,n=jessie-backports,l=bunsenlabs,c=main
     origin pkg.bunsenlabs.org
 500 http://httpredir.debian.org/debian/ jessie-updates/non-free Translation-en
 500 http://httpredir.debian.org/debian/ jessie-updates/main Translation-en
 500 http://httpredir.debian.org/debian/ jessie-updates/contrib Translation-en
 500 http://httpredir.debian.org/debian/ jessie-updates/non-free amd64 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=non-free
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie-updates/contrib amd64 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=contrib
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=jessie-updates,l=Debian,c=main
     origin httpredir.debian.org
 500 http://security.debian.org/ jessie/updates/non-free Translation-en
 500 http://security.debian.org/ jessie/updates/main Translation-en
 500 http://security.debian.org/ jessie/updates/contrib Translation-en
 500 http://security.debian.org/ jessie/updates/non-free amd64 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=non-free
     origin security.debian.org
 500 http://security.debian.org/ jessie/updates/contrib amd64 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=contrib
     origin security.debian.org
 500 http://security.debian.org/ jessie/updates/main amd64 Packages
     release v=8,o=Debian,a=stable,n=jessie,l=Debian-Security,c=main
     origin security.debian.org
 500 http://httpredir.debian.org/debian/ jessie/non-free Translation-en
 500 http://httpredir.debian.org/debian/ jessie/main Translation-en
 500 http://httpredir.debian.org/debian/ jessie/contrib Translation-en
 500 http://httpredir.debian.org/debian/ jessie/contrib amd64 Packages
     release v=8.6,o=Debian,a=stable,n=jessie,l=Debian,c=contrib
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie/non-free amd64 Packages
     release v=8.6,o=Debian,a=stable,n=jessie,l=Debian,c=non-free
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian/ jessie/main amd64 Packages
     release v=8.6,o=Debian,a=stable,n=jessie,l=Debian,c=main
     origin httpredir.debian.org
Pinned packages:

I tried your suggestion, but got this when doing 'm-a build broadcom-sta-source'... with the 'gui' saying the build failed. But it doesn't look to me like an error..?



for templ in ; do \                                                            
  │     cp $templ `echo $templ | sed -e 's/_KVERS_/4.7.0-0.bpo.1-amd64/g'` ; \     
  │   done                                                                         
  │ for templ in `ls debian/*.modules.in` ; do \                                   
  │     test -e ${templ%.modules.in}.backup || cp ${templ%.modules.in}             
  │ ${templ%.modules.in}.backup 2>/dev/null || true; \                             
  │     sed -e 's/##KVERS##/4.7.0-0.bpo.1-amd64/g                                  
  │ ;s/#KVERS#/4.7.0-0.bpo.1-amd64/g ; s/_KVERS_/4.7.0-0.bpo.1-amd64/g ;           
  │ s/##KDREV##/4.7.8-1~bpo8+1/g ; s/#KDREV#/4.7.8-1~bpo8+1/g ;                    
  │ s/_KDREV_/4.7.8-1~bpo8+1/g  ' < $templ > ${templ%.modules.in}; \               
  │   done                                                                         
  │ dh_clean                                                                       
  │ /usr/bin/make clean KBUILD=/lib/modules/4.7.0-0.bpo.1-amd64/build              
  │ KVER=4.7.0-0.bpo.1-amd64                                                       
  │ make[1]: Entering directory '/usr/src/modules/broadcom-sta'     

...
 │ /usr/src/modules/broadcom-sta/src/wl/sys/wl_cfg80211_hybrid.c: In function     
  │ ‘wl_update_wiphybands’:                                                        
  │ /usr/src/modules/broadcom-sta/src/wl/sys/wl_cfg80211_hybrid.c:2843:15:         
  │ error: array subscript is not an integer                                       
  │    wiphy->bands[IEEE80211_BAND_5GHZ] = &__wl_band_5ghz_n;                      
  │                ^                                                               
  │ /usr/src/modules/broadcom-sta/src/wl/sys/wl_cfg80211_hybrid.c:2843:3:          
  │ warning: statement with no effect [-Wunused-value]                             
  │    wiphy->bands[IEEE80211_BAND_5GHZ] = &__wl_band_5ghz_n;                      
  │    ^                                                                           
  │ /usr/src/linux-headers-4.7.0-0.bpo.1-common/scripts/Makefile.build:294:        
  │ recipe for target                                                              
  │ '/usr/src/modules/broadcom-sta/src/wl/sys/wl_cfg80211_hybrid.o' failed         
  │ make[5]: *** 
[/usr/src/modules/broadcom-sta/src/wl/sys/wl_cfg80211_hybrid.o] Error 1        
  │ /usr/src/linux-headers-4.7.0-0.bpo.1-common/Makefile:1475: recipe for          
  │ target '_module_/usr/src/modules/broadcom-sta' failed                          
  │ make[4]: *** [_module_/usr/src/modules/broadcom-sta] Error 2                   
  │ Makefile:150: recipe for target 'sub-make' failed                              
  │ make[3]: *** [sub-make] Error 2                                                
  │ Makefile:8: recipe for target 'all' failed                                     
  │ make[2]: *** [all] Error 2                                                     
  │ make[2]: Leaving directory '/usr/src/linux-headers-4.7.0-0.bpo.1-amd64'        
  │ debian/rules:16: recipe for target 'binary-modules' failed                     
  │ make[1]: *** [binary-modules] Error 2                                          
  │ make[1]: Leaving directory '/usr/src/modules/broadcom-sta'                     
  │ /usr/share/modass/include/common-rules.make:56: recipe for target              
  │ 'kdist_build' failed                                                           
  │ make: *** [kdist_build] Error 2               

Above is the top and tail of it - but the errors look the same as those in my original post. I'm guessing this has something to do with my repositories?

Thanks again!

Dean.

Offline

#4 2016-11-13 17:59:33

stevep
MX Linux Developer
Registered: 2016-08-08
Posts: 381

Re: Problem installing Broadcom wl driver with kernel 4.7.0-0.bpo.1-amd64

The j-b version won't build with the 4.7 kernel.  It was fixed with the -3 revision upstream, but nobody has backported it yet for j-b. A polite request on the backports mailing list should correct that oversight, though. I'll put one in.

The current -4 version on Stretch should also be a simple backport on the OBS, if HOAS wants to give it a go; otherwise I'll set one up.

broadcom-sta (6.30.223.271-3) unstable; urgency=low

  * Added patch to support kernel 4.7 changes, based on
    https://github.com/archlinuxcn/repo/blob/f4d6cff1cacf8dad13006fade5f96bc2cf020a9b/broadcom-wl-dkms/003-linux47.patch
    with minor modifications (closes: #829363)

 -- Eduard Bloch <blade@debian.org>  Sun, 03 Jul 2016 00:42:10 +0200

Last edited by stevep (2016-11-13 18:02:18)

Offline

#5 2016-11-13 18:24:21

mobeus
Member
Registered: 2016-11-13
Posts: 5

Re: Problem installing Broadcom wl driver with kernel 4.7.0-0.bpo.1-amd64

Hi Stevep,

That sounds wonderful (although, I must confess to only grasping the outline of what you said), and thanks.

How do I find out when Backports has been updated? You'll have to excuse my Noobness, I'm afraid!

Thanks again to both of you!

Dean.

Offline

#6 2016-11-13 19:40:01

stevep
MX Linux Developer
Registered: 2016-08-08
Posts: 381

Re: Problem installing Broadcom wl driver with kernel 4.7.0-0.bpo.1-amd64

You can search packages.debian.org for the package "broadcom-sta-dkms" to see when it makes it into backports, but sometimes they move pretty slow, and it takes just a few minutes for me to set up my own repository for it on the openSUSE build service, upload source files, and for it to build and publish the packages, so here's the OBS repository instructions:

https://software.opensuse.org/download. … m-sta-dkms

Use the Debian 8 instructions, I also built Debian 7 packages just in case anyone out there is running a 4.7 kernel on Wheezy (hey, it could happen).

You also have to run the commands to add the repository key as root or with sudo, whatever you use for sysadmin. Then the version from my repo should appear as an upgrade. That version ends with a "-4~bpo8" versus j-b's "-2~bpo8+1".

Offline

#7 2016-11-13 20:52:45

mobeus
Member
Registered: 2016-11-13
Posts: 5

Re: Problem installing Broadcom wl driver with kernel 4.7.0-0.bpo.1-amd64

Thank you so very much for your help!

I got it working by installing the deb file - and hence I am at this very moment writing from my internet enabled macbook air. Who needs OSX?

I did begin by following the repository instructions (using sudo) but hit a weird snag on the first line, and this is probably my lack of understanding of something, but I get this...

mobeus@Ghost:~$ sudo echo 'deb http://download.opensuse.org/repositories/home:/stevenpusser:/wl/Debian_8.0/ /' > /etc/apt/sources.list.d/broadcom-sta-dkms.list
bash: /etc/apt/sources.list.d/broadcom-sta-dkms.list: Permission denied
mobeus@Ghost:~$ 

I thought 'sudo' gave me root powers, as in, I run as root? Is this a misapprehension on my part? I didn't think it was possible for things to be denied to root...

The urgency is gone, but I'd just like to understand what I'm doing wrong.

And I just want to say a huge 'thank you' to you both - there's no way I could have come even close to solving this on my own, and it's deeply comforting to find such a great community here!

I shall now go and play with my new shiny OS smile

Thanks,

Dean.

Offline

#8 2016-11-13 21:08:24

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Problem installing Broadcom wl driver with kernel 4.7.0-0.bpo.1-amd64

mobeus wrote:

I thought 'sudo' gave me root powers, as in, I run as root? Is this a misapprehension on my part? I didn't think it was possible for things to be denied to root...

The elevated permissions conferred by the `sudo` command do not apply on the "other side" of the redirection (the ">" symbol).

Try this instead:

sudo tee /etc/apt/sources.list.d/broadcom-sta-dkms.list <<< "deb http://download.opensuse.org/repositories/home:/stevenpusser:/wl/Debian_8.0/ /"

http://mywiki.wooledge.org/HereDocument

EDIT: The here string construct only works for BASH.

Last edited by Head_on_a_Stick (2016-11-13 21:28:44)


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#9 2016-11-13 21:26:41

mobeus
Member
Registered: 2016-11-13
Posts: 5

Re: Problem installing Broadcom wl driver with kernel 4.7.0-0.bpo.1-amd64

Ahh, I see. Thanks. I'm learning a lot here, even if most of it is learning just how little I know (but I am inspired to go do some background reading on all of this now!)

Just tried the instructions again with your suggestion and they worked perfectly.

Thanks yet again!

Dean.

Offline

Board footer

Powered by FluxBB