You are not logged in.

#1 2015-10-12 23:04:00

protacticus
Member
Registered: 2015-10-12
Posts: 13

Volume control icon in taskbar (Solved)

Please help, I do not have volume control icon in taskbar. What I need to do?

protacticus@renegade:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: 92HD95 Analog [92HD95 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
protacticus@renegade:~$ cat /proc/asound/cards
 0 [HDMI           ]: HDA-Intel - HDA Intel HDMI
                      HDA Intel HDMI at 0xb0610000 irq 48
 1 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xb0614000 irq 45
protacticus@renegade:~$ lspci -knn|grep -iA2 audio
00:03.0 Audio device [0403]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller [8086:0c0c] (rev 06)
	Subsystem: Intel Corporation Device [8086:2010]
	Kernel driver in use: snd_hda_intel
--
00:1b.0 Audio device [0403]: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller [8086:8c20] (rev 05)
	Subsystem: Intel Corporation Device [8086:2010]
	Kernel driver in use: snd_hda_intel

Last edited by protacticus (2015-10-13 00:47:18)

Offline

#2 2015-10-12 23:12:24

hhh
Meep!
Registered: 2015-09-17
Posts: 10,461
Website

Re: Volume control icon in taskbar (Solved)

We have no idea how you installed BunsenLabs. However, first see if Volti is installed. Open a terminal and run...

apt-cache policy volti

If it's installed, run it from your run dialog (Alt+F2 and type in "volti" w/out quotes, then press Enter).

If that works, make sure it's present in your ~/.config/openbox/autostart file.

Offline

#3 2015-10-12 23:21:12

protacticus
Member
Registered: 2015-10-12
Posts: 13

Re: Volume control icon in taskbar (Solved)

I have Volti, but nothing happens when I run it.
part from autostart:

## Volume control for systray
(sleep 2; volti) &

## Volume keys daemon
xfce4-volumed &

Offline

#4 2015-10-12 23:28:22

hhh
Meep!
Registered: 2015-09-17
Posts: 10,461
Website

Re: Volume control icon in taskbar (Solved)

Post the result of...

apt-cache policy volti

Offline

#5 2015-10-12 23:29:41

hhh
Meep!
Registered: 2015-09-17
Posts: 10,461
Website

Re: Volume control icon in taskbar (Solved)

If that shows volti as being installed, please run volti in a terminal and post any output.

Offline

#6 2015-10-12 23:30:07

protacticus
Member
Registered: 2015-10-12
Posts: 13

Re: Volume control icon in taskbar (Solved)

volti:
  Installed: 0.2.3-5
  Candidate: 0.2.3-5
  Version table:
 *** 0.2.3-5 0
        500 http://ftp.hr.debian.org/debian/ jessie/main amd64 Packages
        100 /var/lib/dpkg/status

Offline

#7 2015-10-12 23:31:39

protacticus
Member
Registered: 2015-10-12
Posts: 13

Re: Volume control icon in taskbar (Solved)

volti
[alsactrl.py:__init__:41] can't open Master control for card HDMI, trying to select first available mixer channel

[alsactrl.py:__init__:49] can't open first available control for card HDMI
error: list index out of range
Traceback (most recent call last):
  File "/usr/bin/volti", line 53, in <module>
    volti = main.VolumeTray()
  File "/usr/lib/volti/volti/main.py", line 124, in __init__
    self.watchid = gobject.io_add_watch(fd, eventmask, self.update)
TypeError: an integer is required

Offline

#8 2015-10-12 23:41:33

damo
....moderator....
Registered: 2015-08-20
Posts: 6,252

Re: Volume control icon in taskbar (Solved)

Try the Arch wiki: Troubleshooting#HDMI


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

#9 2015-10-12 23:41:49

hhh
Meep!
Registered: 2015-09-17
Posts: 10,461
Website

Re: Volume control icon in taskbar (Solved)

I think this is fixable by switching volti's mixer to pavucontrol, but there are others here who can better help you.

Offline

#10 2015-10-12 23:57:03

protacticus
Member
Registered: 2015-10-12
Posts: 13

Re: Volume control icon in taskbar (Solved)

I can run pavucontrol also and manual set volume...How can I switch from volti to pavucontrol?

Offline

#11 2015-10-13 00:17:01

tknomanzr
BL Die Hard
From: Around the Bend
Registered: 2015-09-29
Posts: 1,029

Re: Volume control icon in taskbar (Solved)

Right click on the volti icon and select preferences. Under mixer, unselect builtin to external mixer. Then enter pavucontrol in the box. This will tell volti to use pavucontrol as its mixer and should solve your missing volti icon issue.
Alternatively, edit, the file in ~/.config/volti/config. On the line with mixer, set it to pavucontrol. Save the file then run volti.

Last edited by tknomanzr (2015-10-13 00:17:12)

Offline

#12 2015-10-13 00:46:47

protacticus
Member
Registered: 2015-10-12
Posts: 13

Re: Volume control icon in taskbar (Solved)

Solved. "If Volti doesn't run, i.e. no volume icon, drop to terminal and type volti and check for errors.  If you see the following error:
[alsactrl.py:__init__:41] can't open Master control for card HDMI, trying to select first available mixer channel
Open the Volti configuration file (/home/<user>/.config/volti) and under the [global] section, change the value for card-index from 0 to 1.  Start Volti (using gmrun or Run from the openbox menu) or reboot the computer.
If you prefer to see a value on the volume scale, open the Volti configuration file and under the [global] section, change the value for show-scale-value from 0 to 1.  If Volti is currently running, right-click its icon and select Quit.  Restart Volti (using gmrun or Run from the openbox menu) or reboot the computer."
Credits to KrunchTime from Chrunchbang forum

Offline

#13 2015-10-13 00:56:10

damo
....moderator....
Registered: 2015-08-20
Posts: 6,252

Re: Volume control icon in taskbar (Solved)

Glad to see you have it fixed smile

PS For quotes and terminal output don't forget you can use [ quote ] and [ code ] tags - it makes it much easier to read wink


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

#14 2017-01-19 22:09:13

net5
Member
Registered: 2017-01-18
Posts: 11

Re: Volume control icon in taskbar (Solved)

I have the same problem and there is no ~'volti' folder in my config.

Offline

#15 2017-01-19 22:12:57

damo
....moderator....
Registered: 2015-08-20
Posts: 6,252

Re: Volume control icon in taskbar (Solved)

net5 wrote:

I have the same problem and there is no ~'volti' folder in my config.

If you have a problem, then please start a new thread with a complete description of the issue, and anything you have tried. This thread is already marked as SOLVED.


Be Excellent to Each Other...
The Bunsenlabs Lithium Desktop » Here
FORUM RULES and posting guidelines «» Help page for forum post formatting
Artwork on DeviantArt  «» BunsenLabs on DeviantArt

Online

Board footer

Powered by FluxBB