You are not logged in.

#1 2016-04-29 19:47:53

pepemopap
Member
Registered: 2015-09-30
Posts: 36

[SOLVED] Disable lightdm and use alternative text mode locker

Hi! I would like to disable lightdm and use manual startx for run X window. There are not problem on this.
The problem is in the locker. I want use physlock as a locker.
I have modified the script bl-lock to call physlock and works fine. But when I suspend the system and the system is resumed the locker doesnt works.
Maybe the problem is relationated with the file /etc/systemd/system/display-manager.service but I dont know how to create a new adapted file por physlock

Any suggestion is welcome!
Thanks

Last edited by pepemopap (2016-04-29 23:52:06)

Offline

#2 2016-04-29 19:59:27

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] Disable lightdm and use alternative text mode locker

Welcome to BunsenLabs!
smile

pepemopap wrote:

I have modified the script bl-lock to call physlock and works fine. But when I suspend the system and the system is resumed the locker doesnt works

What modifications have you made?

What exactly do you mean by "doesn't work"?

Also, how did you disable LightDM?


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#3 2016-04-29 20:51:38

pepemopap
Member
Registered: 2015-09-30
Posts: 36

Re: [SOLVED] Disable lightdm and use alternative text mode locker

Head_on_a_Stick wrote:

Welcome to BunsenLabs!
smile

pepemopap wrote:

I have modified the script bl-lock to call physlock and works fine. But when I suspend the system and the system is resumed the locker doesnt works

What modifications have you made?

What exactly do you mean by "doesn't work"?

Also, how did you disable LightDM?

Hi! Thanks for your welcome. This is my first intervention, but I follow the forum for a long time.

I have uninstlled lightdm and light-locker.

First i modified bl-block only replacling light-locker-command for physlock. But now i have restart the content of this script and i have created a script in /usr/bin/light-locker-command  that only call physlock. I prefer not modify system files to prevent errors in future package update.
bl-lock command works fine with this.

When i suspend the system it restart directly without lock screen. No errors or messages are showed.
I would need configure the system for calling physlock after resume.

Thanks a lot.

Offline

#4 2016-04-29 21:59:34

Horizon_Brave
Operating System: Linux-Nettrix
Registered: 2015-10-18
Posts: 1,473

Re: [SOLVED] Disable lightdm and use alternative text mode locker

Would this be because you uninstalled lightdm? Perhaps physlock needs a DM for it to be called?


"I have not failed, I have found 10,000 ways that will not work" -Edison

Offline

#5 2016-04-29 22:30:37

pepemopap
Member
Registered: 2015-09-30
Posts: 36

Re: [SOLVED] Disable lightdm and use alternative text mode locker

Horizon_Brave wrote:

Would this be because you uninstalled lightdm? Perhaps physlock needs a DM for it to be called?

Really physlock works fine only calling the command physlock. I need config the system for calling it at resuming. I beleave physlock dont do it by itself, is very simple software.

Offline

#6 2016-04-29 23:20:26

Horizon_Brave
Operating System: Linux-Nettrix
Registered: 2015-10-18
Posts: 1,473

Re: [SOLVED] Disable lightdm and use alternative text mode locker

pepemopap wrote:
Horizon_Brave wrote:

Would this be because you uninstalled lightdm? Perhaps physlock needs a DM for it to be called?

Really physlock works fine only calling the command physlock. I need config the system for calling it at resuming. I beleave physlock dont do it by itself, is very simple software.

with light-locker,  it gives you different switches to allow you to set how long and what happens when you resume...are you sure this physlock application doesn't have such a features?   Also...I can't actually find any documentation about this. Are you spelling the name correctly?


"I have not failed, I have found 10,000 ways that will not work" -Edison

Offline

#7 2016-04-29 23:38:29

pepemopap
Member
Registered: 2015-09-30
Posts: 36

Re: [SOLVED] Disable lightdm and use alternative text mode locker

I have tried this solution and seems to work: https://wiki.debian.org/ScreenLockingOnSleep

Yes, physlock is the name. The github page is https://github.com/muennich/physlock
But if someone knows a better solution for lock in text mode i would like to know. The vlock command is popular, but the package in debian doesnt have the plugin for -n option, needed for lock in X mode.

Offline

#8 2016-04-29 23:45:34

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] Disable lightdm and use alternative text mode locker

pepemopap wrote:

if someone knows a better solution for lock in text mode i would like to know

I don't know about better, but:

ArchWiki wrote:

Only sflock, physlock, Cinnamon Screensaver, MATE Screensaver and GNOME Screensaver are able to block tty access.

https://github.com/benruijl/sflock

Please add [SOLVED] to the thread title to help others with this problem wink


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

Board footer

Powered by FluxBB