You are not logged in.

#1 2016-04-23 16:22:57

rabauki
Member
Registered: 2016-04-23
Posts: 11

[SOLVED] No Sound on HP-350 Notebook (Broadwell)

Hi,

i got a new HP Notebook with Intel-Hardware on Board.

When i start Bunsenlabs everything is OK, but i have got no Sound.
No Icon in Tint2 - and no Program played any Sound.

---

Some commands an their outputs :

alsactl init

Found hardware: "HDA-Intel" "Intel Broadwell HDMI" "HDA:80862808,80860101,00100000" "0x103c" "0x803b"
Hardware is initialized using a generic method

lspci | grep Audio

00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)

aplay -l

**** Liste der Hardware-Geräte (PLAYBACK) ****
Karte 0: HDMI [HDA Intel HDMI], Gerät 3: HDMI 0 [HDMI 0]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA Intel HDMI], Gerät 7: HDMI 1 [HDMI 1]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA Intel HDMI], Gerät 8: HDMI 2 [HDMI 2]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 1: Coffee [Calyx Coffee], Gerät 0: USB Audio [USB Audio]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 1: Coffee [Calyx Coffee], Gerät 1: USB Audio [USB Audio #1]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 2: PCH [HDA Intel PCH], Gerät 0: ALC3227 Analog [ALC3227 Analog]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0

My ~/.config/volti/ config :

[card-0]
control = Master
mask_lock = 0
mask_control = 33554431

[global]
mixer_show_values = 1
scale_increment = 1.0
card_index = 0
icon_theme = Faenza
scale_show_value = 0
mixer = pavucontrol
show_tooltip = 1
notify_position = 0
keys = 0
toggle = mute
mixer_internal = 0
notify_body = <span font_desc="14" weight="bold">{volume}</span>
	<small>{card}</small>
	<small>{mixer}</small>
keys_backend = xlib
run_in_terminal = 0
notify_timeout = 2.0
show_notify = 0

[card-1]
mask_lock = 0

[card-2]
mask_lock = 0
mask_control = 2047

---

I don't understand why i got no Sound ;)

If i start volti in a Terminal - several Errors occur.

The first one :

[alsactrl.py:__init__:41] can't open Master control for card HDMI, trying to select first available mixer channel

and some more...

Anyone any suggestions ?

== Please use Code blocks ==

[code]
code in code blocks
[/code]

Sorry I can not help.  :(

Last edited by Sector11 (2016-04-23 16:31:51)

Offline

#2 2016-04-23 16:34:40

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] No Sound on HP-350 Notebook (Broadwell)

Welcome to the forums!
smile

rabauki wrote:

My ~/.config/volti/ config :

[global]
[...]
card_index = 0

Try changing this line to:

card_index = 2
rabauki wrote:

several Errors occur.

The first one :

Please always post *complete* error messages.

I note that you have Broadwell hardware -- this has relatively poor support with the stock kernel & video drivers.

You could try this guide:
https://forums.bunsenlabs.org/viewtopic.php?id=1185

EDIT: use this command to make sure that your Master channel is un-muted with the correct volume set:

alsamixer

If there are still problems, post the output of:

speaker-test -l1 -c2

Last edited by Head_on_a_Stick (2016-04-23 16:38:29)


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#3 2016-04-23 17:17:45

jalexander9
Member
Registered: 2015-11-08
Posts: 152

Re: [SOLVED] No Sound on HP-350 Notebook (Broadwell)

Here is another guide from the crunchbang forums, "[solved] No Sound..." on an HP system.

crunchbang

This is an older post, but since it solved the no sound problem it may have useful hints for you to use.

Offline

#4 2016-04-24 08:48:15

rabauki
Member
Registered: 2016-04-23
Posts: 11

Re: [SOLVED] No Sound on HP-350 Notebook (Broadwell)

Hi again,

thanks for your replies,

alsamixer shows me 3 Soundcards :

HDA-Intel-HDMI-Audio
Calyx Coffee (my USB Soundcard)
HDA-Intel-PCH

Actual i am only interested in my USB-Card and the PCH-Audio on Board.
If i select with [F6] the Calyx-Soundcard - there is only one Bar - i put it on 59.
But no Sound out of this Card.
If i choose ther PCH-Card - there are :
Master Headphone Speaker PCM Mic Mic Boost Beep - Bars
Master is on 59 - to say it short : everything is unmuted wink

But no Sound on every Soundcard

If i start Audacious it says :
ALSA error : No suitable mixer element found
ALSA error: snd_mixer_find_selem failed.
ALSA error: snd_pcm_open failed: Datei oder Verzeichnis nicht gefunden.


Bad support for Intel Broadwell or not - i've got no Sound even on the USB-Card.

Next try :

speaker-test -l1 -c2

speaker-test 1.0.28

Wiedergabe-Gerät ist default
Stream-Parameter sind 48000 Hz, S16_LE, 2 Kanäle
Verwende 16 Oktaven rosa Rauschen
ALSA lib pcm_dmix.c:1022:(snd_pcm_dmix_open) unable to open slave
Fehler beim Öffnen des Gerätes: -2, Datei oder Verzeichnis nicht gefunden

Dont know what it means - but it doesent work ;(

Last edited by Head_on_a_Stick (2016-04-24 10:08:21)

Offline

#5 2016-04-24 10:06:39

rabauki
Member
Registered: 2016-04-23
Posts: 11

Re: [SOLVED] No Sound on HP-350 Notebook (Broadwell)

Solved wink

apt-get install --target-release jessie-backports firmware-misc-nonfree

I did a new start of the System - and what do i see ???

A Speaker-Icon in the Tint2-Bar wink

Now my Webradio can play - and i can work with music.

Next issue is to change the Output-Cards "on the Fly"
The PCH-Card played on internal Speakers - the external USB-Card is plugged in to my Soundsystem.

Last edited by rabauki (2016-04-24 10:07:43)

Offline

#6 2016-04-24 10:07:59

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: [SOLVED] No Sound on HP-350 Notebook (Broadwell)

Excellent!

Thanks for posting your solution, I'm sure many will find it useful smile


“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#7 2016-04-24 10:38:29

rabauki
Member
Registered: 2016-04-23
Posts: 11

Re: [SOLVED] No Sound on HP-350 Notebook (Broadwell)

Thank you all for helping !

Nice when things work smile

Offline

Board footer

Powered by FluxBB