You are not logged in.

#1 2016-04-10 12:34:45

Peregrino69
Member
Registered: 2016-03-11
Posts: 37

Remote desktop with Chrome Desktop

Has anyone tried this successfully?

Offline

#2 2016-04-11 14:06:00

Peregrino69
Member
Registered: 2016-03-11
Posts: 37

Re: Remote desktop with Chrome Desktop

Nobody?

Does someone know a similar, TeamViewer-type remote access solution that works?

Offline

#3 2016-04-11 14:31:45

schwim
Member
From: Western NC, US
Registered: 2015-09-29
Posts: 228
Website

Re: Remote desktop with Chrome Desktop

I use it to connect to my main work computer when I'm not around. I can't use my VPN system as I'm behind a NAT firewall and Chrome Remote does.  It works just fine for what I need.


Schw.im! A social site with an identity crisis.

Offline

#4 2016-04-11 15:01:44

twoion
ほやほや
Registered: 2015-08-10
Posts: 2,482

Re: Remote desktop with Chrome Desktop

Peregrino69 wrote:

Nobody?

Does someone know a similar, TeamViewer-type remote access solution that works?

You could try using VNC or SPICE. I know that x11vnc works quite well  as a VNC server (am using it at work to access a headless toy server) but getting the X11 authorization (.Xauthority and such) right requires some fiddling.

Otherwise, I am using remote shells, not desktops.


A silent kite against the blue, blue sky

Offline

#5 2016-04-11 16:22:45

Peregrino69
Member
Registered: 2016-03-11
Posts: 37

Re: Remote desktop with Chrome Desktop

scwhim wrote:

I use it to connect to my main work computer

So are you using it to connect from a Windows system to a BunsenLabs system? That's the part I can't get working... it's a simple three-step process...

1. Create a file called .chrome-remote-desktop-session in your home directory.  (Not explained very well but basically do the below and then add the resulting line to the new  ‘.chrome-remote-desktop-session’ file, I need a reboot before this actually worked)
2. Look in /usr/share/xsessions/ to start the desktop. For example, the ubuntu-2d.desktop file has the line: Exec=gnome-session --session=ubuntu-2d. 
3. Use the text after ‘Exec=’ as the command to start the session. In this case, the correct command would be: exec /usr/sbin/lightdm-session "gnome-session --session=ubuntu-2d"

... and I'm too dumb to figure out what the "Exec=" line should be tongue

twoion wrote:

You could try using VNC or SPICE

VNC doesn't cut it. You need to be able to reach the server directly, which isn't possible in this case. Lab's entirely isolated from production environment, so I need go from office through firewall to lab firewall and lab systems - and I don't manage any of the firewalls. From the looks of it SPICE works the same way, so not an option either.

I've got a reverse SSH tunnel running from the lab system to a RasPI at home and have been SSHing in through that. As long as I'm on CLI, there's no issue, but running Wireshark over that connection just doesn't work. It's way too slow. TV does the job but as it needs to be licensed...

AnyDesk works otherwise fine, but has a slight problem with keyboard mapping in Win => Lin direction. It's a known issue. Remote Win keyboard gets mapped to something vaguely German-ish layout, and can't be fixed on the remote system without excessive surgery which I'm not really willing to dive into.

Offline

#6 2016-04-11 18:10:08

Head_on_a_Stick
Member
From: London
Registered: 2015-09-29
Posts: 8,759
Website

Re: Remote desktop with Chrome Desktop

Peregrino69 wrote:

it's a simple three-step process...

1. Create a file called .chrome-remote-desktop-session in your home directory.  (Not explained very well but basically do the below and then add the resulting line to the new  ‘.chrome-remote-desktop-session’ file, I need a reboot before this actually worked)
2. Look in /usr/share/xsessions/ to start the desktop. For example, the ubuntu-2d.desktop file has the line: Exec=gnome-session --session=ubuntu-2d. 
3. Use the text after ‘Exec=’ as the command to start the session. In this case, the correct command would be: exec /usr/sbin/lightdm-session "gnome-session --session=ubuntu-2d"

... and I'm too dumb to figure out what the "Exec=" line should be

Try:

exec /usr/sbin/lightdm "/usr/bin/openbox-session"

“Et ignotas animum dimittit in artes.” — Ovid, Metamorphoses, VIII., 18.

Forum Rules   •   How to report a problem   •   Software that rocks

Offline

#7 2016-04-11 18:31:27

pingu
Member
Registered: 2015-09-29
Posts: 128

Re: Remote desktop with Chrome Desktop

Peregrino69 wrote:

VNC doesn't cut it. You need to be able to reach the server directly, which isn't possible in this case.
[...]
I've got a reverse SSH tunnel running from the lab system to a RasPI at home and have been SSHing in through that.

That means you can use vnc. You just have to tunnel through your ssh connection.
You can  start the vncserver with:

vncserver -localhost=1 -rfbport 666  (start a server listening on localhost:666)

Than you just need the ssh tunnel linking that port on the server to whatever port you want at home and connect to that port on your home's localhost.
e.g:

ssh -L 666:localhost:999 -N -f user@home.url -p 22 (ssh server port)

and connect with

vncviewer localhost:999

at home (reaching the server "dicretly" from the vnc poing-of-view).

Last edited by pingu (2016-04-11 18:33:15)


"Chuck Norris can compile syntax errors."

Offline

Board footer

Powered by FluxBB