You are not logged in.

#1 2015-12-29 08:00:28

bedware
New Member
Registered: 2015-12-29
Posts: 3

Language icon in the tray [SOLVED]

I have two languages in the system. The general is an English. Env locale - en_US.UTF-8. I change language by pressing Alt+Shift. But I don't see what the current language is? BTW, I see little empty space in the tray. Is there space for language icon or just a bug?
87256d8d61837636817defaa1cf6b75445bbd7ca17de1b286924c0fb25bf0a9dfbccfd7c40a460c7b0c12ac8be3d6e311f2106500a8a71be.php

Last edited by bedware (2016-01-11 13:34:44)

Offline

#2 2015-12-29 09:34:40

brontosaurusrex
Middle Office
Registered: 2015-09-29
Posts: 2,374
Website

Re: Language icon in the tray [SOLVED]

So you are actually changing the system language or just keyboard layout?

Last edited by brontosaurusrex (2015-12-29 09:35:40)

Offline

#3 2015-12-29 12:55:06

ohnonot
...again
Registered: 2015-09-29
Posts: 5,554

Re: Language icon in the tray [SOLVED]

bedware, welcome to the forums!

i cannot see whatever image you posted.
it just says "URL périmée".

can't you just explain what the problem is?
it's most likely not a bug.


Give to COVAX! Here or here. (explanation)

Offline

#4 2015-12-31 12:59:19

orcrist
Member
From: Dachau, Bayern
Registered: 2015-12-31
Posts: 6

Re: Language icon in the tray [SOLVED]

The empty space in the tray is the battery applet (fdpowermon) which does not show after the first system upgrade with bl-welcome script. The solution to this is running bl-welcome from terminal again, adding the backports repo, installing xfce4-power-manager and removing fdpowermon (just follow the bl-welcome proposals). There's a thread already.
Now for your primary question, you could add fbxkb in /home/"your user name"/.config/openbox/autostart file. If it shows ?? instead of the American flag, go to /usr/share/fbxkb/images/ folder, save zz.png as zz.png.old (or simply delete it) and then save us.png as zz.png.
You should then restart your system on both cases.

I hope I've been of some help.

Offline

#5 2016-01-08 22:10:06

joksim
New Member
Registered: 2016-01-08
Posts: 1

Re: Language icon in the tray [SOLVED]

Hi,

I would recommend using xxkb instead of fbxkb.
Instead of global keyboard switching, xxkb can manage per window switching (for me its preferable).

The man pages can be found here, and my configuration can be found here.

I have an entry in

~/.config/openbox/autostart

that goes like this:

 (sleep 7; xxkb) & 

Best regards

Offline

#6 2016-01-09 21:25:36

nobody0
Disabled account
Registered: 2015-09-29
Posts: 664

Re: Language icon in the tray [SOLVED]

bedware wrote:

I have two languages in the system. The general is an English. Env locale - en_US.UTF-8. I change language by pressing Alt+Shift. But I don't see what the current language is?

Check here, https://forums.bunsenlabs.org/viewtopic … 2724#p2724
or here, https://forums.bunsenlabs.org/viewtopic … 776#p14776

Offline

#7 2016-01-11 13:34:23

bedware
New Member
Registered: 2015-12-29
Posts: 3

Re: Language icon in the tray [SOLVED]

I apologize for this huge delay in my reply. I used solution from orcrist. Now all is perfect! Thank you orcrist, brontosaurusrex, ohnonot, joksim, ostrolek for your help!

Offline

Board footer

Powered by FluxBB