You are not logged in.

#1 2022-02-25 15:05:42

Colonel Panic
Member
Registered: 2018-11-13
Posts: 549

Enabling sound in Slackware

Another Slackware one. I've noticed that in recent Slacks and distros derived from it, sound doesn't work out of the box and has to be enabled.

I'm not sure why, but it seems that there's a clash between pulseaudio and alsa-utils that is responsible.

One solution (there may be others) is to first remove pulseaudio, so enable root in a terminal;

su root <password>

then, at the console,

removepkg pulseaudio

That still doesn't do it, because alsamixer will redirect to pulseaudio by default when it loads; so we have to move its configuration file;

mv /etc/asound.conf /home

Then restart (or better, reboot) and alsamixer should work unimpeded.

Last edited by Colonel Panic (2022-02-25 15:06:59)

Offline

Board footer

Powered by FluxBB