You are not logged in.

#1 2022-02-05 14:44:01

Musbang
Member
Registered: 2019-05-16
Posts: 7

[SOLVED] application run problem [hasciicam&enpass]

Hello Bunsen people,


I have 2 issues that are similar and may have the same source.


System:
Dell inspiron 1300 (32bit), 2g Ram, 1.6ghz
Kernel: 5.10.0-0.bpo.9-686-pea | debian 5.10.70-1bpo10+1
Openbox : 3.6.1
Enpass : 5.6.9   - apt install
Hasciicam : 1.1.2


1e = hasciicam (ascii webcam).

Hasccicam can be started only in the following way.

I must first start hasciicam, as root. Both terminal and Alt+F2 possible.
Then I close the window.
After this I can start Hasciicam as user. This only works from the terminal or Alt+F2, not from the menu.
And one time. After close this window, i have to do the sequence over again.

2e = Enpass (password manager)

Enpass has a similar behavior. I can only start Enpass from the terminal.

Not with menu or Alt+F2.
I cannot automate Enpass startup from the terminal (autostart), this does not work either.
Enpass kills itself after fill in password. Tray-icone appears/disappears.

This is how I use it now, after boot.

$ /opt/Enpass/bin/runenpass.sh &!

_Error_

At first I got error messages for Enpass. 'gail' and 'atk'.
I installed all possible atk and gail packages.
The error messages disappeared, but the behavior is still the same, that I only can start enpass manually, from the terminal.

I have tried different kernels. And looked at the user rights to start Enpass or Hasciicam.


If more info is needed, let me know.

I hope someone can give a direction to look at.

cheers.

Last edited by Musbang (2022-02-14 11:27:37)

Offline

#2 2022-02-06 08:51:53

brontosaurusrex
Middle Office
Registered: 2015-09-29
Posts: 2,464
Website

Re: [SOLVED] application run problem [hasciicam&enpass]

1e - Needing sudo might be avoided by adding your user to 'video' group.
Example:

usermod -a -G video username

hasciicam page states that this is a terminal utility, so for starting from the menu you would need to start it with the terminal of choice included, like

urxvt -e command
# check man and search for examples in this forum

2e - Looks like commercial utility, so ask them?

Last edited by brontosaurusrex (2022-02-06 08:53:50)

Online

#3 2022-02-06 10:12:08

Sun For Miles
Member
Registered: 2017-04-12
Posts: 219

Re: [SOLVED] application run problem [hasciicam&enpass]

2e - I have followed installation instructions from the Enpass website. I see /opt/enpass folder that I have added to PATH and I see it in Bunsen Applications/Accessories menu:

Q2K4bGFt.png

Executable is called "Enpass".

It starts fine from the menu (without terminal). Didn't test the startup sequence, but I don't see a reason why it wouldn't work.


Señor Chang, why do you teach Spanish?

Offline

#4 2022-02-06 12:54:14

Musbang
Member
Registered: 2019-05-16
Posts: 7

Re: [SOLVED] application run problem [hasciicam&enpass]

@brontosaurusrex : hasciicam (32bit)

My experience with hasciicam is that I can run it both from the menu and from the terminal.
There are sometimes difficulties with xfonts, but generally I get it running from the menu.
Without any extra startup command for rxvt. I checked this option too.

Running hasciicam as user, from the terminal, gives this output.

Screenshot-2022-02-06-11-53-25.png


And this when i run it as user, after closing the root run.
Screenshot-2022-02-06-11-55-31.png


Actually, I can only run Hasciicam as USER via Alt+F2. With the oddity to run as root first.

I added the user to VIDEO, with no result.

---

@Sun For Miles : The way to install Enpass on 32bit/64bit  is indeed from their repo.
32bit portable version only for win/mac.
scot enpass path

I cannot run /opt/Enpass/bin/Enpass. I have to use the runenpass.sh script to launch Enpass from the terminal.

Running Enpass exec

./Enpass: error while loading shared libraries: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory

list of installed libs :::

libcrypto++-dev/oldstable 5.6.4-8 i386
  General purpose cryptographic library - C++ development

libcrypto++-doc/oldstable 5.6.4-8 all
  General purpose cryptographic library - documentation

libcrypto++-utils/oldstable 5.6.4-8 i386
  General purpose cryptographic library - utilities and data files

libcrypto++6/oldstable 5.6.4-8 i386
  General purpose cryptographic library - shared library

libcrypto++6-dbg/oldstable 5.6.4-8 i386
  General purpose cryptographic library - debug symbols

libcrypto-equality-clojure/oldstable 1.0.0-1 all
  Clojure library protecting against timing attacks

libcrypto-random-clojure/oldstable 1.2.0-1 all
  secure random generator for Clojure

libcryptokit-ocaml/oldstable 1.11-1+b2 i386
  cryptographic algorithm library for OCaml - runtime

libcryptokit-ocaml-dev/oldstable 1.11-1+b2 i386
  cryptographic algorithm library for OCaml - development

libssl-dev/oldstable,oldstable,now 1.1.1d-0+deb10u7 i386 [installed]
  Secure Sockets Layer toolkit - development files

libssl-doc/oldstable,oldstable 1.1.1d-0+deb10u7 all
  Secure Sockets Layer toolkit - development documentation

libssl1.1/oldstable,oldstable,now 1.1.1d-0+deb10u7 i386 [installed]
  Secure Sockets Layer toolkit - shared libraries

r-cran-openssl/oldstable 1.2.2+dfsg-1 i386
  GNU R toolkit for encryption, signatures and certificates based o

Installed libcrypto++-utils, no effect (after reboot).
I have no idea if this list include the missing lib.


I asked Enpass.devs too. No response yet.

Thanks for the thoughts.

Offline

#5 2022-02-06 14:41:55

Musbang
Member
Registered: 2019-05-16
Posts: 7

Re: [SOLVED] application run problem [hasciicam&enpass]

Adding a gif example :: Opening Enpass on different way's.
The last one works. alias enpass.

My system has to work, to record at the same time, a bit sloww. Looping . . . Starts with Alt+F2 options.

startup_enpass.gif

ps:: i cannot automate my alias ... that does not work. I have to do it manualy.

edit:gif period = one month. After that it will be deleted.

Last edited by Musbang (2022-02-06 15:12:28)

Offline

#6 2022-02-14 11:26:46

Musbang
Member
Registered: 2019-05-16
Posts: 7

Re: [SOLVED] application run problem [hasciicam&enpass]

[SOLVED] Enpass. 

I found a libssl error. After some research i found the next solution.
Enpass now startup from boot and menu, without issues.

I did the following ::

nano ~/.xsessionrc

adding ::

export OPENSSL_CONF=/etc/ssl/

Hasciicam has issues, but can work with it. [solved]

Offline

Board footer

Powered by FluxBB