You are not logged in.

#1 2021-12-26 21:55:18

Pugn
New Member
Registered: 2021-12-26
Posts: 3

get a package is not avalibe error when installing anything

the output of my sources.list is this>


#

# deb cdrom:[Debian GNU/Linux 10 _Lithium_ - Snapshot amd64 LIVE/INSTALL Binary 20210824-15:06]/ buster contrib main non-free

#deb cdrom:[Debian GNU/Linux 10 _Lithium_ - Snapshot amd64 LIVE/INSTALL Binary 20210824-15:06]/ buster contrib main non-free

deb https://deb.debian.org/debian buster main non-free contrib
# deb-src https://deb.debian.org/debian buster main non-free contrib

## Debian security updates
deb https://deb.debian.org/debian-security buster/updates main contrib non-free

# buster-updates, previously known as 'volatile'
deb https://deb.debian.org/debian buster-updates main contrib non-free
# deb-src https://deb.debian.org/debian buster-updates main contrib non-free

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual




please help, its done the same thing for plain debian to.

Offline

#2 2021-12-26 23:49:09

sleekmason
zoom
Registered: 2018-05-22
Posts: 691
Website

Re: get a package is not avalibe error when installing anything

Did you remember to:

sudo apt update

Before attempting to install?
If you get something unusual with that, please post the output here.

Offline

#3 2021-12-27 00:10:34

Pugn
New Member
Registered: 2021-12-26
Posts: 3

Re: get a package is not avalibe error when installing anything

ok, ive done that but i still get it. this is weird as it should have helped.

Offline

#4 2021-12-27 00:22:38

sleekmason
zoom
Registered: 2018-05-22
Posts: 691
Website

Re: get a package is not avalibe error when installing anything

Okay, a bit more info please.

What package are you trying to install?
What were the results of 'sudo apt update'? Please post the output.
What is the exact line you are using to install the package?
Are you connected to the internet?

We need to start somewhere and I'm trying to keep it simple, but we need real info in order to help you.  Guessing it is something quite simple.

Offline

#5 2021-12-27 01:37:59

hhh
Ol' Pink Eyes
Registered: 2015-09-17
Posts: 12,759
Website

Re: get a package is not avalibe error when installing anything

^ This. You need to try and do some troubleshooting on your own, or at least give us the best info possible. At least name the package, what the...


Does your physical disability preclude you from coming to the point?

Offline

#6 2021-12-27 01:38:27

Pugn
New Member
Registered: 2021-12-26
Posts: 3

Re: get a package is not avalibe error when installing anything

what im trying to install(this as well as the nvidia drivers):
sudo apt-get install leafpad

what apt update gives me:
sudo apt-get update
Hit:1 https://deb.debian.org/debian buster InRelease
Get:2 https://deb.debian.org/debian-security buster/updates InRelease [65.4 kB]
Hit:3 https://deb.debian.org/debian buster-updates InRelease
Hit:4 http://eu.pkg.bunsenlabs.org/debian lithium InRelease
Fetched 65.4 kB in 1s (65.7 kB/s)
Reading package lists... Done

i have a ethernet cable to the router and im able to access the internet.

Offline

#7 2021-12-27 01:42:16

hhh
Ol' Pink Eyes
Registered: 2015-09-17
Posts: 12,759
Website

Re: get a package is not avalibe error when installing anything

sudo apt install leafpad
❯ sudo apt install leafpad
[sudo] password for rachel: 
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package leafpad is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'leafpad' has no installation candidate

~ took 6s 
❯ 

Leafpad is no longer maintained. Try mousepad instead. It's based on leafpad, and it's what I use...

sudo apt install mousepad

https://packages.debian.org/bullseye/mousepad


Does your physical disability preclude you from coming to the point?

Offline

Board footer

Powered by FluxBB