You are not logged in.

#1 2021-12-20 14:29:07

rocky33
Member
Registered: 2021-06-23
Posts: 24

[Solved] Boot Error - Minimal bash like line editing is supported

Guys,

I have installed BL on an Acer Aspire 3 laptop. From the very first time I tried to boot, it was failing to get to the boot menu. Instead, shows up "Minimal bash like line editing supported ... " page.

When I press F12, while the machine is starting up, then I get boot options, I am able to select BL from there and boot. The list also shows Ubuntu which I have overwritten.

As I understand, it is a EFI system. I tried updating and reinstalling Grub, both on the system and from live usb, following different tutorials, but I am still getting the same error.

efibootmgr -v
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0002,0001,0000,2001,2002,2003
Boot0000* bunsenlabs	HD(1,GPT,ce83c5ca-6591-4994-944f-53246e308f76,0x800,0x100000)/File(\EFI\bunsenlabs\grubx64.efi)
Boot0001* debian	HD(1,GPT,ce83c5ca-6591-4994-944f-53246e308f76,0x800,0x100000)/File(\EFI\debian\shimx64.efi)
Boot0002* ubuntu	HD(1,GPT,ce83c5ca-6591-4994-944f-53246e308f76,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot2001* EFI USB Device	RC
Boot2002* EFI DVD/CDROM	RC
Boot2003* EFI Network	RC

Any help will be appreciated, thanks in advance...

Last edited by rocky33 (2021-12-20 17:26:18)

Offline

#2 2021-12-20 14:54:06

twoion
一期一会
Registered: 2015-08-10
Posts: 3,436

Re: [Solved] Boot Error - Minimal bash like line editing is supported

Am I reading this right that your problem is: You have BunsenLabs installed, want to boot it by default, but when you just turn on the machine it doesn't boot straight into BunsenLabs but arrives at a GRUB prompt with the "Minimal bash like ..." message? And you have removed Ubuntu from the system.

Then, it seems that you need:

Remove the ubuntu EFI entry (here: Boot0002) because when the system boots into this default EFI entry, the GRUB ubuntu has set up does no longer work (sends you to the grub> prompt you've already noticed).

Adjust BootOrder (here: 0002,0001,0000,2001,2002,2003) to 0000,0001,2001,2002,2003 so that the system automatically boots into BunsenLab's GRUB by default.

Maybe your computer's UEFI firmware offers you to adjust EFI start up options. If it doesn't, you can use efibootmgr to achieve the goal:

sudo efibootmgr --delete-bootnum --bootnum 0002

should get rid of entry Boot0002. Then,

sudo efibootmgr --bootorder 0000,0001,2001,2002,2003

should fix the boot order and make BL the default. Confirm results using efibootmgr, then reboot to test. Please review the commands if they make sense and in case I have mistyped something. See also https://man.archlinux.org/man/efibootmgr.8 .

Also please confirm the entry numbering before changing the boot order in case the numbering changes after deleting the old ubuntu entry!

Last edited by twoion (2021-12-20 14:59:19)

Offline

#3 2021-12-20 17:25:41

rocky33
Member
Registered: 2021-06-23
Posts: 24

Re: [Solved] Boot Error - Minimal bash like line editing is supported

I think the removing the Grub from Ubuntu did the trick, now it seems to be working, thanks a lot.

Offline

Board footer

Powered by FluxBB