You are not logged in.

#1 2021-11-06 01:40:03

Registered: 2021-10-14
Posts: 7

x2go doesn't connect to desktop environment

Hi there, I'm experimenting with making a BunsenLabs image I can deploy as a remote workstation in various cloud environments. Accordingly, my first task is to figure out a solid remote access solution, and VNC doesn't cut it. I heard good things about X2go so I figured I'd give it a shot.

Long story short, I got the server installed, and the client installed elsewhere, and I can log in to my BL target system, but it comes up with a completely blank desktop and only bare default menus - not the BunsenLabs environment which appears when I log in via the console.

I'm sure I'm missing something obvious but I'm stumped, and I'm not really familiar with the difference between starting a full X desktop session vs some sort of more limited session? My main familiarity with X is with running single applications remotely via SSH X forwarding.

I'd love to hear anybody's tips. Thanks!


#2 2021-11-06 03:45:49

Registered: 2021-10-14
Posts: 7

Re: x2go doesn't connect to desktop environment

Found the answer with a little more searching.

In X2go Client, in session config > Session Type, one has to choose Custom Desktop and for Command enter 'bunsenlabs-desktop' and then things work as expected.

Original answer quoted below:a

malm wrote:

Original message: … 045#p96045

s-rod wrote:

Also noticed that when the x2go session starts there is no wall paper or tint2. Running nitrogen --restore will bring up the wallpaper with the following errors
I have used x2go to remote multiple BL machines prior to Lithium and did not experienced the wall paper, tint2 issues.

This is because ~/.config/openbox/autostart has changed name. When running x2goclient, choose "bunsenlabs-session" rather than "openbox" or "openbox-session". Or create a new ~/.config/openbox/autostart file. @s-rod solved this, but thought the answer should be included here for reference.


#3 2021-11-06 08:09:03

From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 1,295

Re: x2go doesn't connect to desktop environment

@bayronic, good you had it solved!

Can you edit your first post, prepend [Solved] on the subject lione?

// Regards rbh

Please read before requesting help: Guide to getting help,
Introduction to the Bunsenlabs Lithium Desktop and other help topics under "Help Resources" on the BunsenLabs menu


Board footer

Powered by FluxBB