You are not logged in.

#1 2021-10-13 20:15:30

bic
Member
Registered: 2021-09-09
Posts: 13

Hibernation not working

I'm having an issue with the hibernation feature. The system seems to hibernate just fine, but when I resume from hibernation, at first it starts booting but then it performs a hard restart, and boots normally from there. The second boot doesn't resume the hibernated session - it just boots like normal. I know the first boot doesn't doesn't shut down gracefully since it prints some messages about recovering the filesystem journal when booting the second time.

Any idea why that might be happening?

I am using the fake-hwclock package since the hardware clock on my machine doesn't work for some reason (probably the battery died but I haven't checked). To enter hibernation, I am using `systemctl hibernate`. I haven't tried with other distros since I am not sure how to hibernate from a live USB.

Last edited by bic (2021-10-22 21:02:39)

Offline

#2 2021-10-13 22:19:40

rbh
Moderator
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 1,240

Re: Hibernation not working

Do you have a lot of usb-equipment atached?
Remove all you can and test hibernate.
If ok, add one at a time.

Mine desktop can not suspend/hibernate with the Logitech BCC950 video camera. No problem with the cheaper C930e camera.


// Regards rbh

Please read before requesting help: Guide to getting help,
Introduction to the Bunsenlabs Lithium Desktop and other help topics under "Help Resources" on the BunsenLabs menu

Offline

#3 2021-10-14 20:30:30

bic
Member
Registered: 2021-09-09
Posts: 13

Re: Hibernation not working

No, this was without any USB devices attached.

Offline

#4 2021-10-15 17:43:48

rbh
Moderator
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 1,240

Re: Hibernation not working

bic wrote:

I'm having an issue with the hibernation feature.
[...]
Any idea why that might be happening?

You need to add some info. What hardware do you have? Link to your manufactorys hw-info, hardware probe at https://linux-hardware.org or output from command "inxi -Fxrzm".

I know the first boot doesn't doesn't shut down gracefully since it prints some messages about recovering the filesystem journal when booting the second time.

So, what related info du you have in your logs? (Related to power and files-system errors.)

I am using the fake-hwclock package since the hardware clock on my machine doesn't work for some reason (probably the battery died but I haven't checked).

Don't think that is the cause.

To enter hibernation, I am using `systemctl hibernate`.

Can you suspend?

I haven't tried with other distros since I am not sure how to hibernate from a live USB.

Does it work in BL live session?

Have it worked before and then stoped? Or have you installed now with no os on the disk before or...?


// Regards rbh

Please read before requesting help: Guide to getting help,
Introduction to the Bunsenlabs Lithium Desktop and other help topics under "Help Resources" on the BunsenLabs menu

Offline

#5 2021-10-15 18:35:49

bic
Member
Registered: 2021-09-09
Posts: 13

Re: Hibernation not working

inxi -Fxrzm output:

System:
  Host: debian Kernel: 4.19.0-17-686-pae i686 bits: 32 compiler: gcc 
  v: 8.3.0 Desktop: Openbox 3.6.1 
  Distro: BunsenLabs GNU/Linux 10.5 (Lithium) base: Debian GNU/Linux 10 
Machine:
  Type: Laptop System: LG product: X120-L.C7L1A9 v: N/A serial: <filter> 
  Mobo: LG model: Xenia2 serial: <filter> BIOS: Phoenix v: PUMASF02 
  date: 02/26/2009 
Memory:
  RAM: total: 992.8 MiB used: 216.7 MiB (21.8%) 
  RAM Report: 
  permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Topology: Single Core model: Intel Atom N270 bits: 32 type: MT 
  arch: Bonnell rev: 2 L2 cache: 512 KiB 
  flags: nx pae sse sse2 sse3 ssse3 bogomips: 6383 
  Speed: 1596 MHz min/max: 800/1600 MHz Core speeds (MHz): 1: 1596 2: 1596 
Graphics:
  Device-1: Intel Mobile 945GSE Express Integrated Graphics vendor: LG 
  driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.4 driver: intel 
  unloaded: fbdev,modesetting,vesa resolution: 1024x576~60Hz 
  OpenGL: renderer: Mesa DRI Intel 945GME x86/MMX/SSE2 v: 1.4 Mesa 18.3.6 
  direct render: Yes 
Audio:
  Device-1: Intel NM10/ICH7 Family High Definition Audio vendor: LG 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.19.0-17-686-pae 
Network:
  Device-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet 
  vendor: LG RTL810xE driver: r8169 v: kernel port: 2000 bus ID: 02:00.0 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Realtek RTL8187SE Wireless LAN driver: rtl818x_pci v: kernel 
  port: 3000 bus ID: 03:00.0 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 149.05 GiB used: 5.73 GiB (3.8%) 
  ID-1: /dev/sda vendor: Fujitsu model: MHZ2160BH size: 149.05 GiB 
Partition:
  ID-1: / size: 22.71 GiB used: 5.73 GiB (25.3%) fs: ext4 dev: /dev/sda5 
  ID-2: swap-1 size: 1.86 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda6 
Sensors:
  Missing: Required tool sensors not installed. Check --recommends 
Repos:
  Active apt repos in: /etc/apt/sources.list 
  1: deb https://deb.debian.org/debian buster main non-free contrib
  2: deb https://deb.debian.org/debian-security buster/updates main contrib non-free
  3: deb https://deb.debian.org/debian buster-updates main contrib non-free
  Active apt repos in: /etc/apt/sources.list.d/bunsen.list 
  1: deb https://pkg.bunsenlabs.org/debian lithium main
Info:
  Processes: 132 Uptime: 1m Init: systemd runlevel: 5 Compilers: gcc: 8.3.0 
  Shell: bash v: 5.0.3 inxi: 3.0.32 

Journalctl output: http://paste.debian.net/1215578/

Same thing happens with `systemctl suspend`

I used to have Windows XP on this machine, and hibernation worked fine on that. It's set up for dual-boot now, but I don't use Windows anymore.

Suspend didn't work out of the box for me, I had to add "resume=UUID=(uuid)" to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub for suspending to disk to happen. So I don't think it will work from the live USB

Offline

#6 2021-10-15 22:13:25

rbh
Moderator
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 1,240

Re: Hibernation not working

Just suspend should work ok without no extra. "sudo systemctl suspend".

Does file /etc/initramfs-tools/conf.d/resume contain the uuid of your swapfile?
If not, you have forgot to run:

$ sudo update-initramfs -u -k all

Nothing in the log about forced filecheck, but it was only last boot.
But you should mash persobal details like MAC-adress and ip-adress...

You can try to update kernel from backports if updating initramfs does not make any difference.


// Regards rbh

Please read before requesting help: Guide to getting help,
Introduction to the Bunsenlabs Lithium Desktop and other help topics under "Help Resources" on the BunsenLabs menu

Offline

#7 2021-10-15 22:24:33

rbh
Moderator
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 1,240

Re: Hibernation not working

Sorry, I was tired, did not think...

Edit /etc/initramfs-tools/conf.d/resume, add if not there;

RESUME=UUID=[uuid of your swap]

Then run update-initramfs


// Regards rbh

Please read before requesting help: Guide to getting help,
Introduction to the Bunsenlabs Lithium Desktop and other help topics under "Help Resources" on the BunsenLabs menu

Offline

#8 2021-10-15 23:05:41

DeepDayze
Like sands through an hourglass...
From: In Linux Land
Registered: 2017-05-28
Posts: 1,357

Re: Hibernation not working

the blkid command will display the UUID's of your devices and partitions. Look for the UUID for your swap partition in the list the command returns then check in  /etc/initramfs-tools/conf.d/resume to verify the if the UUID in:

RESUME=UUID=[uuid of your swap]

matches the UUID that blkid tells you for the swap.

Also make sure your swap partition is somewhat larger than the amount of RAM in your machine. If it is too small suspend/resume will fail.


Real Men Use Linux

Offline

#9 2021-10-16 15:28:41

sleekmason
zoom
Registered: 2018-05-22
Posts: 629
Website

Re: Hibernation not working

bic wrote:

I am using the fake-hwclock package since the hardware clock on my machine doesn't work for some reason (probably the battery died but I haven't checked). To enter hibernation, I am using `systemctl hibernate`. I haven't tried with other distros since I am not sure how to hibernate from a live USB.

Just a couple of ideas/questions.

Doesn't the hardware clock still need to keep track of time during hibernation?  If that is interrupted, does it send a signal to reboot instead?

Are you really talking about/needing hibernation? or just suspend which is now the more common item to use.

If so, is 1GB ram enough these days? Even though swap is involved, does this make a difference somehow?

As others have said, are you able to match the uuid's from:

sudo blkid -l -t TYPE=swap

Then check these for the same:

/etc/fstab    and:
/etc/initramfs-tools/conf.d/resume

Are you having to wait at boot for a minute or two? or does it boot right up?

Testing hibernation in a live environment should be the same.  You will need the live password for root (generally "live"). Every distro should state the "username" and "root" password somewhere easy to see on their download page.

From what I see, your swap size should be fine:)

Last edited by sleekmason (2021-10-16 15:43:24)

Offline

#10 2021-10-16 19:45:54

rbh
Moderator
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 1,240

Re: Hibernation not working

sleekmason wrote:

Are you really talking about/needing hibernation? or just suspend which is now the more common item to use.

Suspend does not work either. I often use suspend duringe the day on my desktop, but prefer using hibernate when snowing heavily (no fun suspend and get powerfailure...) and lets cron hibernate the server every midninght.
So, both hibernate and suspend is good to have.


sudo blkid -l -t TYPE=swap

You do not need sudo for running blkid.

Testing hibernation in a live environment should be the same.

No, only if you have configured your live stick with persistence...
But, suspend should work in live system. Good test to se if the pc is wrongly configured.


// Regards rbh

Please read before requesting help: Guide to getting help,
Introduction to the Bunsenlabs Lithium Desktop and other help topics under "Help Resources" on the BunsenLabs menu

Offline

#11 2021-10-16 19:59:04

sleekmason
zoom
Registered: 2018-05-22
Posts: 629
Website

Re: Hibernation not working

rbh wrote:
sleekmason wrote:

Are you really talking about/needing hibernation? or just suspend which is now the more common item to use.

Suspend does not work either. I often use suspend duringe the day on my desktop, but prefer using hibernate when snowing heavily (no fun suspend and get powerfailure...) and lets cron hibernate the server every midninght.
So, both hibernate and suspend is good to have.


sudo blkid -l -t TYPE=swap

You do not need sudo for running blkid.

Testing hibernation in a live environment should be the same.

No, only if you have configured your live stick with persistence...
But, suspend should work in live system. Good test to se if the pc is wrongly configured.

Hmm. Is not needing root for blkid just in Bunsenlabs for some reason?  I am needing it here or it says "command not found".

Yep, forgot about hibernation needing persistence:)  I haven't bothered in a while but what you say about the weather and such makes sense.

Last edited by sleekmason (2021-10-16 20:21:18)

Offline

#12 2021-10-16 21:09:50

rbh
Moderator
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 1,240

Re: Hibernation not working

sleekmason wrote:

Hmm. Is not needing root for blkid just in Bunsenlabs for some reason?  I am needing it here or it says "command not found".

"lsblk" works without sudo on my lubuntu and debian box.

Maybe you have to adjust path?

~$ which lsblk
/usr/bin/lsblk

/usr/bin, should be in your path.


// Regards rbh

Please read before requesting help: Guide to getting help,
Introduction to the Bunsenlabs Lithium Desktop and other help topics under "Help Resources" on the BunsenLabs menu

Offline

#13 2021-10-16 21:39:07

sleekmason
zoom
Registered: 2018-05-22
Posts: 629
Website

Re: Hibernation not working

rbh wrote:
sleekmason wrote:

Hmm. Is not needing root for blkid just in Bunsenlabs for some reason?  I am needing it here or it says "command not found".

"lsblk" works without sudo on my lubuntu and debian box.

Maybe you have to adjust path?

~$ which lsblk
/usr/bin/lsblk

/usr/bin, should be in your path.

lsblk works fine, and shows /usr/local/bin, just not blkid.

*Edit - Ha! thank you @rbh  Looks like /usr/sbin is not in my path!

Last edited by sleekmason (2021-10-17 17:59:27)

Offline

#14 2021-10-17 00:24:21

DeepDayze
Like sands through an hourglass...
From: In Linux Land
Registered: 2017-05-28
Posts: 1,357

Re: Hibernation not working

sleekmason wrote:
rbh wrote:
sleekmason wrote:

Hmm. Is not needing root for blkid just in Bunsenlabs for some reason?  I am needing it here or it says "command not found".

"lsblk" works without sudo on my lubuntu and debian box.

Maybe you have to adjust path?

~$ which lsblk
/usr/bin/lsblk

/usr/bin, should be in your path.

lsblk works fine, and shows /usr/local/bin, just not blkid.

Yes lsblk only shows your SSD/HDD devices and lists the partitions in each and where they are mounted, but no blkid's. Would been nice if there was a switch that can display the blkid for each partition...

Where it says [SWAP] that's your swap partition when lsblk is used.

Last edited by DeepDayze (2021-10-17 00:25:48)


Real Men Use Linux

Offline

#15 2021-10-17 05:38:55

rbh
Moderator
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 1,240

Re: Hibernation not working

Sorry, I had been sitting in videokonferense all day, not thinking stright...

Neither blkid nor lsblk (with -f) demands sudo.


// Regards rbh

Please read before requesting help: Guide to getting help,
Introduction to the Bunsenlabs Lithium Desktop and other help topics under "Help Resources" on the BunsenLabs menu

Offline

#16 2021-10-17 10:58:11

rbh
Moderator
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 1,240

Re: Hibernation not working

bic wrote:

Suspend didn't work out of the box for me, I had to add "resume=UUID=(uuid)" to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub for suspending to disk to happen. So I don't think it will work from the live USB

I should have commented the above also.
suspending to disk is the same as hibernate. You can also do hybrid suspend, both to ram and disk. Then if powerfailure, it wil resume from disk instead of resumef from ram.

I think you should try to remove resume=UUID=(uuid)" from /etc/default/grub, ad it to /etc/initramfs-tools/conf.d/resume and then update grub and run command "sudo update-initramfs -u -k all"


// Regards rbh

Please read before requesting help: Guide to getting help,
Introduction to the Bunsenlabs Lithium Desktop and other help topics under "Help Resources" on the BunsenLabs menu

Offline

#17 2021-10-19 16:18:55

bic
Member
Registered: 2021-09-09
Posts: 13

Re: Hibernation not working

I should have commented the above also.
suspending to disk is the same as hibernate. You can also do hybrid suspend, both to ram and disk. Then if powerfailure, it wil resume from disk instead of resumef from ram.

This machine is an old laptop with no battery, so suspending to RAM isn't useful to me. I unplug the power when I move so I never need to resume from a state where the machine constantly had power since the last time I used it.

If so, is 1GB ram enough these days?

It's an old machine that I'm still trying to get some use out of. It's enough for basic operations (except for web browsing) but yes, maybe I should recycle this thing soon.

As others have said, are you able to match the uuid's from:

sudo blkid -l -t TYPE=swap

Then check these for the same:

/etc/fstab    and:
/etc/initramfs-tools/conf.d/resume

That partition is listed as swap in /etc/fstab, and is also in /etc/initramfs-tools/conf.d/resume:

RESUME=UUID=...

Offline

#18 2021-10-19 16:33:00

bic
Member
Registered: 2021-09-09
Posts: 13

Re: Hibernation not working

I think you should try to remove resume=UUID=(uuid)" from /etc/default/grub, ad it to /etc/initramfs-tools/conf.d/resume and then update grub and run command "sudo update-initramfs -u -k all"

Same result as before. Though by removing "quiet" from the parameters, I could see that the last message before the hard shutdown was something about disabling console. This was before the phase with the [  Ok  ] messages. I can try to get a picture of the exact message if it would be helpful

Last edited by bic (2021-10-19 16:45:55)

Offline

#19 2021-10-19 16:43:55

sleekmason
zoom
Registered: 2018-05-22
Posts: 629
Website

Re: Hibernation not working

bic wrote:

I should have commented the above also.
suspending to disk is the same as hibernate. You can also do hybrid suspend, both to ram and disk. Then if powerfailure, it wil resume from disk instead of resumef from ram.

This machine is an old laptop with no battery, so suspending to RAM isn't useful to me. I unplug the power when I move so I never need to resume from a state where the machine constantly had power since the last time I used it.

If so, is 1GB ram enough these days?

It's an old machine that I'm still trying to get some use out of. It's enough for basic operations (except for web browsing) but yes, maybe I should recycle this thing soon.

As others have said, are you able to match the uuid's from:

sudo blkid -l -t TYPE=swap

Then check these for the same:

/etc/fstab    and:
/etc/initramfs-tools/conf.d/resume

That partition is listed as swap in /etc/fstab, and is also in /etc/initramfs-tools/conf.d/resume:

RESUME=UUID=...

-------------

okie dokie.  Looks like you are missing some code?

Here is my example:

sleekmason@ai:~$ blkid -l -t TYPE=swap
/dev/nvme0n1p3: UUID="fca07f55-88a8-414d-936f-746f663f8919" TYPE="swap"

and /etc/initrafs-tools/conf.d/resume

RESUME=UUID=fca07f55-88a8-414d-936f-746f663f8919

and /etc/fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# systemd generates mount units based on this file, see systemd.mount(5).
# Please run 'systemctl daemon-reload' after making changes here.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/nvme0n1p5 during installation
UUID=86963628-2e86-4ec5-9697-04e80c263e53 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/nvme0n1p1 during installation
UUID=C6ED-4F30  /boot/efi       vfat    umask=0077      0       1
# /home was on /dev/nvme0n1p6 during installation
UUID=65a5e235-2d21-4ecf-8c11-c7d1de804d0b /home           ext4    defaults        0       2
# swap was on /dev/nvme0n1p3 during installation
UUID=fca07f55-88a8-414d-936f-746f663f8919 none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0

So, replace or add the number from blkid to those files in /etc, and then from a terminal run:

sudo update-initramfs -u -k all

I actually made up a small script some time ago to deal with exactly this:)  https://forums.bunsenlabs.org/viewtopic.php?id=7020
It just grabs your swap uuid and opens all the relevant windows to do the changes.

Offline

#20 2021-10-19 16:51:18

bic
Member
Registered: 2021-09-09
Posts: 13

Re: Hibernation not working

sleekmason wrote:
bic wrote:

I should have commented the above also.
suspending to disk is the same as hibernate. You can also do hybrid suspend, both to ram and disk. Then if powerfailure, it wil resume from disk instead of resumef from ram.

This machine is an old laptop with no battery, so suspending to RAM isn't useful to me. I unplug the power when I move so I never need to resume from a state where the machine constantly had power since the last time I used it.

If so, is 1GB ram enough these days?

It's an old machine that I'm still trying to get some use out of. It's enough for basic operations (except for web browsing) but yes, maybe I should recycle this thing soon.

As others have said, are you able to match the uuid's from:

sudo blkid -l -t TYPE=swap

Then check these for the same:

/etc/fstab    and:
/etc/initramfs-tools/conf.d/resume

That partition is listed as swap in /etc/fstab, and is also in /etc/initramfs-tools/conf.d/resume:

RESUME=UUID=...

-------------

okie dokie.  Looks like you are missing some code?

Here is my example:

sleekmason@ai:~$ blkid -l -t TYPE=swap
/dev/nvme0n1p3: UUID="fca07f55-88a8-414d-936f-746f663f8919" TYPE="swap"

and /etc/initrafs-tools/conf.d/resume

RESUME=UUID=fca07f55-88a8-414d-936f-746f663f8919

and /etc/fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# systemd generates mount units based on this file, see systemd.mount(5).
# Please run 'systemctl daemon-reload' after making changes here.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/nvme0n1p5 during installation
UUID=86963628-2e86-4ec5-9697-04e80c263e53 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/nvme0n1p1 during installation
UUID=C6ED-4F30  /boot/efi       vfat    umask=0077      0       1
# /home was on /dev/nvme0n1p6 during installation
UUID=65a5e235-2d21-4ecf-8c11-c7d1de804d0b /home           ext4    defaults        0       2
# swap was on /dev/nvme0n1p3 during installation
UUID=fca07f55-88a8-414d-936f-746f663f8919 none            swap    sw              0       0
/dev/sr0        /media/cdrom0   udf,iso9660 user,noauto     0       0

So, replace or add the number from blkid to those files in /etc, and then from a terminal run:

sudo update-initramfs -u -k all

I actually made up a small script some time ago to deal with exactly this:)  https://forums.bunsenlabs.org/viewtopic.php?id=7020
It just grabs your swap uuid and opens all the relevant windows to do the changes.

I guess I wasn't clear. The output from my machine is the same:

alex@debian:~$ blkid -l -t TYPE=swap
/dev/sda6: UUID=9d5aabc3-4ac0-4169-8b5e-7e7799a29c67 TYPE=swap PARTUUID=54ac320b-06
alex@debian:~$ cat /etc/initramfs-tools/conf.d/resume 
RESUME=UUID=9d5aabc3-4ac0-4169-8b5e-7e7799a29c67
alex@debian:~$ cat /etc/fstab 
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda5 during installation
UUID=1ed70e6a-04d8-43e5-a762-893416871649 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda6 during installation
UUID=9d5aabc3-4ac0-4169-8b5e-7e7799a29c67 none            swap    sw              0       0

Offline

#21 2021-10-19 17:08:20

unklar
Back to the roots 1.9
From: #! BL
Registered: 2015-10-31
Posts: 1,581

Re: Hibernation not working

^

bic wrote:

Same result as before. Though by removing "quiet" from the parameters, I could see that the last message before the hard shutdown was something about disabling console. This was before the phase with the [  Ok  ] messages. Not sure if that's helpful at all. Is there a way to preserve this output between reboots?

You can use the journal of systemd.
If this is configured correctly for the user, then you can run the commands as the user. If not, you must use root.

For the previous boot (which is what you want):

journalctl -ab-1 | grep -i kill

For the current boot:

journalctl -ab | grep -i kill

For the second to last boot (and so on):

journalctl -ab-2 | grep -i kill

Offline

#22 2021-10-19 17:15:00

sleekmason
zoom
Registered: 2018-05-22
Posts: 629
Website

Re: Hibernation not working

okay, to recap:
You haven't removed any necessary packages, pm-utils power manager etc . .
And you tried adding resume=UUID=9d5aabc3-4ac0-4169-8b5e-7e7799a29c67 to grub and then update-grub.
And the swap # is correct for resume and fstab . . .

Nice puzzle.. .

I am using `systemctl hibernate`.

Do you need/use sudo when calling systemctl hibernate?

Offline

#23 2021-10-19 18:36:45

bic
Member
Registered: 2021-09-09
Posts: 13

Re: Hibernation not working

sleekmason wrote:

okay, to recap:
You haven't removed any necessary packages, pm-utils power manager etc . .
And you tried adding resume=UUID=9d5aabc3-4ac0-4169-8b5e-7e7799a29c67 to grub and then update-grub.
And the swap # is correct for resume and fstab . . .

Nice puzzle.. .

I am using `systemctl hibernate`.

Do you need/use sudo when calling systemctl hibernate?

Yeah, that's exactly what I did. I also tried adding the initramfs above.

No, it works without sudo.

Offline

#24 2021-10-19 20:36:14

rbh
Moderator
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 1,240

Re: Hibernation not working

bic wrote:

This machine is an old laptop with no battery, so suspending to RAM isn't useful to me.

I often suspend to ram my very old laptop with no battery, only 500MB ram, if I leave it alone for some hour...

It's an old machine that I'm still trying to get some use out of. It's enough for basic operations (except for web browsing)

Install midori or dillo... Not suitable for all web-pages though.

but yes, maybe I should recycle this thing soon.

Recycle when the it is worn out...

I guess I wasn't clear. The output from my machine is the same:

Ok, now when we know that, why do you not run hw-probe? Easiest to run it, is to upgrade to bullseye (Debian 11) and run "sudo apt install hw-probe". Read more at https://linux-hardware.org/?view=howto.


// Regards rbh

Please read before requesting help: Guide to getting help,
Introduction to the Bunsenlabs Lithium Desktop and other help topics under "Help Resources" on the BunsenLabs menu

Offline

#25 2021-10-21 21:06:47

bic
Member
Registered: 2021-09-09
Posts: 13

Re: Hibernation not working

Install midori or dillo... Not suitable for all web-pages though.

I do use dillo when I can, but not many pages these days work without javascript

Ok, now when we know that, why do you not run hw-probe? Easiest to run it, is to upgrade to bullseye (Debian 11) and run "sudo apt install hw-probe". Read more at https://linux-hardware.org/?view=howto.

http://linux-hardware.org/?probe=42b7007a7e

I'm running Debian 11 from a USB without a swap partition so I can't test hibernation.

Last edited by bic (2021-10-21 21:07:44)

Offline

Board footer

Powered by FluxBB