You are not logged in.

#1 2021-09-14 09:09:25

glass
New Member
Registered: 2021-09-14
Posts: 4

Fresh installation with auto settings takes long to boot

As a beginner I installed bunsenlabs with auto settings (partitioning method: use entire disk and set up LVM). This lead to long boot time, which as I understand have to do with the following message:

Gave up waiting for suspend/resume device
/dev/mapper/myUsername--vg-root: clean 186635/1455... 

Please help tracing the cause of message and possible fix to it.

Last edited by glass (2021-09-14 09:35:32)

Offline

#2 2021-09-14 09:41:59

rbh
Moderator
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 1,244

Re: Fresh installation with auto settings takes long to boot

glass wrote:

Gave up waiting for suspend/resume device

If you make an internet search for "Gave up waiting for suspend/resume device", you get quit many results.

File /etc/initramfs-tools/conf.d/resume, contains pointer to your swap partition, from where pc restores when resume after hibernating.

Mine says: "RESUME=UUID=1e25aba9-7107-4744-89e9-4fe1b19e11c8"

If you format swap after installing, UUIDof swap will be different. Or if you delete swap, the partiion wont be found.

So, in terminal issue:

$ lsblk -f | grep swap

Compare the result with the resume-file and correct the file.

Last edited by rbh (2021-09-14 09:42:43)


// Regards rbh

Please read before requesting help: Guide to getting help,
Introduction to the Bunsenlabs Lithium Desktop and other help topics under "Help Resources" on the BunsenLabs menu

Offline

#3 2021-09-14 09:56:58

glass
New Member
Registered: 2021-09-14
Posts: 4

Re: Fresh installation with auto settings takes long to boot

rbh wrote:

If you make an internet search for "Gave up waiting for suspend/resume device", you get quit many results.

File /etc/initramfs-tools/conf.d/resume, contains pointer to your swap partition, from where pc restores when resume after hibernating.

Mine says: "RESUME=UUID=1e25aba9-7107-4744-89e9-4fe1b19e11c8"

If you format swap after installing, UUIDof swap will be different. Or if you delete swap, the partiion wont be found.

So, in terminal issue:

$ lsblk -f | grep swap

Compare the result with the resume-file and correct the file.

Thanks for reply. In my case both "/etc/initramfs-tools/conf.d/resume" and "lsblk -f | grep swap" has the same number. Haven't format nor deleted swap after installtion.. At this stage I'just reinstall and see if the error persists.

Last edited by glass (2021-09-14 09:59:45)

Offline

#4 2021-09-14 11:31:06

glass
New Member
Registered: 2021-09-14
Posts: 4

Re: Fresh installation with auto settings takes long to boot

Now installed with encrypted LVM option. Full message:

Volume group "name-vg" not found
Cannot process volume group name-vg
Please unlock disk sda5_crypt:
/dev/sdb: open failed: No medium found
 /dev/sdb: open failed: No medium found
cryptsetup: sda5_crypt: set up successfully

Offline

#5 2021-09-14 11:46:20

rbh
Moderator
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 1,244

Re: Fresh installation with auto settings takes long to boot

glass wrote:

Full message:

Full message of what?

You give very little information.
If you are installing with encrypted LVM, you ought to know what info to give to be able to track down your problems.
Maybe you should use a more standard aproach?

Me, I seldom use LVM, have no clue what has gone wrong.


// Regards rbh

Please read before requesting help: Guide to getting help,
Introduction to the Bunsenlabs Lithium Desktop and other help topics under "Help Resources" on the BunsenLabs menu

Offline

#6 2021-09-14 13:41:26

glass
New Member
Registered: 2021-09-14
Posts: 4

Re: Fresh installation with auto settings takes long to boot

Just that installing crungbangplusplus with exact settings results in no erros, that is why i reached out.
I'll stick to basics and partition disk without lvm.

Offline

#7 2021-10-07 15:48:24

cpicanco
Member
From: Brazil
Registered: 2015-10-15
Posts: 8
Website

Re: Fresh installation with auto settings takes long to boot

Hi, I am also getting the same message after a fresh install of LVM partitions. I did research about the problem and found that you can hide the message, you can avoid the message, but I have not come to a robust solution for it. What I mean by "robust" is a solution that does not have collateral issues (for example, breaking hibernation, disabling acpi, and so on).

I am doing a fresh install right now and would really appreciate any help to solve this.

Last edited by cpicanco (2021-10-07 15:51:07)

Offline

#8 2021-10-07 16:06:55

cpicanco
Member
From: Brazil
Registered: 2015-10-15
Posts: 8
Website

Re: Fresh installation with auto settings takes long to boot

Here are some information about how I found this issue. I am used to install Bunsen Labs in a hard drive for my personal desktop pc and just avoiding this message (and its long waiting time ~1min) by editing and updating grub with acpi=off. Today I installed Bunsen Labs Lithium-3 in an external driver. I was expecting the issue and it did happened again. At this point, I was thinking "Humm, maybe this old pc and its BIOS is a piece of corrupted and broken shit lol". However I was a little bit surprised when I boot my new fresh Bunsen Labs on external USB driver and saw the same error happening again. Then I thought "Hummm, wtf, are you really thinking that this shit is spreading all the way around to this brand new i5 8th gen notebook BIOS too, my dear?".

Of course, I don't have a clue about what kind of information you need to help me on this issue guys. I am just trying to laugh about it right now.

Last edited by cpicanco (2021-10-07 16:14:12)

Offline

#9 2021-10-07 17:01:51

cpicanco
Member
From: Brazil
Registered: 2015-10-15
Posts: 8
Website

Re: Fresh installation with auto settings takes long to boot

Ok, I must say that I had mixed up stuff here. I am sorry. The acpi value is not related to this and solves another thing.

So, I was thinking carefully about my installation process and now I have a clue about why the blocking wait message is happening. OP said that he used default configurations during LVM install. In my case, during the installation (the graphical one), I edited LVM partitions. I deleted the swap partition and created it again with increased size. Then I deleted the root partition and created it again to increase its size too. However, I would not expect this blocking message, because the installation process includes calls to update UUID in boot and system files.

Offline

Board footer

Powered by FluxBB