You are not logged in.

#1 2021-09-11 20:58:14

ututo
Member
Registered: 2015-09-29
Posts: 294

Starting Qtile on Bunsenlabs

...And I come back to you now, at the turn of the tide...seeking for wisdom my fellow *nixers.

So, I was trying to install qtile from source on bunsenlabs lithium. I managed to follow linuxdabbler's instructions without any issues until... I've to create a xsession entry in order to run qtile.

I've been following the documentation. I created a qtile.desktop file in /usr/share/xsessions but i was unable to start qtile from lightdm.

I try to log in but i get a 'file not found' error and it falls back to defaults, entering bunsenlabs default session.

The official documentations says that if I'm using a x session manager i've to create a custom qtile.desktop but with Exec=/etc/X11/xsession (which i did) and then, create my own ~/.xsession file. And this is where i'm stuck. I don't know what to put in ~/.xsession in order to work in BL.

Any ideas? Have you tried qtile on bunsenlabs before? Any guidence will be much appreciated

cheers


BunsenLabs on deviantArt
Don't touch my git!

Offline

#2 2021-09-11 22:45:18

twoion
一期一会
Registered: 2015-08-10
Posts: 3,355

Re: Starting Qtile on Bunsenlabs

.xsession can only contain an

exec /path/to/qtile

in which case the session would exit immediately as soon as qtile quits. .xession in the case of simple WMs is to be set up like for any other minimal WM, like dwm. Personally, I put into that file:

# set up various things
systemctl --user start dwm.service
# tear down various things

which ran a unit that started dwm. It really is a shell script which, as soon as it exits, will terminate the session. The shell script is executed with all environment variables and arguments that the default xsession-type session provides it.

Online

#3 2021-09-12 10:00:38

brontosaurusrex
Middle Office
Registered: 2015-09-29
Posts: 2,381
Website

Re: Starting Qtile on Bunsenlabs

I'am obviosly not an expert in this, but on pure debian with lightdm there appears to be
/usr/share/xsessions/qtile.desktop with

[Desktop Entry]
Name=Qtile
Comment=Qtile Session
Exec=/home/b/.local/bin/qtile start
Type=Application
Keywords=wm;tiling

There is no file named ~/.xssesion

And this alows selecting openbox or qtile when logging in with lightdm.

Last edited by brontosaurusrex (2021-09-12 10:03:14)

Offline

#4 2021-09-12 14:35:11

ututo
Member
Registered: 2015-09-29
Posts: 294

Re: Starting Qtile on Bunsenlabs

thanks @twoion and @bronto for your responses.

I have that [desktop entry] in my /usr/share/xsessions. LightDM allows me to select Qtile from the dropdown menu, but whenever I try to login I get this error message:

Xsession: unable to launch "/home/ututo/.local/bin/qtile start" X session ---
"/home/ututo/.local/bin/qtile start" not found: falling back to default session.

the qtile file is in did in that directory. I tried changing the exec path to

Exec=/home/ututo/.local/bin/qtile
Exec=python3 /home/ututo/.local/bin/qtile
Exec=/home/ututo/.local/bin/qtile start

but i get that error message or loop back to the login manager.

I'm clearly missing something but I don't know what could it be.

Last edited by ututo (2021-09-12 14:36:10)


BunsenLabs on deviantArt
Don't touch my git!

Offline

#5 2021-09-12 14:54:02

eight.bit.al
Member
From: Prison
Registered: 2015-10-01
Posts: 1,102

Re: Starting Qtile on Bunsenlabs

OT
@ututo, thanks for the wallpapers. smile

8bit


If art is how we decorate space, music is how we decorate time.

Offline

#6 2021-09-12 15:03:10

ututo
Member
Registered: 2015-09-29
Posts: 294

Re: Starting Qtile on Bunsenlabs

eight.bit.al wrote:

OT
@ututo, thanks for the wallpapers. smile

8bit

you're welcome!


BunsenLabs on deviantArt
Don't touch my git!

Offline

#7 2021-09-12 16:37:59

brontosaurusrex
Middle Office
Registered: 2015-09-29
Posts: 2,381
Website

Re: Starting Qtile on Bunsenlabs

Anything of importance in
cat ~/.local/share/qtile/qtile.log #?

Offline

#8 2021-09-12 18:59:41

ututo
Member
Registered: 2015-09-29
Posts: 294

Re: Starting Qtile on Bunsenlabs

there's no log file in there.


BunsenLabs on deviantArt
Don't touch my git!

Offline

#9 2021-09-13 07:57:38

brontosaurusrex
Middle Office
Registered: 2015-09-29
Posts: 2,381
Website

Re: Starting Qtile on Bunsenlabs

I guess that means it a. doesn't even attempt to start b. or the path to qtile is wrong c. or you config defines some other log file?

What happens if you just do

/path/to/qtile start

From openbox it should just complain that another wm is already running.

Offline

#10 2021-09-17 00:23:23

ututo
Member
Registered: 2015-09-29
Posts: 294

Re: Starting Qtile on Bunsenlabs

Hi, @bronto!
If I do what you suggest i get:

~/.local/bin qtile start
2021-09-16 21:14:02,003 libqtile core.py:__init__():L106  not starting; existing window manager Openbox
Traceback (most recent call last):
  File "/home/ututo/.local/bin/qtile", line 10, in <module>
    sys.exit(main())
  File "/home/ututo/.local/lib/python3.7/site-packages/libqtile/scripts/main.py", line 55, in main
    options.func(options)
  File "/home/ututo/.local/lib/python3.7/site-packages/libqtile/scripts/start.py", line 87, in start
    q = make_qtile(options)
  File "/home/ututo/.local/lib/python3.7/site-packages/libqtile/scripts/start.py", line 50, in make_qtile
    kore = libqtile.backend.get_core(options.backend)
  File "/home/ututo/.local/lib/python3.7/site-packages/libqtile/backend/__init__.py", line 15, in get_core
    return importlib.import_module(f"libqtile.backend.{backend}.core").Core(*args)
  File "/home/ututo/.local/lib/python3.7/site-packages/libqtile/backend/x11/core.py", line 107, in __init__
    raise ExistingWMException(existing_wmname)
libqtile.backend.x11.core.ExistingWMException: Openbox

another thing I did was to add ~/.local/bin to PATH by appending

export PATH="$HOME/.local/bin:$PATH"

to my .bashrc, but nothing seems to work so far


BunsenLabs on deviantArt
Don't touch my git!

Offline

#11 2021-09-17 00:43:35

ututo
Member
Registered: 2015-09-29
Posts: 294

Re: Starting Qtile on Bunsenlabs

...and this is my ~/.xsession-errors

Xsession: X session started for ututo at Thu 16 Sep 2021 09:09:19 PM -03
Xsession: unable to launch "/home/ututo/.local/bin/qtile start" X session --- 
"/home/ututo/.local/bin/qtile start" not found; falling back to default 
session.
localuser:ututo being added to access control list
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: warning: error sending to systemd: org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
dbus-update-activation-environment: setting USER=ututo
dbus-update-activation-environment: setting LANGUAGE=en_US:en
dbus-update-activation-environment: setting XDG_SESSION_TYPE=x11
dbus-update-activation-environment: setting HOME=/home/ututo
dbus-update-activation-environment: setting DESKTOP_SESSION=qtile
dbus-update-activation-environment: setting XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
dbus-update-activation-environment: setting DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-0EkdVNehu6,guid=d24e2e08747bea6c42f6c6876143dcbc
dbus-update-activation-environment: setting QT_QPA_PLATFORMTHEME=gtk2
dbus-update-activation-environment: setting LOGNAME=ututo
dbus-update-activation-environment: setting XDG_SESSION_CLASS=user
dbus-update-activation-environment: setting PATH=/home/ututo/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games
dbus-update-activation-environment: setting XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session7
dbus-update-activation-environment: setting XDG_RUNTIME_DIR=/run/user/1000
dbus-update-activation-environment: setting DISPLAY=:0
dbus-update-activation-environment: setting LANG=en_US.UTF-8
dbus-update-activation-environment: setting XDG_SESSION_DESKTOP=qtile
dbus-update-activation-environment: setting XAUTHORITY=/home/ututo/.Xauthority
dbus-update-activation-environment: setting XDG_GREETER_DATA_DIR=/var/lib/lightdm/data/ututo
dbus-update-activation-environment: setting SHELL=/bin/bash
dbus-update-activation-environment: setting GDMSESSION=qtile
dbus-update-activation-environment: setting QT_ACCESSIBILITY=1
dbus-update-activation-environment: setting GPG_AGENT_INFO=/run/user/1000/gnupg/S.gpg-agent:0:1
dbus-update-activation-environment: setting PWD=/home/ututo
dbus-update-activation-environment: warning: error sending to systemd: org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.freedesktop.systemd1 exited with status 1
export DBUS_SESSION_BUS_ADDRESS='unix:abstract=/tmp/dbus-0EkdVNehu6,guid=d24e2e08747bea6c42f6c6876143dcbc'
export DESKTOP_SESSION='qtile'
export DISPLAY=':0'
export GDMSESSION='qtile'
export GPG_AGENT_INFO='/run/user/1000/gnupg/S.gpg-agent:0:1'
export HOME='/home/ututo'
export LANG='en_US.UTF-8'
export LANGUAGE='en_US:en'
export LOGNAME='ututo'
export PATH='/home/ututo/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games'
export PWD='/home/ututo'
export QT_ACCESSIBILITY='1'
export QT_QPA_PLATFORMTHEME='gtk2'
export SHELL='/bin/bash'/.Xauthority'
export XDG_GREETER_DATA_DIR='/var/lib/lightdm/data/ututo'
export XDG_RUNTIME_DIR='/run/user/1000'
export XDG_SEAT='seat0'
export XDG_SEAT_PATH='/org/freedesktop/DisplayManager/Seat0'
export XDG_SESSION_CLASS='user'
export XDG_SESSION_DESKTOP='qtile'
export XDG_SESSION_ID='20'
export XDG_SESSION_PATH='/org/freedesktop/DisplayManager/Session7'
export XDG_SESSION_TYPE='x11'
export XDG_VTNR='7'
4858
Unable to find a synaptics device.

(polkit-gnome-authentication-agent-1:4953): dbind-WARNING **: 21:09:32.472: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-4F0AmAGa9o: Connection refused
/usr/bin/bl-tint2restart: no tint2 processes running

(pnmixer:4968): dbind-WARNING **: 21:09:33.538: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-4F0AmAGa9o: Connection refused
conky: desktop window (110) is root window
conky: window type - desktop
conky: drawing to created window (0x1a00001)
conky: drawing to double buffer
conky: forked to background, pid is 4986

(clipit:4970): dbind-WARNING **: 21:09:33.551: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-4F0AmAGa9o: Connection refused


(thunar:4976): dbind-WARNING **: 21:09:33.596: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-4F0AmAGa9o: Connection refused
[1;33mwarning[0m: /build/pnmixer-s2Hxqg/pnmixer-0.7.2/src/ui-tray-icon.c: Unable to lookup icon 'audio-volume-off'
dbus-daemon[5032]: Activating service name='org.a11y.atspi.Registry' requested by ':1.0' (uid=1000 pid=5035 comm="xfce4-power-manager ")
dbus-daemon[5032]: Successfully activated service 'org.a11y.atspi.Registry'
SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
[1;33mwarning[0m: /build/pnmixer-s2Hxqg/pnmixer-0.7.2/src/ui-tray-icon.c: Unable to lookup icon 'audio-volume-off'

(clipit:4970): Gdk-CRITICAL **: 21:09:35.590: gdk_window_thaw_toplevel_updates: assertion 'window->update_and_descendants_freeze_count > 0' failed
warn: found old lockfile; lockfile removed
<window.Window object at 0x7f90403bed38 (terminatorlib+window+Window at 0x1966260)> is not in registered window list

BunsenLabs on deviantArt
Don't touch my git!

Offline

#12 2021-09-17 13:41:20

PackRat
jgmenu user Numero Uno
Registered: 2015-10-02
Posts: 1,470

Re: Starting Qtile on Bunsenlabs

"/home/ututo/.local/bin/qtile start" not found; falling back to default  session.

dbus-update-activation-environment: setting PATH=/home/ututo/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games

Some sort of issue with your PATH?

Have you tried placing the qtile binary in /usr/bin or /usr/local/bin and try starting it from there?


You must unlearn what you have learned.
    -- yoda

Offline

#13 2021-09-18 01:53:52

ututo
Member
Registered: 2015-09-29
Posts: 294

Re: Starting Qtile on Bunsenlabs

I tried placing the qtile binary in both /usr/bin and /usr/local/bin directories. I get the same error messages. File not found, falling back to default session.

Another thing I tried was to place the binary in /home/ututo/bin. In this case, when i try to login, it doesn't show any message but it loops back to the login manager.

In each case mentioned above, I edited the qtile.desktop file and pointed Exec= to the 'right' directory.

no luck so far...


BunsenLabs on deviantArt
Don't touch my git!

Offline

#14 2021-09-18 02:55:57

DeepDayze
Like sands through an hourglass...
From: In Linux Land
Registered: 2017-05-28
Posts: 1,357

Re: Starting Qtile on Bunsenlabs

ututo wrote:

I tried placing the qtile binary in both /usr/bin and /usr/local/bin directories. I get the same error messages. File not found, falling back to default session.

Another thing I tried was to place the binary in /home/ututo/bin. In this case, when i try to login, it doesn't show any message but it loops back to the login manager.

In each case mentioned above, I edited the qtile.desktop file and pointed Exec= to the 'right' directory.

no luck so far...

Why not reach out to the developer for help?


Real Men Use Linux

Offline

#15 2021-09-24 02:04:57

ututo
Member
Registered: 2015-09-29
Posts: 294

Re: Starting Qtile on Bunsenlabs

I don't think it's a qtile problem. I'm experiencing the same issues with i3-gaps and spectrwm.
Anyways. I won't continue delving into this matter. I think it ain't worth it.

I really appreciate the help and time you have taken to answer me.-


BunsenLabs on deviantArt
Don't touch my git!

Offline

Board footer

Powered by FluxBB