You are not logged in.

#1 2021-08-28 18:18:56

cpicanco
Member
From: Brazil
Registered: 2015-10-15
Posts: 8
Website

I was debugging hibernation and now "systemctl poweroff" just halts

Hi everyone, I known, I known. I should not be playing with kernel commands. But I was just trying to hibernate my desktop machine!  cry

I was following this instructions here: https://www.kernel.org/doc/html/latest/ … gging.html

My setup have enough swap memory and hibernation do works but right now I must press the power button manually after the hibernation command finishes its job (i.e., with my machine, when the processing led turn off and you can hear a quiet "click").

But now poweroff does not, it just halts the system.

So, please, can you help me to setup my /sys/power/disk and /sys/power/state to their default values?

Thanks in advance!

Offline

#2 2021-09-03 09:32:35

rbh
Moderator
From: Sweden/Vasterbotten/Rusfors
Registered: 2016-08-11
Posts: 1,236

Re: I was debugging hibernation and now "systemctl poweroff" just halts

cpicanco wrote:

So, please, can you help me to setup my /sys/power/disk and /sys/power/state to their default values?

On my desktop (use suspend daily, hibernation works), reinstalled in in june and on an fresh installed lithium vm, are the contents:

/sys/power/disk:
[platform] shutdown reboot suspend test_resume

/sys/power/state:
freeze standby mem disk

btw, If changing systemfiles, allways backup before...

Last edited by rbh (2021-09-03 09:33:28)


// Regards rbh

Please read before requesting help: Guide to getting help,
Introduction to the Bunsenlabs Lithium Desktop and other help topics under "Help Resources" on the BunsenLabs menu

Offline

#3 2021-09-04 23:18:20

cpicanco
Member
From: Brazil
Registered: 2015-10-15
Posts: 8
Website

Re: I was debugging hibernation and now "systemctl poweroff" just halts

Hi everyone,

Turns out  that I had a problem related to my bios. In fact, you can't edit files like /sys/power/disk. You are allowed to change its existing options only. Those files are bios specific.

I solved my problem changing my

acpi=off

to

acpi=noirq

in boot options, as described here:

https://askubuntu.com/questions/632591/ … just-halts

Best regards,
R

Offline

Board footer

Powered by FluxBB