You are not logged in.

#1 2021-08-01 08:07:28

jjbackagain
Member
Registered: 2018-06-06
Posts: 26

My keybinds have stopped working? The process dose not seem to start?

My keybinding have stopped working.. I am on a near raw install... just started updating it... this is my current keybinding file...

# For the benefit of emacs users: -*- shell-script -*-
###########################
# xbindkeys configuration #
###########################
#
# Version: 1.8.6
#
# This file is adapted for BunsenLabs Linux.
#

# NOTE: There is a gui available for editing keybinds - 'xbindkeys-config'.
# However we don't recommend its installation and use because it has some bugs.

# The format of a command line is:
#    "command to start"
#       associated key
#

# To identify a key, you can run 'xbindkeys --key' or
# 'xbindkeys --multikey' in a terminal
# and put one of the two output lines in this file.

# List of modifiers:
#   Release, Control, Shift, Mod1 (Alt), Mod2 (NumLock),
#   Mod3 (CapsLock), Mod4, Mod5 (Scroll).
#
# Mod4 is also known as the Super or Windows key.
#
# The release modifier is not a standard X modifier, but you can
# use it if you want to catch release events instead of press events.
#
# By default, xbindkeys does not pay attention to the modifiers
# NumLock, CapsLock and ScrollLock.
# Uncomment the lines below if you want to pay attention to them.
#
#keystate_numlock = enable
#keystate_capslock = enable
#keystate_scrolllock= enable

# NOTE xbindkeys reloads its configuration file each time it has changed.
# If you want to force it to reload its configuration file,
# you can send a HUP signal:
#
#       killall -HUP xbindkeys
#
# Or if that's not enough, a full restart:
#
#       
#
# (Sometimes this is needed.)
# When a HUP signal is sent to xbindkeys,
# changes in $HOME/.xbindkeysrc take effect only after moving the mouse.

# See 'man xbindkeys' for more information.

# Show main menu
"jgmenu_run"
    Alt + F2

# Run Program
"gmrun"
    Alt + F3

# Show dmenu
"~/.config/dmenu/dmenu-bind.sh"
    Mod4 + Space

# Terminal
"x-terminal-emulator"
    Mod4 + t

# Web Browser
"x-www-browser"
    Mod4 + w

# File Manager
"bl-file-manager"
    Mod4 + f

# Editor
"bl-text-editor"
    Mod4 + e

# Media Player
"bl-media-player"
    Mod4 + m

# Volume
"pavucontrol"
    Mod4 + v

# htop task manager
"x-terminal-emulator -T 'htop task manager' -e htop"
    Mod4 + h

# Lock Screen
"bl-lock"
    Mod4 + l

# Logout
"bl-exit"
    Mod4 + x

# Kill a Window
"xkill"
    Mod4 + Escape

# Print Screen (xfce)
"xfce4-screenshooter"
    Print

# Print Screen (scrot)
"scrot '%Y-%m-%d--%s_$wx$h_scrot.png' -e 'mv $f ~/Pictures/screenshots/ ; bl-image-viewer ~/Pictures/screenshots/$f'"
    Alt + Print

# Scrot with 10s delay
"scrot -d 10 '%Y-%m-%d--%s_$wx$h_scrot.png' -e 'mv $f ~/Pictures/screenshots/ ; bl-image-viewer ~/Pictures/screenshots/$f'"
    Control + Alt + Print

# Show xbindkeys settings
# (install tk to use this)
#"xbindkeys_show"
#    Control + Shift + q

##################################
# End of xbindkeys configuration #
##################################

All I did was try to change alt+F2 to mod1+Space and mod1+space to Alt+F2...  but as soon as I did that the thing would not load... if I try the commands in the file

killall -HUP xbindkeys
xbindkeys: no process found

or

pkill -x xbindkeys
xbindkeys_autostart

and these do not make it work.

In my Autoexec it still has "xbindkeys_autostart" in it and stuff...

## BunsenLabs autostart
## ====================
## When you login to your BunsenLabs session, this autostart script
## will be executed to launch any applications
## you want to run at startup.
##
## NB, like openbox's autostart script, this uses the default shell,
## so "bashisms" are not supported.
##
## (Environment variables are set in ~/.config/bunsen/environment.)
##
## Note: some programs, such as 'nm-applet' are run via XDG autostart,
## from .desktop files in /etc/xdg/autostart and ~/.config/autostart.
## To disable this, comment out the last line in this file:
## "bl-xdg-autostart"
##
## Run 'bl-xdg-autostart --list' to list any XDG autostarted programs.
##
## If you do something cool with your autostart script and you think others
## could benefit from your hack, please consider sharing it at:
## http://forums.bunsenlabs.org (registration required)
##

## WINDOW MANAGER
## Do not edit the next line unless you have also installed any
## necessary other programs for the different window manager,
## and edited the window-manager-dependent section later in this file.
## Use the window manager's actual command, not name:
window_manager=openbox

# test if chosen window manager is actually running (you should probably not edit this line)
pgrep -x -u "$USER" "$window_manager" || { echo "$0: Window manager $window_manager is not running." >&2 ; exit 1;}

### SETTINGS START

# start keybinds daemon
# (If this clashes with some window manager's keybinds,
# you can move it to the window-manager-dependent section below.)
xbindkeys_autostart

## Turn on/off system beep.
xset b off

## Set keyboard settings - 250 ms delay and 25 cps (characters per second) repeat rate.
## Adjust the values according to your preferances.
xset r rate 250 25

## Add keyboard mapping.
#xmodmap -e "keysym Insert = Multi_key"

## Disable CapsLock
#setxkbmap -option ctrl:nocaps
setxkbmap -option caps:swapescape
# alternative: use as compose key
#setxkbmap -option compose:caps

### TOUCHPAD: comment out the next two entries if you don't have one

## Configure touchpad. See 'man synaptics' for more info.
## (Now might be using libinput instead of synaptics.)
synclient VertEdgeScroll=1 HorizEdgeScroll=1 TapButton1=1 2>/dev/null

## Disable touchpad while typing
syndaemon -i .5 -K -t -R -d &

### TOUCHPAD END

### SETTINGS END

## GNOME PolicyKit authentication
/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 &

#######################################################
######## window-manager-dependent applications ########
# these will be things like panels, conky, wallpaper etc

case "$window_manager" in
openbox)
    ## The following applications will only be started in an openbox session.
    ## Add a new clause for your window manager, if different.

    ## Alias Super key to Super+Space for single-key menu.
    ## See 'man xcape' for other possibilities.
    xcape -e 'Super_L=Super_L|space'

    ## Set a wallpaper
    nitrogen --restore

    ## Compton
    ## NOTE: composition must be started before tint2
#    bl-compositor --start

    ## Start the tint2 session (the default tint2 will run if no sessions have been set)
    ( sleep 2; bl-tint2-session ) &

    ## Start the Conky session (the default conkyrc will run if no sessions have been set)
    bl-conky-session --autostart &
    ;;
    # End of openbox application group.

## Vague possibility for XFCE window manager
#xfwm4)
#   xcape -e 'Super_L=Super_L|space'
#   (sleep 3; xfdesktop) &
#   bl-tint2-session
#   bl-conky-session --autostart &
#   ;;

## Vague possibility for Awesome window manager
#awesome)
#    bl-compositor --start
#    xfce4-panel &
#    bl-conky-session --autostart &
#    ;;

esac

####### end of window-manager-dependent section #######
#######################################################

### Following entries apply to all window managers: ###

## Volume control for systray
pnmixer &

## Start Clipboard manager
clipit &

## Start Thunar Daemon, if set as bl-file-manager
if [ "$(readlink -f $(which bl-file-manager))" = "$(which thunar)" ]
then
    thunar --daemon &
fi

## bl-welcome - post-installation script, will not run in a live session
## and only runs once. Safe to remove.
(sleep 10; bl-welcome --firstrun) &

## bl-fortune - have the system come up with a little adage
## These quotes are from the #! and BL forums.
## Many of them are from the 'Off Topic' subforums of those sites,
## so they are likely to be abstract, out-of-context...
## ... and possibly Not Safe For Work, children, or your mental health in general.
## Uncomment the following line to enable this (adjust the sleep seconds to taste).
#(sleep 20; bl-fortune) &

## Run the XDG autostart stuff. This requires python3-xdg to be installed.
## See bl-xdg-autostart --list for list of autostarted applications.
bl-xdg-autostart

Is there a github or something I can get the default keybinding file.. I didn't back it up before editing it.... I am super confused.. I think it is not loading as there is a formatting error... but I can not seem to work out what it is.

Last edited by jjbackagain (2021-08-01 08:08:45)

Offline

#2 2021-08-02 04:33:53

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 8,281
Website

Re: My keybinds have stopped working? The process dose not seem to start?

The default user configs are stored in /usr/share/bunsen/skel so the default xbindkeys file is /usr/share/bunsen/skel/.xbindkeysrc

Github: https://github.com/BunsenLabs/bunsen-co … thium/skel


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Offline

#3 2021-08-03 20:46:49

jjbackagain
Member
Registered: 2018-06-06
Posts: 26

Re: My keybinds have stopped working? The process dose not seem to start?

johnraff wrote:

The default user configs are stored in /usr/share/bunsen/skel so the default xbindkeys file is /usr/share/bunsen/skel/.xbindkeysrc

Github: https://github.com/BunsenLabs/bunsen-co … thium/skel

I ended up just doing a fresh install lol... but I will have to adjust the hotkeys and conky at some point.. so I'll leave this thread unsolved in case I have questions then... thanks for the reply!

Offline

#4 2021-08-03 21:14:44

jjbackagain
Member
Registered: 2018-06-06
Posts: 26

Re: My keybinds have stopped working? The process dose not seem to start?

Also, super+up/down/left/right sorta snap the window to the top/bottom/left/right side of the screen, but I can not see these in the keybind file or a way to maximize...

Offline

#5 2021-08-04 05:46:28

johnraff
nullglob
From: Nagoya, Japan
Registered: 2015-09-09
Posts: 8,281
Website

Re: My keybinds have stopped working? The process dose not seem to start?

^for window keybinds (as opposed to launching applications) check out menu>Preferences>Openbox>edit bl.xml


...elevator in the Brain Hotel, broken down but just as well...
( a boring Japan blog (currently paused), idle Twitterings and GitStuff )

Introduction to the Bunsenlabs Lithium Desktop

Offline

Board footer

Powered by FluxBB